summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/mips-sources/mips-sources-2.6.27.21-r1.ebuild')
-rw-r--r--sys-kernel/mips-sources/mips-sources-2.6.27.21-r1.ebuild50
1 files changed, 28 insertions, 22 deletions
diff --git a/sys-kernel/mips-sources/mips-sources-2.6.27.21-r1.ebuild b/sys-kernel/mips-sources/mips-sources-2.6.27.21-r1.ebuild
index 7d14a85ae03c..8d0e677f252a 100644
--- a/sys-kernel/mips-sources/mips-sources-2.6.27.21-r1.ebuild
+++ b/sys-kernel/mips-sources/mips-sources-2.6.27.21-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-2.6.27.21-r1.ebuild,v 1.3 2010/01/10 09:48:34 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-2.6.27.21-r1.ebuild,v 1.4 2010/02/13 19:07:33 kumba Exp $
# INCLUDED:
# 1) linux sources from kernel.org
@@ -138,31 +138,37 @@ eblit-pkg() {
#//------------------------------------------------------------------------------
load_eblit_funcs() {
- # All are in ${FILESDIR}/eblits
- # If a message for a given machine needs to change,
- # then we create a new eblit and increment the
- # version and reference it here.
- [ -n "${MIPS_SOURCES_EBLITS_LOADED}" ] && return;
- eblit-include err_disabled_mach v1
- eblit-include err_only_one_mach_allowed v1
- eblit-include show_ip22_info v1
- eblit-include show_ip27_info v1
- eblit-include show_ip28_info v1
- eblit-include show_ip30_info v1
- eblit-include show_ip32_info v1
- eblit-include show_cobalt_info v1
-
- # This makes sure pkg_setup & pkg_postinst gets into any binpkg.
- # Neccessary because we can't guarantee FILESDIR is around for binpkgs.
- eblit-pkg setup v1
- eblit-pkg postinst v1
- MIPS_SOURCES_EBLITS_LOADED=1
+ # This is a sanity check to avoid QA issues. It prevents
+ # eblits from being referenced during metadata operations.
+ [ -n "${MIPS_SOURCES_EBLITS_LOADED}" ] && return
+
+ # All are in ${FILESDIR}/eblits
+ # If a message for a given machine needs to change,
+ # then we create a new eblit and increment the
+ # version and reference it here.
+ eblit-include err_disabled_mach v1
+ eblit-include err_only_one_mach_allowed v1
+ eblit-include show_ip22_info v1
+ eblit-include show_ip27_info v1
+ eblit-include show_ip28_info v1
+ eblit-include show_ip30_info v1
+ eblit-include show_ip32_info v1
+ eblit-include show_cobalt_info v1
+
+ # This makes sure pkg_setup & pkg_postinst gets into any binpkg.
+ # Neccessary because we can't guarantee FILESDIR is around for binpkgs.
+ eblit-pkg setup v1
+ eblit-pkg postinst v1
+
+ # Eblit load complete
+ MIPS_SOURCES_EBLITS_LOADED=1
}
pkg_setup() {
- load_eblit_funcs
- pkg_setup
+ load_eblit_funcs
+ pkg_setup
}
+
src_unpack() { eblit-run src_unpack v1 ; }
#//------------------------------------------------------------------------------