summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/mozilla-firefox/mozilla-firefox-2.0.0.6.ebuild')
-rw-r--r--www-client/mozilla-firefox/mozilla-firefox-2.0.0.6.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/www-client/mozilla-firefox/mozilla-firefox-2.0.0.6.ebuild b/www-client/mozilla-firefox/mozilla-firefox-2.0.0.6.ebuild
index adef4e5d78f8..0da2dd2e8b65 100644
--- a/www-client/mozilla-firefox/mozilla-firefox-2.0.0.6.ebuild
+++ b/www-client/mozilla-firefox/mozilla-firefox-2.0.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/mozilla-firefox-2.0.0.6.ebuild,v 1.7 2007/08/05 15:57:45 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/mozilla-firefox-2.0.0.6.ebuild,v 1.8 2007/08/09 11:04:22 armin76 Exp $
WANT_AUTOCONF="2.1"
@@ -191,9 +191,9 @@ src_compile() {
# requirements while compiling
edit_makefiles
- # Anything more than -j1 will still break things, please don't remove until
- # you're sure upstream has fixed this. See bug #135420.
- emake -j1 || die
+ # Should the build use multiprocessing? Not enabled by default, as it tends to break
+ [ "${WANT_MP}" = "true" ] && jobs=${MAKEOPTS} || jobs="-j1"
+ emake ${jobs} || die
}
pkg_preinst() {