summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client')
-rw-r--r--www-client/mozilla-firefox/ChangeLog7
-rw-r--r--www-client/mozilla-firefox/metadata.xml8
-rw-r--r--www-client/mozilla-firefox/mozilla-firefox-2.0.0.19.ebuild312
-rw-r--r--www-client/mozilla-firefox/mozilla-firefox-3.5.8.ebuild276
-rw-r--r--www-client/mozilla-firefox/mozilla-firefox-3.6.7.ebuild287
5 files changed, 6 insertions, 884 deletions
diff --git a/www-client/mozilla-firefox/ChangeLog b/www-client/mozilla-firefox/ChangeLog
index 6687562bfb36..f43daa62555d 100644
--- a/www-client/mozilla-firefox/ChangeLog
+++ b/www-client/mozilla-firefox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/mozilla-firefox
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/ChangeLog,v 1.634 2010/07/25 13:46:39 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/ChangeLog,v 1.635 2010/07/25 16:21:47 anarchy Exp $
+
+ 25 Jul 2010; Jory A. Pratt <anarchy@gentoo.org>
+ -mozilla-firefox-2.0.0.19.ebuild, -mozilla-firefox-3.5.8.ebuild,
+ -mozilla-firefox-3.6.7.ebuild, metadata.xml:
+ cleanup stale builds
25 Jul 2010; Jeroen Roovers <jer@gentoo.org> mozilla-firefox-3.6.8.ebuild:
Stable for HPPA PPC (bug #329279).
diff --git a/www-client/mozilla-firefox/metadata.xml b/www-client/mozilla-firefox/metadata.xml
index 59c279975896..fca07fb99439 100644
--- a/www-client/mozilla-firefox/metadata.xml
+++ b/www-client/mozilla-firefox/metadata.xml
@@ -5,17 +5,9 @@
<use>
<flag name='custom-optimization'>Fine-tune custom compiler
optimizations</flag>
- <flag name='filepicker'>Enable old gtkfilepicker from 1.0.x firefox</flag>
- <flag name='iceweasel'>Enable iceweasel branding</flag>
<flag name="ipc">Use inter-process communication between tabs and plugins.
Allows for greater stability in case of plugin crashes</flag>
- <flag name='mozdevelop'>Enable features for web developers (e.g.
- Venkman)</flag>
- <flag name='moznopango'>Disable <pkg>x11-libs/pango</pkg> during
- runtime</flag>
<flag name='system-sqlite'>Use the system-wide <pkg>dev-db/sqlite</pkg>
installation with secure-delete enabled</flag>
- <flag name='xforms'>XForms is a standard to split up XHTML into XForms,
- instance data, and user interface</flag>
</use>
</pkgmetadata>
diff --git a/www-client/mozilla-firefox/mozilla-firefox-2.0.0.19.ebuild b/www-client/mozilla-firefox/mozilla-firefox-2.0.0.19.ebuild
deleted file mode 100644
index ed318edccd41..000000000000
--- a/www-client/mozilla-firefox/mozilla-firefox-2.0.0.19.ebuild
+++ /dev/null
@@ -1,312 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/mozilla-firefox-2.0.0.19.ebuild,v 1.10 2010/04/18 19:04:45 volkmar Exp $
-
-WANT_AUTOCONF="2.1"
-
-inherit flag-o-matic toolchain-funcs eutils mozconfig-2 mozilla-launcher makeedit multilib fdo-mime mozextension autotools
-
-PATCH="${P}-patches-0.1"
-LANGS="af ar be bg ca cs da de el en-GB en-US es-AR es-ES eu fi fr fy-NL ga-IE gu-IN he hu it ja ka ko ku lt mk mn nb-NO nl nn-NO pa-IN pl pt-BR pt-PT ro ru sk sl sv-SE tr uk zh-CN zh-TW"
-NOSHORTLANGS="en-GB es-AR pt-BR zh-TW"
-
-DESCRIPTION="Firefox Web Browser"
-HOMEPAGE="http://www.mozilla.com/firefox"
-
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
-SLOT="0"
-LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
-IUSE="java mozdevelop bindist xforms filepicker iceweasel"
-
-MOZ_URI="http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${PV}"
-SRC_URI="${MOZ_URI}/source/firefox-${PV}-source.tar.bz2
- mirror://gentoo/${PATCH}.tar.bz2
- iceweasel? ( mirror://gentoo/iceweasel-icons-2.0.0.11.tar.bz2 )"
-
-# These are in
-#
-# http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/linux-i686/xpi/
-#
-# for i in $LANGS $SHORTLANGS; do wget $i.xpi -O ${P}-$i.xpi; done
-for X in ${LANGS} ; do
- if [ "${X}" != "en" ] && [ "${X}" != "en-US" ]; then
- SRC_URI="${SRC_URI}
- linguas_${X/-/_}? ( http://dev.gentoo.org/~armin76/dist/${P}-xpi/${P}-${X}.xpi )"
- fi
- IUSE="${IUSE} linguas_${X/-/_}"
- # english is handled internally
- if [ "${#X}" == 5 ] && ! has ${X} ${NOSHORTLANGS}; then
- if [ "${X}" != "en-US" ]; then
- SRC_URI="${SRC_URI}
- linguas_${X%%-*}? ( http://dev.gentoo.org/~armin76/dist/${P}-xpi/${P}-${X}.xpi )"
- fi
- IUSE="${IUSE} linguas_${X%%-*}"
- fi
-done
-
-RDEPEND="java? ( virtual/jre )
- >=www-client/mozilla-launcher-1.55
- >=sys-devel/binutils-2.16.1
- >=dev-libs/nss-3.11.8
- >=dev-libs/nspr-4.6.8"
-
-DEPEND="${RDEPEND}
- java? ( >=dev-java/java-config-0.2.0 )"
-
-S="${WORKDIR}/mozilla"
-
-# Needed by src_compile() and src_install().
-# Would do in pkg_setup but that loses the export attribute, they
-# become pure shell variables.
-export MOZ_CO_PROJECT=browser
-export BUILD_OFFICIAL=1
-export MOZILLA_OFFICIAL=1
-
-linguas() {
- local LANG SLANG
- for LANG in ${LINGUAS}; do
- if has ${LANG} en en_US; then
- has en ${linguas} || linguas="${linguas:+"${linguas} "}en"
- continue
- elif has ${LANG} ${LANGS//-/_}; then
- has ${LANG//_/-} ${linguas} || linguas="${linguas:+"${linguas} "}${LANG//_/-}"
- continue
- elif [[ " ${LANGS} " == *" ${LANG}-"* ]]; then
- for X in ${LANGS}; do
- if [[ "${X}" == "${LANG}-"* ]] && \
- [[ " ${NOSHORTLANGS} " != *" ${X} "* ]]; then
- has ${X} ${linguas} || linguas="${linguas:+"${linguas} "}${X}"
- continue 2
- fi
- done
- fi
- ewarn "Sorry, but mozilla-firefox does not support the ${LANG} LINGUA"
- done
-}
-
-pkg_setup(){
- if ! built_with_use x11-libs/cairo X; then
- eerror "Cairo is not built with X useflag."
- eerror "Please add 'X' to your USE flags, and re-emerge cairo."
- die "Cairo needs X"
- fi
-
- if ! built_with_use --missing true x11-libs/pango X; then
- eerror "Pango is not built with X useflag."
- eerror "Please add 'X' to your USE flags, and re-emerge pango."
- die "Pango needs X"
- fi
-
- if ! use bindist && ! use iceweasel; then
- elog "You are enabling official branding. You may not redistribute this build"
- elog "to any users on your network or the internet. Doing so puts yourself into"
- elog "a legal problem with Mozilla Foundation"
- elog "You can disable it by emerging ${PN} _with_ the bindist USE-flag"
-
- fi
-
- use moznopango && warn_mozilla_launcher_stub
-}
-
-src_unpack() {
- unpack firefox-${PV}-source.tar.bz2 ${PATCH}.tar.bz2
-
- if use iceweasel; then
- unpack iceweasel-icons-2.0.0.11.tar.bz2
-
- cp -r iceweaselicons/browser mozilla/
- fi
-
- linguas
- for X in ${linguas}; do
- [[ ${X} != "en" ]] && xpi_unpack "${P}-${X}.xpi"
- done
- if [[ ${linguas} != "" && ${linguas} != "en" ]]; then
- einfo "Selected language packs (first will be default): ${linguas}"
- fi
-
- # Apply our patches
- cd "${S}" || die "cd failed"
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- epatch "${WORKDIR}"/patch
-
- if use filepicker; then
- epatch "${FILESDIR}"/mozilla-filepicker.patch
- fi
-
- if use iceweasel; then
- sed -i -e "s|Bon Echo|Iceweasel|" browser/locales/en-US/chrome/branding/brand.*
- sed -i -e "s|BonEcho|Iceweasel|" configure.in
- fi
-
- #Don't strip extension
- sed -i -e 's/STRIP_/#STRIP_/g' extensions/xforms/Makefile.in
-
- eautoreconf
-}
-
-src_compile() {
- declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
-
- mozconfig_init
- mozconfig_config
-
- mozconfig_annotate '' --enable-application=browser
- mozconfig_annotate '' --enable-image-encoder=all
- mozconfig_annotate '' --enable-canvas
- mozconfig_annotate '' --with-system-nspr
- mozconfig_annotate '' --with-system-nss
-
- if use xforms; then
- mozconfig_annotate '' --enable-extensions=default,xforms,schema-validation,typeaheadfind
- else
- mozconfig_annotate '' --enable-extensions=default,typeaheadfind
- fi
-
- if use ia64; then
- echo "ac_cv_visibility_pragma=no" >> "${S}/.mozconfig"
- fi
-
- if ! use bindist && ! use iceweasel; then
- mozconfig_annotate '' --enable-official-branding
- fi
-
- # Bug 60668: Galeon doesn't build without oji enabled, so enable it
- # regardless of java setting.
- mozconfig_annotate '' --enable-oji --enable-mathml
-
- # Other ff-specific settings
- mozconfig_use_enable mozdevelop jsd
- mozconfig_use_enable mozdevelop xpctools
- mozconfig_use_extension mozdevelop venkman
- mozconfig_annotate '' --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME}
-
- # Finalize and report settings
- mozconfig_final
-
- # -fstack-protector{,-all} breaks us
- filter-flags -fstack-protector -fstack-protector-all
-
- ####################################
- #
- # Configure and build
- #
- ####################################
-
- CPPFLAGS="${CPPFLAGS} -DARON_WAS_HERE" \
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
- econf || die
-
- # It would be great if we could pass these in via CPPFLAGS or CFLAGS prior
- # to econf, but the quotes cause configure to fail.
- sed -i -e \
- 's|-DARON_WAS_HERE|-DGENTOO_NSPLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsplugins\\\" -DGENTOO_NSBROWSER_PLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsbrowser/plugins\\\"|' \
- "${S}"/config/autoconf.mk \
- "${S}"/toolkit/content/buildconfig.html
-
- # This removes extraneous CFLAGS from the Makefiles to reduce RAM
- # requirements while compiling
- edit_makefiles
-
- # Should the build use multiprocessing? Not enabled by default, as it tends to break
- [ "${WANT_MP}" = "true" ] && jobs=${MAKEOPTS} || jobs="-j1"
- emake ${jobs} || die
-}
-
-pkg_preinst() {
- declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
-
- einfo "Removing old installs with some really ugly code. It potentially"
- einfo "eliminates any problems during the install, however suggestions to"
- einfo "replace this are highly welcome. Send comments and suggestions to"
- einfo "mozilla@gentoo.org."
- rm -rf "${ROOT}"/"${MOZILLA_FIVE_HOME}"
-}
-
-src_install() {
- declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
-
- # Most of the installation happens here
- dodir "${MOZILLA_FIVE_HOME}"
- cp -RL "${S}"/dist/bin/* "${D}"/"${MOZILLA_FIVE_HOME}"/ || die "cp failed"
-
- linguas
- for X in ${linguas}; do
- [[ ${X} != "en" ]] && xpi_install "${WORKDIR}"/"${P}-${X}"
- done
-
- local LANG=${linguas%% *}
- if [[ -n ${LANG} && ${LANG} != "en" ]]; then
- elog "Setting default locale to ${LANG}"
- dosed -e "s:general.useragent.locale\", \"en-US\":general.useragent.locale\", \"${LANG}\":" \
- "${MOZILLA_FIVE_HOME}"/defaults/pref/firefox.js \
- "${MOZILLA_FIVE_HOME}"/defaults/pref/firefox-l10n.js || \
- die "sed failed to change locale"
- fi
-
- # Create /usr/bin/firefox
- install_mozilla_launcher_stub firefox "${MOZILLA_FIVE_HOME}"
-
- # Install icon and .desktop for menu entry
- if use iceweasel; then
- newicon "${S}"/browser/base/branding/icon48.png iceweasel-icon.png
- newmenu "${FILESDIR}"/icon/iceweasel.desktop \
- mozilla-firefox-2.0.desktop
- elif ! use bindist; then
- newicon "${S}"/other-licenses/branding/firefox/content/icon48.png firefox-icon.png
- newmenu "${FILESDIR}"/icon/mozilla-firefox-1.5.desktop \
- mozilla-firefox-2.0.desktop
- else
- newicon "${S}"/browser/base/branding/icon48.png firefox-icon-unbranded.png
- newmenu "${FILESDIR}"/icon/mozilla-firefox-1.5-unbranded.desktop \
- mozilla-firefox-2.0.desktop
- fi
-
- # Fix icons to look the same everywhere
- insinto "${MOZILLA_FIVE_HOME}"/icons
- doins "${S}"/dist/branding/mozicon16.xpm
- doins "${S}"/dist/branding/mozicon50.xpm
-
- # Install files necessary for applications to build against firefox
- einfo "Installing includes and idl files..."
- cp -LfR "${S}"/dist/include "${D}"/"${MOZILLA_FIVE_HOME}" || die "cp failed"
- cp -LfR "${S}"/dist/idl "${D}"/"${MOZILLA_FIVE_HOME}" || die "cp failed"
-
- # Dirty hack to get some applications using this header running
- dosym "${MOZILLA_FIVE_HOME}"/include/necko/nsIURI.h \
- "${MOZILLA_FIVE_HOME}"/include/nsIURI.h
-
- # Install pkgconfig files
- insinto /usr/"$(get_libdir)"/pkgconfig
- doins "${S}"/build/unix/*.pc
-
- insinto "${MOZILLA_FIVE_HOME}"/greprefs
- newins "${FILESDIR}"/gentoo-default-prefs.js all-gentoo.js
- insinto "${MOZILLA_FIVE_HOME}"/defaults/pref
- newins "${FILESDIR}"/gentoo-default-prefs.js all-gentoo.js
-}
-
-pkg_postinst() {
- declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
-
- # This should be called in the postinst and postrm of all the
- # mozilla, mozilla-bin, firefox, firefox-bin, thunderbird and
- # thunderbird-bin ebuilds.
- update_mozilla_launcher_symlinks
-
- # Update mimedb for the new .desktop file
- fdo-mime_desktop_database_update
-
- elog "Please remember to rebuild any packages that you have built"
- elog "against Firefox. Some packages might be broken by the upgrade; if this"
- elog "is the case, please search at http://bugs.gentoo.org and open a new bug"
- elog "if one does not exist. Before filing any bugs, please move or remove"
- elog " ~/.mozilla and test with a clean profile directory."
-}
-
-pkg_postrm() {
- declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
-
- update_mozilla_launcher_symlinks
-}
diff --git a/www-client/mozilla-firefox/mozilla-firefox-3.5.8.ebuild b/www-client/mozilla-firefox/mozilla-firefox-3.5.8.ebuild
deleted file mode 100644
index 8a054d853d21..000000000000
--- a/www-client/mozilla-firefox/mozilla-firefox-3.5.8.ebuild
+++ /dev/null
@@ -1,276 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/mozilla-firefox-3.5.8.ebuild,v 1.6 2010/03/02 20:20:37 keytoaster Exp $
-EAPI="2"
-WANT_AUTOCONF="2.1"
-
-inherit flag-o-matic toolchain-funcs eutils mozconfig-3 makeedit multilib pax-utils fdo-mime autotools mozextension
-
-LANGS="af ar as be bg bn-BD bn-IN ca cs cy da de el en en-GB en-US eo es-AR
-es-CL es-ES es-MX et eu fa fi fr fy-NL ga-IE gl gu-IN he hi-IN hr hu id is it ja
-ka kk kn ko ku lt lv mk ml mn mr nb-NO nl nn-NO oc or pa-IN pl pt-BR pt-PT rm ro
-ru si sk sl sq sr sv-SE ta-LK ta te th tr uk vi zh-CN zh-TW"
-NOSHORTLANGS="en-GB es-AR es-CL es-MX pt-BR zh-CN zh-TW"
-
-XUL_PV="1.9.1.8"
-MAJ_XUL_PV="1.9.1"
-MAJ_PV="${PV/_*/}" # Without the _rc and _beta stuff
-DESKTOP_PV="3.5"
-MY_PV="${PV/_beta/b}" # Handle betas for SRC_URI
-MY_PV="${PV/_/}" # Handle rcs for SRC_URI
-PATCH="${PN}-3.5.5-patches-0.1"
-
-DESCRIPTION="Firefox Web Browser"
-HOMEPAGE="http://www.mozilla.com/firefox"
-
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
-SLOT="0"
-LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
-IUSE="+alsa bindist java mozdevelop sqlite iceweasel" # qt-experimental
-
-REL_URI="http://releases.mozilla.org/pub/mozilla.org/firefox/releases"
-SRC_URI="${REL_URI}/${MY_PV}/source/firefox-${MY_PV}.source.tar.bz2
- http://dev.gentoo.org/~anarchy/dist/${PATCH}.tar.bz2"
-
-for X in ${LANGS} ; do
- if [ "${X}" != "en" ] && [ "${X}" != "en-US" ]; then
- SRC_URI="${SRC_URI}
- linguas_${X/-/_}? ( ${REL_URI}/${MY_PV}/linux-i686/xpi/${X}.xpi -> ${P}-${X}.xpi )"
- fi
- IUSE="${IUSE} linguas_${X/-/_}"
- # english is handled internally
- if [ "${#X}" == 5 ] && ! has ${X} ${NOSHORTLANGS}; then
- if [ "${X}" != "en-US" ]; then
- SRC_URI="${SRC_URI}
- linguas_${X%%-*}? ( ${REL_URI}/${PV}/linux-i686/xpi/${X}.xpi -> ${P}-${X}.xpi )"
- fi
- IUSE="${IUSE} linguas_${X%%-*}"
- fi
-done
-
-# Not working.
-# qt-experimental? (
-# x11-libs/qt-gui
-# x11-libs/qt-core )
-# =net-libs/xulrunner-${XUL_PV}*[java=,qt-experimental=]
-
-RDEPEND="
- >=sys-devel/binutils-2.16.1
- >=dev-libs/nss-3.12.2
- >=dev-libs/nspr-4.7.3
- >=app-text/hunspell-1.2
- sqlite? ( >=dev-db/sqlite-3.6.20-r1[fts3] )
- alsa? ( media-libs/alsa-lib )
- ~net-libs/xulrunner-${XUL_PV}[java=,sqlite=]
- >=x11-libs/cairo-1.8.8[X]
- x11-libs/pango[X]"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-S="${WORKDIR}/mozilla-1.9.1"
-
-QA_PRESTRIPPED="usr/$(get_libdir)/${PN}/firefox"
-
-linguas() {
- local LANG SLANG
- for LANG in ${LINGUAS}; do
- if has ${LANG} en en_US; then
- has en ${linguas} || linguas="${linguas:+"${linguas} "}en"
- continue
- elif has ${LANG} ${LANGS//-/_}; then
- has ${LANG//_/-} ${linguas} || linguas="${linguas:+"${linguas} "}${LANG//_/-}"
- continue
- elif [[ " ${LANGS} " == *" ${LANG}-"* ]]; then
- for X in ${LANGS}; do
- if [[ "${X}" == "${LANG}-"* ]] && \
- [[ " ${NOSHORTLANGS} " != *" ${X} "* ]]; then
- has ${X} ${linguas} || linguas="${linguas:+"${linguas} "}${X}"
- continue 2
- fi
- done
- fi
- ewarn "Sorry, but ${PN} does not support the ${LANG} LINGUA"
- done
-}
-
-pkg_setup() {
- if ! use bindist ; then
- elog "You are enabling official branding. You may not redistribute this build"
- elog "to any users on your network or the internet. Doing so puts yourself into"
- elog "a legal problem with Mozilla Foundation"
- elog "You can disable it by emerging ${PN} _with_ the bindist USE-flag"
- fi
-
- if use iceweasel ; then
- elog "You have enabled iceweasel useflag which does nothing in current ebuild."
- elog "Please 'emerge -C mozilla-firefox; emerge icecat' if you wish to have same support"
- elog "as you currently had with iceweasel useflag."
- eerror "Please 'emerge -C mozilla-firefox; emerge icecat' to have a same support"
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- linguas
- for X in ${linguas}; do
- # FIXME: Add support for unpacking xpis to portage
- [[ ${X} != "en" ]] && xpi_unpack "${P}-${X}.xpi"
- done
- if [[ ${linguas} != "" && ${linguas} != "en" ]]; then
- einfo "Selected language packs (first will be default): ${linguas}"
- fi
-}
-
-src_prepare() {
- # Apply our patches
- EPATCH_EXCLUDE="136-fix_ftbfs_with_cairo_fb.patch" \
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- epatch "${WORKDIR}"
-
- eautoreconf
-
- cd js/src
- eautoreconf
-
- # We need to re-patch this because autoreconf overwrites it
- cd "${S}"
- epatch "${FILESDIR}/000_flex-configure-LANG.patch"
-}
-
-src_configure() {
- MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
- MEXTENSIONS="default"
-
- ####################################
- #
- # mozconfig, CFLAGS and CXXFLAGS setup
- #
- ####################################
-
- mozconfig_init
- mozconfig_config
-
- # It doesn't compile on alpha without this LDFLAGS
- use alpha && append-ldflags "-Wl,--no-relax"
-
- mozconfig_annotate '' --enable-extensions="${MEXTENSIONS}"
- mozconfig_annotate '' --enable-application=browser
- mozconfig_annotate 'gtk' --enable-default-toolkit=cairo-gtk2
- mozconfig_annotate '' --disable-mailnews
- mozconfig_annotate 'broken' --disable-crashreporter
- mozconfig_annotate '' --enable-image-encoder=all
- mozconfig_annotate '' --enable-canvas
- # Bug 60668: Galeon doesn't build without oji enabled, so enable it
- # regardless of java setting.
- mozconfig_annotate '' --enable-oji --enable-mathml
- mozconfig_annotate 'places' --enable-storage --enable-places
- mozconfig_annotate '' --enable-safe-browsing
-
- # System-wide install specs
- mozconfig_annotate '' --disable-installer
- mozconfig_annotate '' --disable-updater
- mozconfig_annotate '' --disable-strip
- mozconfig_annotate '' --disable-install-strip
-
- # Use system libraries
- mozconfig_annotate '' --enable-system-cairo
- mozconfig_annotate '' --enable-system-hunspell
- mozconfig_annotate '' --with-system-nspr
- mozconfig_annotate '' --with-system-nss
- mozconfig_annotate '' --enable-system-lcms
- mozconfig_annotate '' --with-system-bz2
- mozconfig_annotate '' --with-system-libxul
- mozconfig_annotate '' --with-libxul-sdk=/usr/$(get_libdir)/xulrunner-devel-${MAJ_XUL_PV}
-
- # Enable/Disable based on useflag
- mozconfig_use_enable sqlite system-sqlite
- mozconfig_use_enable mozdevelop jsd
- mozconfig_use_enable mozdevelop xpctools
- mozconfig_use_enable alsa ogg
- mozconfig_use_enable alsa wave
-
- if ! use bindist ; then
- mozconfig_annotate '' --enable-official-branding
- fi
-
- # Finalize and report settings
- mozconfig_final
-
- if [[ $(gcc-major-version) -lt 4 ]]; then
- append-cxxflags -fno-stack-protector
- fi
-
- ####################################
- #
- # Configure and build
- #
- ####################################
-
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" econf
-}
-
-src_compile() {
- # Should the build use multiprocessing? Not enabled by default, as it tends to break
- [ "${WANT_MP}" = "true" ] && jobs=${MAKEOPTS} || jobs="-j1"
- emake ${jobs} || die
-}
-
-src_install() {
- MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
-
- emake DESTDIR="${D}" install || die "emake install failed"
-
- linguas
- for X in ${linguas}; do
- [[ ${X} != "en" ]] && xpi_install "${WORKDIR}"/"${P}-${X}"
- done
-
- # Install icon and .desktop for menu entry
- if ! use bindist ; then
- newicon "${S}"/other-licenses/branding/firefox/content/icon48.png firefox-icon.png
- newmenu "${FILESDIR}"/icon/mozilla-firefox-1.5.desktop \
- ${PN}-${DESKTOP_PV}.desktop
- else
- newicon "${S}"/browser/base/branding/icon48.png firefox-icon-unbranded.png
- newmenu "${FILESDIR}"/icon/mozilla-firefox-1.5-unbranded.desktop \
- ${PN}-${DESKTOP_PV}.desktop
- sed -i -e "s:Bon Echo:Shiretoko:" \
- "${D}"/usr/share/applications/${PN}-${DESKTOP_PV}.desktop || die "sed failed!"
- fi
-
- # Add StartupNotify=true bug 237317
- if use startup-notification ; then
- echo "StartupNotify=true" >> "${D}"/usr/share/applications/${PN}-${DESKTOP_PV}.desktop
- fi
-
- pax-mark m "${D}"/${MOZILLA_FIVE_HOME}/firefox
-
- # Enable very specific settings not inherited from xulrunner
- cp "${FILESDIR}"/firefox-default-prefs.js \
- "${D}/${MOZILLA_FIVE_HOME}/defaults/preferences/all-gentoo.js" || \
- die "failed to cp xulrunner-default-prefs.js"
-
- # Plugins dir
- dosym ../nsbrowser/plugins "${MOZILLA_FIVE_HOME}"/plugins \
- || die "failed to symlink"
-
- # very ugly hack to make firefox not sigbus on sparc
- if use sparc ; then
- sed -i \
- -e 's/Firefox/FirefoxGentoo/g' \
- "${D}/${MOZILLA_FIVE_HOME}/application.ini" \
- || die "sparc sed failed"
- fi
-}
-
-pkg_postinst() {
- ewarn "All the packages built against ${PN} won't compile,"
- ewarn "any package that fails to build warrants a bug report."
- elog
-
- # Update mimedb for the new .desktop file
- fdo-mime_desktop_database_update
-}
diff --git a/www-client/mozilla-firefox/mozilla-firefox-3.6.7.ebuild b/www-client/mozilla-firefox/mozilla-firefox-3.6.7.ebuild
deleted file mode 100644
index 89ad157324c4..000000000000
--- a/www-client/mozilla-firefox/mozilla-firefox-3.6.7.ebuild
+++ /dev/null
@@ -1,287 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/mozilla-firefox-3.6.7.ebuild,v 1.7 2010/07/24 16:08:48 jer Exp $
-EAPI="3"
-WANT_AUTOCONF="2.1"
-
-inherit flag-o-matic toolchain-funcs eutils mozconfig-3 makeedit multilib pax-utils fdo-mime autotools mozextension java-pkg-opt-2 python
-
-LANGS="af ar as be bg bn-BD bn-IN ca cs cy da de el en en-GB en-US eo es-AR \
-es-CL es-ES es-MX et eu fa fi fr fy-NL ga-IE gl gu-IN he hi-IN hr hu id is it \
-ja ka kk kn ko ku lt lv mk ml mr nb-NO nl nn-NO oc or pa-IN pl pt-BR pt-PT rm \
-ro ru si sk sl sq sr sv-SE ta ta-LK te th tr uk vi zh-CN zh-TW"
-NOSHORTLANGS="en-GB es-AR es-CL es-MX pt-BR zh-CN zh-TW"
-
-MAJ_XUL_PV="1.9.2"
-MAJ_PV="${PV/_*/}" # Without the _rc and _beta stuff
-DESKTOP_PV="3.6"
-MY_PV="${PV/_rc/rc}" # Handle beta for SRC_URI
-XUL_PV="${MAJ_XUL_PV}${MAJ_PV/${DESKTOP_PV}/}" # Major + Minor version no.s
-PATCH="${PN}-3.6-patches-0.6"
-
-DESCRIPTION="Firefox Web Browser"
-HOMEPAGE="http://www.mozilla.com/firefox"
-
-KEYWORDS="~alpha ~amd64 ~arm hppa ~ia64 ppc ~ppc64 ~sparc x86 ~amd64-linux ~ia64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
-IUSE="+alsa bindist +ipc java libnotify system-sqlite wifi"
-
-REL_URI="http://releases.mozilla.org/pub/mozilla.org/firefox/releases"
-SRC_URI="${REL_URI}/${MY_PV}/source/firefox-${MY_PV}.source.tar.bz2
- http://dev.gentoo.org/~anarchy/dist/${PATCH}.tar.bz2"
-
-for X in ${LANGS} ; do
- if [ "${X}" != "en" ] && [ "${X}" != "en-US" ]; then
- SRC_URI="${SRC_URI}
- linguas_${X/-/_}? ( ${REL_URI}/${MY_PV}/linux-i686/xpi/${X}.xpi -> ${P}-${X}.xpi )"
- fi
- IUSE="${IUSE} linguas_${X/-/_}"
- # english is handled internally
- if [ "${#X}" == 5 ] && ! has ${X} ${NOSHORTLANGS}; then
- if [ "${X}" != "en-US" ]; then
- SRC_URI="${SRC_URI}
- linguas_${X%%-*}? ( ${REL_URI}/${PV}/linux-i686/xpi/${X}.xpi -> ${P}-${X}.xpi )"
- fi
- IUSE="${IUSE} linguas_${X%%-*}"
- fi
-done
-
-RDEPEND="
- >=sys-devel/binutils-2.16.1
- >=dev-libs/nss-3.12.4
- >=dev-libs/nspr-4.8
- >=app-text/hunspell-1.2
- system-sqlite? ( >=dev-db/sqlite-3.6.22-r2[fts3,secure-delete] )
- alsa? ( media-libs/alsa-lib )
- >=x11-libs/cairo-1.8.8[X]
- x11-libs/pango[X]
- wifi? ( net-wireless/wireless-tools )
- libnotify? ( >=x11-libs/libnotify-0.4 )
- ~net-libs/xulrunner-${XUL_PV}[ipc=,java=,wifi=,libnotify=,system-sqlite=]"
-
-DEPEND="${RDEPEND}
- java? ( >=virtual/jdk-1.4 )
- =dev-lang/python-2*[threads]
- dev-util/pkgconfig"
-
-RDEPEND="${RDEPEND} java? ( >=virtual/jre-1.4 )"
-
-S="${WORKDIR}/mozilla-1.9.2"
-
-QA_PRESTRIPPED="usr/$(get_libdir)/${PN}/firefox"
-
-linguas() {
- local LANG SLANG
- for LANG in ${LINGUAS}; do
- if has ${LANG} en en_US; then
- has en ${linguas} || linguas="${linguas:+"${linguas} "}en"
- continue
- elif has ${LANG} ${LANGS//-/_}; then
- has ${LANG//_/-} ${linguas} || linguas="${linguas:+"${linguas} "}${LANG//_/-}"
- continue
- elif [[ " ${LANGS} " == *" ${LANG}-"* ]]; then
- for X in ${LANGS}; do
- if [[ "${X}" == "${LANG}-"* ]] && \
- [[ " ${NOSHORTLANGS} " != *" ${X} "* ]]; then
- has ${X} ${linguas} || linguas="${linguas:+"${linguas} "}${X}"
- continue 2
- fi
- done
- fi
- ewarn "Sorry, but ${PN} does not support the ${LANG} LINGUA"
- done
-}
-
-pkg_setup() {
- # Ensure we always build with C locale.
- export LANG="C"
- export LC_ALL="C"
- export LC_MESSAGES="C"
- export LC_CTYPE="C"
-
- if ! use bindist ; then
- einfo
- elog "You are enabling official branding. You may not redistribute this build"
- elog "to any users on your network or the internet. Doing so puts yourself into"
- elog "a legal problem with Mozilla Foundation"
- elog "You can disable it by emerging ${PN} _with_ the bindist USE-flag"
- fi
-
- java-pkg-opt-2_pkg_setup
-
- python_set_active_version 2
-}
-
-src_unpack() {
- unpack firefox-${MY_PV}.source.tar.bz2 ${PATCH}.tar.bz2
-
- linguas
- for X in ${linguas}; do
- # FIXME: Add support for unpacking xpis to portage
- [[ ${X} != "en" ]] && xpi_unpack "${P}-${X}.xpi"
- done
-}
-
-src_prepare() {
- # Apply our patches
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- EPATCH_EXCLUDE="137-bz460917_att350845_reload_new_plugins-gentoo-update.patch" \
- epatch "${WORKDIR}"
-
- epatch "${FILESDIR}"/${PN}-3.0-solaris64.patch
-
- # The patch excluded above failed, ported patch is applied below
- epatch "${FILESDIR}/137-bz460917_reload_new_plugins-gentoo-update-3.6.4.patch"
-
- # ARM fixes, bug 327783
- epatch "${FILESDIR}/xulrunner-1.9.2-arm-fixes.patch"
-
- # Enable tracemonkey for amd64 (bug #315997)
- epatch "${FILESDIR}/801-enable-x86_64-tracemonkey.patch"
-
- # Allow user to apply additional patches without modifing ebuild
- epatch_user
-
- eautoreconf
-
- cd js/src
- eautoreconf
-}
-
-src_configure() {
- MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
- MEXTENSIONS="default"
-
- ####################################
- #
- # mozconfig, CFLAGS and CXXFLAGS setup
- #
- ####################################
-
- mozconfig_init
- mozconfig_config
-
- # It doesn't compile on alpha without this LDFLAGS
- use alpha && append-ldflags "-Wl,--no-relax"
-
- mozconfig_annotate '' --enable-extensions="${MEXTENSIONS}"
- mozconfig_annotate '' --enable-application=browser
- mozconfig_annotate '' --disable-mailnews
- mozconfig_annotate 'broken' --disable-crashreporter
- mozconfig_annotate '' --enable-image-encoder=all
- mozconfig_annotate '' --enable-canvas
- mozconfig_annotate 'gtk' --enable-default-toolkit=cairo-gtk2
- # Bug 60668: Galeon doesn't build without oji enabled, so enable it
- # regardless of java setting.
- mozconfig_annotate '' --enable-oji --enable-mathml
- mozconfig_annotate 'places' --enable-storage --enable-places
- mozconfig_annotate '' --enable-safe-browsing
-
- # Build mozdevelop permately
- mozconfig_annotate '' --enable-jsd --enable-xpctools
-
- # System-wide install specs
- mozconfig_annotate '' --disable-installer
- mozconfig_annotate '' --disable-updater
- mozconfig_annotate '' --disable-strip
- mozconfig_annotate '' --disable-install-strip
-
- # Use system libraries
- mozconfig_annotate '' --enable-system-cairo
- mozconfig_annotate '' --enable-system-hunspell
- mozconfig_annotate '' --with-system-nspr --with-nspr-prefix="${EPREFIX}"/usr
- mozconfig_annotate '' --with-system-nss --with-nss-prefix="${EPREFIX}"/usr
- mozconfig_annotate '' --x-includes="${EPREFIX}"/usr/include --x-libraries="${EPREFIX}"/usr/$(get_libdir)
- mozconfig_annotate '' --with-system-bz2
- mozconfig_annotate '' --with-system-libxul
- mozconfig_annotate '' --with-libxul-sdk="${EPREFIX}"/usr/$(get_libdir)/xulrunner-devel-${MAJ_XUL_PV}
-
- mozconfig_use_enable ipc # +ipc, upstream default
- mozconfig_use_enable libnotify
- mozconfig_use_enable java javaxpcom
- mozconfig_use_enable wifi necko-wifi
- mozconfig_use_enable alsa ogg
- mozconfig_use_enable alsa wave
- mozconfig_use_enable system-sqlite
- mozconfig_use_enable !bindist official-branding
-
- # Other ff-specific settings
- mozconfig_annotate '' --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME}
-
- # Finalize and report settings
- mozconfig_final
-
- if [[ $(gcc-major-version) -lt 4 ]]; then
- append-cxxflags -fno-stack-protector
- fi
-
- ####################################
- #
- # Configure and build
- #
- ####################################
-
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" PYTHON="$(PYTHON)" econf
-}
-
-src_compile() {
- # Should the build use multiprocessing? Not enabled by default, as it tends to break
- [ "${WANT_MP}" = "true" ] && jobs=${MAKEOPTS} || jobs="-j1"
- emake ${jobs} || die
-}
-
-src_install() {
- MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
-
- emake DESTDIR="${D}" install || die "emake install failed"
-
- linguas
- for X in ${linguas}; do
- [[ ${X} != "en" ]] && xpi_install "${WORKDIR}"/"${P}-${X}"
- done
-
- # Install icon and .desktop for menu entry
- if ! use bindist ; then
- newicon "${S}"/other-licenses/branding/firefox/content/icon48.png firefox-icon.png
- newmenu "${FILESDIR}"/icon/mozilla-firefox-1.5.desktop \
- ${PN}-${DESKTOP_PV}.desktop
- else
- newicon "${S}"/browser/branding/unofficial/content/icon48.png firefox-icon-unbranded.png
- newmenu "${FILESDIR}"/icon/mozilla-firefox-1.5-unbranded.desktop \
- ${PN}-${DESKTOP_PV}.desktop
- sed -i -e "s:Bon Echo:Namoroka:" \
- "${ED}"/usr/share/applications/${PN}-${DESKTOP_PV}.desktop || die "sed failed!"
- fi
-
- # Add StartupNotify=true bug 237317
- if use startup-notification ; then
- echo "StartupNotify=true" >> "${ED}"/usr/share/applications/${PN}-${DESKTOP_PV}.desktop
- fi
-
- pax-mark m "${ED}"/${MOZILLA_FIVE_HOME}/firefox
-
- # Enable very specific settings not inherited from xulrunner
- cp "${FILESDIR}"/firefox-default-prefs.js \
- "${ED}/${MOZILLA_FIVE_HOME}/defaults/preferences/all-gentoo.js" || \
- die "failed to cp firefox-default-prefs.js"
-
- # Plugins dir
- dosym ../nsbrowser/plugins "${MOZILLA_FIVE_HOME}"/plugins \
- || die "failed to symlink"
-
- # very ugly hack to make firefox not sigbus on sparc
- use sparc && { sed -e 's/Firefox/FirefoxGentoo/g' \
- -i "${ED}/${MOZILLA_FIVE_HOME}/application.ini" || \
- die "sparc sed failed"; }
-}
-
-pkg_postinst() {
- ewarn "All the packages built against ${PN} won't compile,"
- ewarn "any package that fails to build warrants a bug report."
- elog
-
- # Update mimedb for the new .desktop file
- fdo-mime_desktop_database_update
-}