summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/luit/luit-1.1.1.ebuild')
-rw-r--r--x11-apps/luit/luit-1.1.1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/x11-apps/luit/luit-1.1.1.ebuild b/x11-apps/luit/luit-1.1.1.ebuild
index 0d20c18a0f97..02160862a06f 100644
--- a/x11-apps/luit/luit-1.1.1.ebuild
+++ b/x11-apps/luit/luit-1.1.1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/luit/luit-1.1.1.ebuild,v 1.10 2013/02/25 21:41:13 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/luit/luit-1.1.1.ebuild,v 1.11 2013/04/12 12:05:43 chithanh Exp $
EAPI=4
+XORG_EAUTORECONF=yes
inherit xorg-2
@@ -14,3 +15,9 @@ RDEPEND="sys-libs/zlib
x11-libs/libX11
x11-libs/libfontenc"
DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # posix_openpt() call needs POSIX 2004, bug #415949
+ sed -i 's/-D_XOPEN_SOURCE=500/-D_XOPEN_SOURCE=600/' configure.ac || die
+ xorg-2_src_prepare
+}