summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xinit/ChangeLog9
-rw-r--r--x11-apps/xinit/files/digest-xinit-1.0.2-r3 (renamed from x11-apps/xinit/files/digest-xinit-1.0.2-r2)0
-rwxr-xr-xx11-apps/xinit/files/xdm.start26
-rw-r--r--x11-apps/xinit/xinit-1.0.2-r3.ebuild (renamed from x11-apps/xinit/xinit-1.0.2-r2.ebuild)2
4 files changed, 29 insertions, 8 deletions
diff --git a/x11-apps/xinit/ChangeLog b/x11-apps/xinit/ChangeLog
index d5540e781158..baee78ad8d51 100644
--- a/x11-apps/xinit/ChangeLog
+++ b/x11-apps/xinit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-apps/xinit
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.45 2006/04/20 06:37:42 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.46 2006/04/21 22:26:37 spyderous Exp $
+
+*xinit-1.0.2-r3 (21 Apr 2006)
+
+ 21 Apr 2006; Donnie Berkholz <spyderous@gentoo.org>; files/xdm.start,
+ -xinit-1.0.2-r2.ebuild, +xinit-1.0.2-r3.ebuild:
+ Missed the actual init script changes last time. Add it now, with a
+ rewritten depend() section by UberLord.
20 Apr 2006; Donnie Berkholz <spyderous@gentoo.org>; files/xdm.confd:
Add a note that rc.conf overrides this DISPLAYMANAGER setting, even though
diff --git a/x11-apps/xinit/files/digest-xinit-1.0.2-r2 b/x11-apps/xinit/files/digest-xinit-1.0.2-r3
index 29ec40dd3a6d..29ec40dd3a6d 100644
--- a/x11-apps/xinit/files/digest-xinit-1.0.2-r2
+++ b/x11-apps/xinit/files/digest-xinit-1.0.2-r3
diff --git a/x11-apps/xinit/files/xdm.start b/x11-apps/xinit/files/xdm.start
index fe4b191d2ea0..09c119ba88d1 100755
--- a/x11-apps/xinit/files/xdm.start
+++ b/x11-apps/xinit/files/xdm.start
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/files/xdm.start,v 1.1 2005/09/06 19:33:51 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/files/xdm.start,v 1.2 2006/04/21 22:26:37 spyderous Exp $
# This is here to serve as a note to myself, and future developers.
#
@@ -39,7 +39,15 @@
# Start X Font Server before X
depend() {
- use xfs hotplug
+ need localmount
+
+ # this should start as early as possible
+ # we can't do 'before *' as that breaks it
+ after bootmisc
+ before alsasound net.lo
+
+ # Start before X
+ use acpid xfs
}
setup_dm() {
@@ -110,10 +118,16 @@ start() {
ebegin "Setting up ${SERVICE}"
#save the prefered DM
save_options "service" "${EXE}"
- #tell init to run /etc/X11/startDM.sh after current
- #runlevel is finished (should *not* be in the "boot"
- # runlevel).
- /sbin/telinit a &>/dev/null
+
+ # Start as soon as possible if XSTATICVT is set
+ if [ "${XSTATICVT}" = "yes" ] ; then
+ /etc/X11/startDM.sh
+ else
+ #tell init to run /etc/X11/startDM.sh after current
+ #runlevel is finished (should *not* be in the "boot"
+ # runlevel).
+ /sbin/telinit a &>/dev/null
+ fi
eend 0
fi
diff --git a/x11-apps/xinit/xinit-1.0.2-r2.ebuild b/x11-apps/xinit/xinit-1.0.2-r3.ebuild
index 44b72234a968..af0206a731c5 100644
--- a/x11-apps/xinit/xinit-1.0.2-r2.ebuild
+++ b/x11-apps/xinit/xinit-1.0.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-1.0.2-r2.ebuild,v 1.1 2006/04/20 06:27:09 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-1.0.2-r3.ebuild,v 1.1 2006/04/21 22:26:37 spyderous Exp $
# Must be before x-modular eclass is inherited
# This is enabled due to modified Makefile.am from the patches