From f160d8784ce9dad8675e887c0427113e17a358af Mon Sep 17 00:00:00 2001
From: Ulrich Müller <ulm@gentoo.org>
Date: Sun, 31 Jan 2010 11:14:28 +0000
Subject: Add prefix keywords, change EAPI to 3. (Portage version:
 2.2_rc62/cvs/Linux i686)

---
 app-emacs/rst/ChangeLog         |  9 +++++++--
 app-emacs/rst/rst-0.6-r1.ebuild | 36 ++++++++++++++++++++++++++++++++++++
 2 files changed, 43 insertions(+), 2 deletions(-)
 create mode 100644 app-emacs/rst/rst-0.6-r1.ebuild

(limited to 'app-emacs/rst')

diff --git a/app-emacs/rst/ChangeLog b/app-emacs/rst/ChangeLog
index f6d7d741b41c..b8bda4121c81 100644
--- a/app-emacs/rst/ChangeLog
+++ b/app-emacs/rst/ChangeLog
@@ -1,6 +1,11 @@
 # ChangeLog for app-emacs/rst
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/rst/ChangeLog,v 1.39 2009/12/08 19:34:35 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/rst/ChangeLog,v 1.40 2010/01/31 11:14:28 ulm Exp $
+
+*rst-0.6-r1 (31 Jan 2010)
+
+  31 Jan 2010; Ulrich Mueller <ulm@gentoo.org> +rst-0.6-r1.ebuild:
+  Add prefix keywords, change EAPI to 3.
 
   08 Dec 2009; nixnut <nixnut@gentoo.org> rst-0.5-r1.ebuild:
   ppc stable #290041
diff --git a/app-emacs/rst/rst-0.6-r1.ebuild b/app-emacs/rst/rst-0.6-r1.ebuild
new file mode 100644
index 000000000000..c14ff5321afd
--- /dev/null
+++ b/app-emacs/rst/rst-0.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/rst/rst-0.6-r1.ebuild,v 1.1 2010/01/31 11:14:28 ulm Exp $
+
+EAPI=3
+
+inherit elisp
+
+DESCRIPTION="ReStructuredText support for Emacs"
+HOMEPAGE="http://www.emacswiki.org/cgi-bin/wiki/reStructuredText"
+SRC_URI="mirror://sourceforge/docutils/docutils-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+S="${WORKDIR}/docutils-${PV}/tools/editors/emacs"
+DOCS="README.txt"
+SITEFILE="50${PN}-gentoo.el"
+
+pkg_setup() {
+	local have_emacs=$(elisp-emacs-version)
+	if [ "${have_emacs%%.*}" -ge 23 ]; then
+		echo
+		elog "Please note that \"${PN}\" is already included with Emacs 23 or"
+		elog "later, so ${CATEGORY}/${PN} is only needed for lower versions."
+		elog "You may select the active Emacs version with \"eselect emacs\"."
+	fi
+}
+
+src_install() {
+	elisp_src_install
+	# prevent inclusion of package dir by subdirs.el
+	touch "${ED}${SITELISP}/${PN}/.nosearch"
+}
-- 
cgit v1.2.3-65-gdbad