From b6dd7ab6beffc6707e60b03cca29db17b0584960 Mon Sep 17 00:00:00 2001
From: Samuli Suominen <ssuominen@gentoo.org>
Date: Tue, 23 Mar 2010 23:58:01 +0000
Subject: Fix bug 292508 in a different way since upstream mentioned wanting
 configure.in check. (Portage version: 2.2_rc67/cvs/Linux x86_64)

---
 app-emulation/vice/ChangeLog                 |  7 ++++-
 app-emulation/vice/files/vice-2.2-xshm.patch | 40 ++++++++++++++++++++++++++++
 app-emulation/vice/vice-2.2.ebuild           |  3 ++-
 3 files changed, 48 insertions(+), 2 deletions(-)
 create mode 100644 app-emulation/vice/files/vice-2.2-xshm.patch

(limited to 'app-emulation')

diff --git a/app-emulation/vice/ChangeLog b/app-emulation/vice/ChangeLog
index 94db7e841fa0..36577056d168 100644
--- a/app-emulation/vice/ChangeLog
+++ b/app-emulation/vice/ChangeLog
@@ -1,6 +1,11 @@
 # ChangeLog for app-emulation/vice
 # Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.68 2010/03/23 22:51:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.69 2010/03/23 23:58:01 ssuominen Exp $
+
+  23 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> vice-2.2.ebuild,
+  +files/vice-2.2-xshm.patch:
+  Fix bug 292508 in a different way since upstream mentioned wanting
+  configure.in check.
 
 *vice-2.2 (23 Mar 2010)
 
diff --git a/app-emulation/vice/files/vice-2.2-xshm.patch b/app-emulation/vice/files/vice-2.2-xshm.patch
new file mode 100644
index 000000000000..0839f15e9005
--- /dev/null
+++ b/app-emulation/vice/files/vice-2.2-xshm.patch
@@ -0,0 +1,40 @@
+Check for xextproto 7.1.1 and include headers for X_ShmAttach.
+
+https://sourceforge.net/tracker/?func=detail&aid=2935150&group_id=223021&atid=1057617
+http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=0a4c4c5fe8ebad2dd13f5770bd90a194eebb2890
+
+--- configure.in
++++ configure.in
+@@ -2192,6 +2192,11 @@
+                  [ X_LIBS="-lXext $X_LIBS";
+                    LINK_X_LIBS="-lXext $LINK_X_LIBS"],,$X_LIBS)
+ 
++    PKG_CHECK_MODULES(XEXT, [xextproto >= 7.0.99.1],
++                 HAVE_XEXTPROTO_71="yes"; AC_DEFINE(HAVE_XEXTPROTO_71, 1, [xextproto 7.1 available]),
++    		 HAVE_XEXTPROTO_71="no")
++    AM_CONDITIONAL(HAVE_XEXTPROTO_71, [ test "$HAVE_XEXTPROTO_71" = "yes" ])
++
+     AC_MSG_CHECKING(for X11/extensions/Xvlib.h)
+     AC_TRY_LINK([#include <X11/Xlib.h>
+                  #include <X11/extensions/Xvlib.h>],
+--- src/arch/unix/x11/xaw/x11video.c
++++ src/arch/unix/x11/xaw/x11video.c
+@@ -56,6 +56,7 @@
+ #include "vice.h"
+ 
+ #include <X11/Xlib.h>
++#include <X11/Xlibint.h>
+ #include <X11/Xutil.h>
+ #include <X11/Intrinsic.h>
+ #include <X11/cursorfont.h>
+@@ -95,6 +96,10 @@
+ #endif
+ 
+ #ifdef USE_MITSHM
++#ifdef HAVE_XEXTPROTO_71
++#include <X11/extensions/shmproto.h>
++#include <X11/extensions/XShm.h>
++#endif
+ extern int shmhandler(Display* display, XErrorEvent* err);
+ extern int mitshm_failed; /* will be set to true if XShmAttach() failed */
+ extern int shmmajor;          /* major number of MITSHM error codes */
diff --git a/app-emulation/vice/vice-2.2.ebuild b/app-emulation/vice/vice-2.2.ebuild
index d1149ba002b5..584209f7ef85 100644
--- a/app-emulation/vice/vice-2.2.ebuild
+++ b/app-emulation/vice/vice-2.2.ebuild
@@ -1,6 +1,6 @@
 # Copyright 1999-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-2.2.ebuild,v 1.1 2010/03/23 22:51:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-2.2.ebuild,v 1.2 2010/03/23 23:58:01 ssuominen Exp $
 
 EAPI=2
 inherit autotools eutils games
@@ -58,6 +58,7 @@ DEPEND="${RDEPEND}
 	nls? ( sys-devel/gettext )"
 
 src_prepare() {
+	epatch "${FILESDIR}"/${P}-xshm.patch
 	sed -i \
 		-e "s:/usr/local/lib/VICE:${GAMES_DATADIR}/${PN}:" \
 		man/vice.1 \
-- 
cgit v1.2.3-65-gdbad