From cdb3d1c6127b81bf25142ecf0ab6eb77670e9562 Mon Sep 17 00:00:00 2001
From: Markus Ullmann <jokey@gentoo.org>
Date: Sun, 26 Mar 2006 23:56:20 +0000
Subject: Adding sample config, thanks to Eric Brown <bigwhitecow@hotmail.com>
 wrt bug #126986 (Portage version: 2.1_pre7-r1)

---
 net-analyzer/prewikka/prewikka-0.9.3-r1.ebuild | 46 ++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)
 create mode 100644 net-analyzer/prewikka/prewikka-0.9.3-r1.ebuild

(limited to 'net-analyzer/prewikka/prewikka-0.9.3-r1.ebuild')

diff --git a/net-analyzer/prewikka/prewikka-0.9.3-r1.ebuild b/net-analyzer/prewikka/prewikka-0.9.3-r1.ebuild
new file mode 100644
index 000000000000..0195fa70aa89
--- /dev/null
+++ b/net-analyzer/prewikka/prewikka-0.9.3-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/prewikka/prewikka-0.9.3-r1.ebuild,v 1.1 2006/03/26 23:56:20 jokey Exp $
+
+inherit distutils
+
+DESCRIPTION="Prelude-IDS Frontend"
+HOMEPAGE="http://www.prelude-ids.org/"
+SRC_URI="http://www.prelude-ids.org/download/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3
+	>=dev-python/cheetah-0.9.18"
+
+RDEPEND="${DEPEND}
+	>=dev-libs/libprelude-0.9.0
+	>=dev-libs/libpreludedb-0.9.0"
+
+pkg_setup() {
+	if ! built_with_use dev-libs/libprelude python ;
+	then
+		die 'requires dev-libs/libprelude to be built with "python" use flag'
+	fi
+
+}
+
+src_install() {
+	distutils_src_install
+	dodir /etc/prewikka
+	insinto /etc/prewikka
+	doins ${FILESDIR}/prewikka.conf-sample
+	rm "${D}"/\-dist
+}
+
+pkg_postinst() {
+	einfo
+	einfo "For additional installation instructions go to"
+	einfo "https://trac.prelude-ids.org/wiki/InstallingPrewikka"
+	einfo
+	einfo "The default config from the website is installed as"
+	einfo "/etc/prewikka/prewikka.conf-sample"
+}
-- 
cgit v1.2.3-65-gdbad