From 86ba60ea06e0c44b53c7fd160e6a545eb067335c Mon Sep 17 00:00:00 2001
From: Peter Volkov <pva@gentoo.org>
Date: Tue, 6 Oct 2009 18:04:28 +0000
Subject: Version bump, bug #280193. Thank Rudy Grigar and  Luca Lesinigo for
 report and updates. (Portage version: 2.1.6.13/cvs/Linux x86_64)

---
 net-analyzer/cacti/ChangeLog           |  8 +++-
 net-analyzer/cacti/cacti-0.8.7e.ebuild | 88 ++++++++++++++++++++++++++++++++++
 2 files changed, 95 insertions(+), 1 deletion(-)
 create mode 100644 net-analyzer/cacti/cacti-0.8.7e.ebuild

(limited to 'net-analyzer')

diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index f2fbbba2a2ad..5d5fe5458bf6 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,12 @@
 # ChangeLog for net-analyzer/cacti
 # Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.150 2009/05/26 17:04:42 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.151 2009/10/06 18:04:28 pva Exp $
+
+*cacti-0.8.7e (06 Oct 2009)
+
+  06 Oct 2009; Peter Volkov <pva@gentoo.org> +cacti-0.8.7e.ebuild:
+  Version bump, bug #280193. Thank Rudy Grigar and Luca Lesinigo for report
+  and updates.
 
   26 May 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
   cacti-0.8.6j-r8.ebuild:
diff --git a/net-analyzer/cacti/cacti-0.8.7e.ebuild b/net-analyzer/cacti/cacti-0.8.7e.ebuild
new file mode 100644
index 000000000000..a58efee691e9
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.7e.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.7e.ebuild,v 1.1 2009/10/06 18:04:28 pva Exp $
+
+inherit eutils webapp depend.php
+
+# Support for _p* in version.
+MY_P=${P/_p*/}
+HAS_PATCHES=1
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.cacti.net/"
+SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
+
+# patches
+if [ "${HAS_PATCHES}" == "1" ] ; then
+	UPSTREAM_PATCHES="cli_add_graph
+		snmp_invalid_response
+		template_duplication
+		fix_icmp_on_windows_iis_servers"
+	for i in ${UPSTREAM_PATCHES} ; do
+		SRC_URI="${SRC_URI} http://www.cacti.net/downloads/patches/${PV/_p*}/${i}.patch"
+	done
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="snmp doc"
+
+DEPEND=""
+
+need_php_cli
+need_httpd_cgi
+need_php_httpd
+
+RDEPEND="snmp? ( >=net-analyzer/net-snmp-5.1.2 )
+	net-analyzer/rrdtool
+	dev-php/adodb
+	virtual/mysql
+	virtual/cron"
+
+src_unpack() {
+	if [ "${HAS_PATCHES}" == "1" ] ; then
+		unpack ${MY_P}.tar.gz
+		[ ! ${MY_P} == ${P} ] && mv ${MY_P} ${P}
+		# patches
+		for i in ${UPSTREAM_PATCHES} ; do
+			EPATCH_OPTS="-p1 -d ${S} -N" epatch "${DISTDIR}"/${i}.patch
+		done ;
+	else
+		unpack ${MY_P}.tar.gz
+	fi
+
+	sed -i -e \
+		's:$config\["library_path"\] . "/adodb/adodb.inc.php":"adodb/adodb.inc.php":' \
+		"${S}"/include/global.php
+
+	rm -rf lib/adodb # don't use bundled adodb
+}
+
+pkg_setup() {
+	webapp_pkg_setup
+	has_php
+	require_php_with_use cli mysql xml session pcre sockets
+}
+
+src_compile() { :; }
+
+src_install() {
+	webapp_src_preinst
+
+	rm LICENSE README
+	dodoc docs/{CHANGELOG,CONTRIB,README,txt/manual.txt} || die
+	use doc && dohtml -r docs/html/
+	rm -rf docs
+
+	edos2unix `find -type f -name '*.php'`
+
+	dodir ${MY_HTDOCSDIR}
+	cp -r . "${D}"${MY_HTDOCSDIR}
+
+	webapp_serverowned ${MY_HTDOCSDIR}/rra
+	webapp_serverowned ${MY_HTDOCSDIR}/log/cacti.log
+	webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+	webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+	webapp_src_install
+}
-- 
cgit v1.2.3-65-gdbad