From 1ff9e89b3e827d1c6ae799bcc336a06e7ac50887 Mon Sep 17 00:00:00 2001
From: Sebastien Fabbro <bicatali@gentoo.org>
Date: Sat, 23 Mar 2013 15:22:10 +0000
Subject: Version bump

(Portage version: 2.2.0_alpha168/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
---
 net-libs/xrootd/ChangeLog           |  8 +++-
 net-libs/xrootd/xrootd-3.2.6.ebuild | 76 -------------------------------------
 net-libs/xrootd/xrootd-3.3.1.ebuild | 76 +++++++++++++++++++++++++++++++++++++
 3 files changed, 83 insertions(+), 77 deletions(-)
 delete mode 100644 net-libs/xrootd/xrootd-3.2.6.ebuild
 create mode 100644 net-libs/xrootd/xrootd-3.3.1.ebuild

(limited to 'net-libs')

diff --git a/net-libs/xrootd/ChangeLog b/net-libs/xrootd/ChangeLog
index a3467daa4618..695564027ec0 100644
--- a/net-libs/xrootd/ChangeLog
+++ b/net-libs/xrootd/ChangeLog
@@ -1,6 +1,12 @@
 # ChangeLog for net-libs/xrootd
 # Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/xrootd/ChangeLog,v 1.12 2013/01/24 17:26:54 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xrootd/ChangeLog,v 1.13 2013/03/23 15:22:10 bicatali Exp $
+
+*xrootd-3.3.1 (23 Mar 2013)
+
+  23 Mar 2013; Sébastien Fabbro <bicatali@gentoo.org> +xrootd-3.3.1.ebuild,
+  -xrootd-3.2.6.ebuild:
+  Version bump
 
 *xrootd-3.2.7 (24 Jan 2013)
 
diff --git a/net-libs/xrootd/xrootd-3.2.6.ebuild b/net-libs/xrootd/xrootd-3.2.6.ebuild
deleted file mode 100644
index 8cad71d5c0fb..000000000000
--- a/net-libs/xrootd/xrootd-3.2.6.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/xrootd/xrootd-3.2.6.ebuild,v 1.2 2012/12/05 18:22:59 bicatali Exp $
-
-EAPI=4
-
-inherit cmake-utils eutils user
-
-DURI="http://xrootd.slac.stanford.edu/doc/prod"
-
-DESCRIPTION="Extended ROOT remote file server"
-HOMEPAGE="http://xrootd.org/"
-SRC_URI="${HOMEPAGE}/download/v${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc fuse kerberos perl readline ssl"
-
-RDEPEND="
-	!<sci-physics/root-5.32[xrootd]
-	sys-libs/zlib
-	fuse? ( sys-fs/fuse )
-	kerberos? ( virtual/krb5 )
-	perl? (
-		dev-lang/perl
-		readline? ( dev-perl/Term-ReadLine-Perl )
-	)
-	readline? ( sys-libs/readline )
-	ssl? ( dev-libs/openssl )"
-DEPEND="${RDEPEND}
-	doc? ( app-doc/doxygen[dot] )
-	perl? ( dev-lang/swig )"
-
-ppkg_setup() {
-	enewgroup xrootd
-	enewuser xrootd -1 -1 "${EPREFIX}"/var/spool/xrootd xrootd
-}
-
-src_configure() {
-	local mycmakeargs=(
-		$(cmake-utils_use_enable fuse)
-		$(cmake-utils_use_enable kerberos KRB5)
-		$(cmake-utils_use_enable perl)
-		$(cmake-utils_use_enable readline)
-		$(cmake-utils_use_enable ssl CRYPTO)
-	)
-	cmake-utils_src_configure
-}
-
-src_compile() {
-	cmake-utils_src_compile
-	use doc && doxygen Doxyfile
-}
-
-src_install() {
-	cmake-utils_src_install
-
-	# base configs
-	insinto /etc/xrootd
-	doins packaging/common/*.cfg
-
-	fowners root:xrootd /etc/xrootd
-	keepdir /var/log/xrootd
-	fowners xrootd:xrootd /var/log/xrootd
-
-	local i
-	for i in cmsd frm_purged frm_xfrd xrootd; do
-		newinitd "${FILESDIR}"/${i}.initd ${i}
-	done
-	# all daemons MUST use single master config file
-	newconfd "${FILESDIR}"/xrootd.confd xrootd
-
-	dodoc docs/ReleaseNotes.txt
-	use doc && dohtml -r doxydoc/html/*
-}
diff --git a/net-libs/xrootd/xrootd-3.3.1.ebuild b/net-libs/xrootd/xrootd-3.3.1.ebuild
new file mode 100644
index 000000000000..4ca919d553e4
--- /dev/null
+++ b/net-libs/xrootd/xrootd-3.3.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xrootd/xrootd-3.3.1.ebuild,v 1.1 2013/03/23 15:22:10 bicatali Exp $
+
+EAPI=5
+
+inherit cmake-utils eutils user
+
+DURI="http://xrootd.slac.stanford.edu/doc/prod"
+
+DESCRIPTION="Extended ROOT remote file server"
+HOMEPAGE="http://xrootd.org/"
+SRC_URI="${HOMEPAGE}/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fuse kerberos perl readline ssl"
+
+RDEPEND="
+	!<sci-physics/root-5.32[xrootd]
+	sys-libs/zlib
+	fuse? ( sys-fs/fuse )
+	kerberos? ( virtual/krb5 )
+	perl? (
+		dev-lang/perl
+		readline? ( dev-perl/Term-ReadLine-Perl )
+	)
+	readline? ( sys-libs/readline )
+	ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+	doc? ( app-doc/doxygen[dot] )
+	perl? ( dev-lang/swig )"
+
+pkg_setup() {
+	enewgroup xrootd
+	enewuser xrootd -1 -1 "${EPREFIX}"/var/spool/xrootd xrootd
+}
+
+src_configure() {
+	local mycmakeargs=(
+		$(cmake-utils_use_enable fuse)
+		$(cmake-utils_use_enable kerberos KRB5)
+		$(cmake-utils_use_enable perl)
+		$(cmake-utils_use_enable readline)
+		$(cmake-utils_use_enable ssl CRYPTO)
+	)
+	cmake-utils_src_configure
+}
+
+src_compile() {
+	cmake-utils_src_compile
+	use doc && doxygen Doxyfile
+}
+
+src_install() {
+	cmake-utils_src_install
+
+	# base configs
+	insinto /etc/xrootd
+	doins packaging/common/*.cfg
+
+	fowners root:xrootd /etc/xrootd
+	keepdir /var/log/xrootd
+	fowners xrootd:xrootd /var/log/xrootd
+
+	local i
+	for i in cmsd frm_purged frm_xfrd xrootd; do
+		newinitd "${FILESDIR}"/${i}.initd ${i}
+	done
+	# all daemons MUST use single master config file
+	newconfd "${FILESDIR}"/xrootd.confd xrootd
+
+	dodoc docs/ReleaseNotes.txt
+	use doc && dohtml -r doxydoc/html/*
+}
-- 
cgit v1.2.3-65-gdbad