From 3ccb6a1f3ed4769dbc917e109da4037e80b0467e Mon Sep 17 00:00:00 2001
From: Kacper Kowalik <xarthisius@gentoo.org>
Date: Thu, 23 Aug 2012 09:36:49 +0000
Subject: Add missing inherit of user.eclass for enew{group,user}. Fix building
 with glibc-2.16 wrt #430252 by Diego Elio Pettenò <flameeyes@gentoo.org>
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
---
 sys-cluster/slurm/ChangeLog                        |  8 +++--
 .../slurm/files/slurm-2.3.4-glibc2.16.patch        | 35 ++++++++++++++++++++++
 sys-cluster/slurm/slurm-2.3.4.ebuild               |  6 ++--
 3 files changed, 45 insertions(+), 4 deletions(-)
 create mode 100644 sys-cluster/slurm/files/slurm-2.3.4-glibc2.16.patch

(limited to 'sys-cluster')

diff --git a/sys-cluster/slurm/ChangeLog b/sys-cluster/slurm/ChangeLog
index 076c000cdae0..9e67e6d0da8c 100644
--- a/sys-cluster/slurm/ChangeLog
+++ b/sys-cluster/slurm/ChangeLog
@@ -1,6 +1,11 @@
 # ChangeLog for sys-cluster/slurm
 # Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/slurm/ChangeLog,v 1.12 2012/05/09 07:37:21 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/slurm/ChangeLog,v 1.13 2012/08/23 09:36:49 xarthisius Exp $
+
+  23 Aug 2012; Kacper Kowalik <xarthisius@gentoo.org>
+  +files/slurm-2.3.4-glibc2.16.patch, slurm-2.3.4.ebuild:
+  Add missing inherit of user.eclass for enew{group,user}. Fix building with
+  glibc-2.16 wrt #430252 by Diego Elio Pettenò <flameeyes@gentoo.org>
 
   09 May 2012; Zac Medico <zmedico@gentoo.org> slurm-2.3.4.ebuild:
   Move EAPI assignment to top of ebuild, bug 411875.
@@ -57,4 +62,3 @@
   +files/slurm.confd, +files/slurmctld.initd, +files/slurmd.initd,
   +files/slurmdbd.initd, +metadata.xml:
   Initial import
-
diff --git a/sys-cluster/slurm/files/slurm-2.3.4-glibc2.16.patch b/sys-cluster/slurm/files/slurm-2.3.4-glibc2.16.patch
new file mode 100644
index 000000000000..34e8e59f2124
--- /dev/null
+++ b/sys-cluster/slurm/files/slurm-2.3.4-glibc2.16.patch
@@ -0,0 +1,35 @@
+Fix building with glibc-2.16
+
+https://bugs.gentoo.org/show_bug.cgi?id=430252
+
+Patch written by Kacper Kowalik <xarthisius@gentoo.org>
+--- a/src/common/jobacct_common.h
++++ b/src/common/jobacct_common.h
+@@ -55,6 +55,7 @@
+ 
+ #include <dirent.h>
+ #include <sys/stat.h>
++#include <sys/resource.h>
+ 
+ #include "slurm/slurmdb.h"
+ 
+--- a/src/salloc/salloc.c
++++ b/src/salloc/salloc.c
+@@ -49,6 +49,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <sys/param.h>
++#include <sys/resource.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ #include <termios.h>
+--- a/src/sbatch/sbatch.c
++++ b/src/sbatch/sbatch.c
+@@ -48,6 +48,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <sys/param.h>               /* MAXPATHLEN */
++#include <sys/resource.h>
+ #include <fcntl.h>
+ 
+ #include "slurm/slurm.h"
diff --git a/sys-cluster/slurm/slurm-2.3.4.ebuild b/sys-cluster/slurm/slurm-2.3.4.ebuild
index 4a5494b99dd6..39f9ab362565 100644
--- a/sys-cluster/slurm/slurm-2.3.4.ebuild
+++ b/sys-cluster/slurm/slurm-2.3.4.ebuild
@@ -1,11 +1,11 @@
 # Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/slurm/slurm-2.3.4.ebuild,v 1.3 2012/05/09 07:37:21 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/slurm/slurm-2.3.4.ebuild,v 1.4 2012/08/23 09:36:49 xarthisius Exp $
 
 EAPI=4
 RESTRICT="primaryuri"
 
-inherit eutils versionator pam perl-module
+inherit eutils versionator pam perl-module user
 
 MY_PV=$(replace_version_separator 3 '-') # stable releases
 #MY_PV=$(replace_version_separator 3 '-0.') # pre-releases
@@ -71,6 +71,8 @@ src_prepare() {
 	sed -e 's:/tmp:/var/tmp:g' \
 		-i "${S}/etc/slurm.conf.example" \
 			|| die "Can't sed for StateSaveLocation=*./tmp"
+
+	epatch "${FILESDIR}"/${P}-glibc2.16.patch
 }
 
 src_configure() {
-- 
cgit v1.2.3-65-gdbad