aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/qtkeychain/qtkeychain-9999.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-libs/qtkeychain/qtkeychain-9999.ebuild b/dev-libs/qtkeychain/qtkeychain-9999.ebuild
index ac90679..a267315 100644
--- a/dev-libs/qtkeychain/qtkeychain-9999.ebuild
+++ b/dev-libs/qtkeychain/qtkeychain-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils
+inherit cmake
HOMEPAGE="https://github.com/frankosterfeld/qtkeychain"
DESCRIPTION="Qt API for storing passwords securely"
@@ -20,13 +20,15 @@ LICENSE="BSD"
SLOT="0/1"
IUSE="gnome-keyring"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
RDEPEND="
dev-qt/qtcore:5
dev-qt/qtdbus:5
gnome-keyring? ( dev-libs/glib:2 )
"
DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
gnome-keyring? ( gnome-base/libgnome-keyring )
"
@@ -41,5 +43,5 @@ src_configure() {
-DLIBSECRET_SUPPORT=$(usex gnome-keyring)
)
- cmake-utils_src_configure
+ cmake_src_configure
}