summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2006-01-04 20:02:30 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2006-01-04 20:02:30 +0000
commit1620396a094e95020f7acb0a2b1a251c5efa5467 (patch)
tree18a75b50cba72ae875c47b50e0ce76c83f9cd28e
parentFixed digests (diff)
downloadoverlay-1620396a094e95020f7acb0a2b1a251c5efa5467.tar.gz
overlay-1620396a094e95020f7acb0a2b1a251c5efa5467.tar.bz2
overlay-1620396a094e95020f7acb0a2b1a251c5efa5467.zip
Another webapp-config test fix
svn path=/; revision=608
-rw-r--r--app-admin/webapp-config/webapp-config-1.50.4.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/app-admin/webapp-config/webapp-config-1.50.4.ebuild b/app-admin/webapp-config/webapp-config-1.50.4.ebuild
index 97992fa..77043bf 100644
--- a/app-admin/webapp-config/webapp-config-1.50.4.ebuild
+++ b/app-admin/webapp-config/webapp-config-1.50.4.ebuild
@@ -35,7 +35,11 @@ src_install() {
src_test() {
cd ${S}
- PYTHONPATH="." ${python} WebappConfig/tests/dtest.py || die "DocTests failed - please submit a bug report"
+ einfo "Running webapp-config doctests..."
+ if ! PYTHONPATH="." ${python} WebappConfig/tests/dtest.py; then
+ eerror "DocTests failed - please submit a bug report"
+ die "DocTesting failed!"
+ fi
}
pkg_postinst() {