aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-09-12 23:44:29 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-02-08 23:55:37 +0200
commit9fba5f3959c4fbdfafad5a44d22ce7680c114511 (patch)
tree839ec7e6deaf9983bf6c8e505e99e32ecd0f96ae
parentGentoo: opcodes: link against libbfd.la for rpath deps (diff)
downloadbinutils-gdb-9fba5f3959c4fbdfafad5a44d22ce7680c114511.tar.gz
binutils-gdb-9fba5f3959c4fbdfafad5a44d22ce7680c114511.tar.bz2
binutils-gdb-9fba5f3959c4fbdfafad5a44d22ce7680c114511.zip
Gentoo: add --with-extra-soversion-suffix= option
--with-extra-soversion-suffix= will allow Gentoo to distinct libbfd.so and libopcodes.so to have more precise SONAME. Today --enable-targets=all and --enable-64-bit-bfd change libbfd.so ABI: --enable-targets=all adds new symbols to the library --enable-64-bit-bfd modifies BFD_ARCH_SIZE default and changes sizes of integer parameters and fields to most APIs. --with-extra-soversion-suffix= will allow Gentoo to inject additional keys into SONAME to indicate ABI change and avoid hard to diagnose crashes when user reinstalls libbfd.so built with different flags (see https://bugs.gentoo.org/663690). Bug: https://bugs.gentoo.org/666100 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--bfd/Makefile.am5
-rw-r--r--bfd/Makefile.in4
-rwxr-xr-xbfd/configure13
-rw-r--r--bfd/configure.ac7
4 files changed, 29 insertions, 0 deletions
diff --git a/bfd/Makefile.am b/bfd/Makefile.am
index 9908249fdd5..c5545d0ef5a 100644
--- a/bfd/Makefile.am
+++ b/bfd/Makefile.am
@@ -59,6 +59,8 @@ bfdinclude_HEADERS += $(INCDIR)/plugin-api.h
LIBDL = @lt_cv_dlopen_libs@
endif
+EXTRA_SOVERSION_SUFFIX = @EXTRA_SOVERSION_SUFFIX@
+
# bfd.h goes here, for now
BFD_H = bfd.h
@@ -952,6 +954,9 @@ bfdver.h: $(srcdir)/version.h $(srcdir)/development.sh $(srcdir)/Makefile.in
bfd_version_string="\"$(VERSION).$${bfd_version_date}\"" ;\
bfd_soversion="$(VERSION).$${bfd_version_date}" ;\
fi ;\
+ if test x"$(EXTRA_SOVERSION_SUFFIX)" != x ; then \
+ bfd_soversion="$${bfd_soversion}.$(EXTRA_SOVERSION_SUFFIX)" ;\
+ fi ;\
$(SED) -e "s,@bfd_version@,$$bfd_version," \
-e "s,@bfd_version_string@,$$bfd_version_string," \
-e "s,@bfd_version_package@,$$bfd_version_package," \
diff --git a/bfd/Makefile.in b/bfd/Makefile.in
index 60fe040af02..9dfecf63c36 100644
--- a/bfd/Makefile.in
+++ b/bfd/Makefile.in
@@ -318,6 +318,7 @@ ECHO_T = @ECHO_T@
EGREP = @EGREP@
EXEEXT = @EXEEXT@
EXEEXT_FOR_BUILD = @EXEEXT_FOR_BUILD@
+EXTRA_SOVERSION_SUFFIX = @EXTRA_SOVERSION_SUFFIX@
FGREP = @FGREP@
GENCAT = @GENCAT@
GMSGFMT = @GMSGFMT@
@@ -2063,6 +2064,9 @@ bfdver.h: $(srcdir)/version.h $(srcdir)/development.sh $(srcdir)/Makefile.in
bfd_version_string="\"$(VERSION).$${bfd_version_date}\"" ;\
bfd_soversion="$(VERSION).$${bfd_version_date}" ;\
fi ;\
+ if test x"$(EXTRA_SOVERSION_SUFFIX)" != x ; then \
+ bfd_soversion="$${bfd_soversion}.$(EXTRA_SOVERSION_SUFFIX)" ;\
+ fi ;\
$(SED) -e "s,@bfd_version@,$$bfd_version," \
-e "s,@bfd_version_string@,$$bfd_version_string," \
-e "s,@bfd_version_package@,$$bfd_version_package," \
diff --git a/bfd/configure b/bfd/configure
index 1e3ff33616d..be3f4361d81 100755
--- a/bfd/configure
+++ b/bfd/configure
@@ -696,6 +696,7 @@ WARN_CFLAGS
REPORT_BUGS_TEXI
REPORT_BUGS_TO
PKGVERSION
+EXTRA_SOVERSION_SUFFIX
DEBUGDIR
PLUGINS_FALSE
PLUGINS_TRUE
@@ -834,6 +835,7 @@ enable_secureplt
enable_separate_code
enable_leading_mingw64_underscores
with_separate_debug_dir
+with_extra_soversion_suffix
with_pkgversion
with_bugurl
enable_werror
@@ -1509,6 +1511,8 @@ Optional Packages:
--with-separate-debug-dir=DIR
Look for global separate debug info in DIR
[[default=LIBDIR/debug]]
+ --with-extra-soversion-suffix=SUFFIX
+ Append '.SUFFIX' to SONAME [default=]
--with-pkgversion=PKG Use PKG in the version string in place of "GNU
Binutils"
--with-bugurl=URL Direct users to URL to report a bug
@@ -12572,6 +12576,15 @@ fi
+EXTRA_SOVERSION_SUFFIX=
+
+# Check whether --with-extra-soversion-suffix was given.
+if test "${with_extra_soversion_suffix+set}" = set; then :
+ withval=$with_extra_soversion_suffix; EXTRA_SOVERSION_SUFFIX="${withval}"
+fi
+
+
+
# Check whether --with-pkgversion was given.
diff --git a/bfd/configure.ac b/bfd/configure.ac
index 0797a08ff37..bcb9221f139 100644
--- a/bfd/configure.ac
+++ b/bfd/configure.ac
@@ -157,6 +157,13 @@ AC_ARG_WITH(separate-debug-dir,
[DEBUGDIR="${withval}"])
AC_SUBST(DEBUGDIR)
+EXTRA_SOVERSION_SUFFIX=
+AC_ARG_WITH(extra-soversion-suffix,
+ AS_HELP_STRING([--with-extra-soversion-suffix=SUFFIX],
+ [Append '.SUFFIX' to SONAME [[default=]]]),
+[EXTRA_SOVERSION_SUFFIX="${withval}"])
+AC_SUBST(EXTRA_SOVERSION_SUFFIX)
+
ACX_PKGVERSION([GNU Binutils])
ACX_BUGURL([http://www.sourceware.org/bugzilla/])