aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-07-05 20:24:00 +0545
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-20 21:09:39 +0200
commitc55536c61ec7e4c2e983e15f51f56f7a7c340889 (patch)
tree9f977fc0e3544cb15a314274f6d43932ab87f4e1
parentGentoo: libiberty: install PIC version of libiberty.a (diff)
downloadbinutils-gdb-c55536c61ec7e4c2e983e15f51f56f7a7c340889.tar.gz
binutils-gdb-c55536c61ec7e4c2e983e15f51f56f7a7c340889.tar.bz2
binutils-gdb-c55536c61ec7e4c2e983e15f51f56f7a7c340889.zip
Gentoo: opcodes: link against libbfd.la for rpath deps
The reason opcodes doesn't link against libbfd.la is to workaround a libtool bug where it uses installed -L paths ahead of DESTDIR paths. The downside is that the library itself lacks rpath tags to find the right version of libbfd.so. Since Gentoo has patched the libtool bug for a while, we don't need the workaround. Use the .la file so we get the rpath tags. URL: https://bugs.gentoo.org/563934 (cherry picked from commit 662586237b0b00ee881e79b56f6234ff36e8bfe6)
-rwxr-xr-xopcodes/configure2
-rw-r--r--opcodes/configure.ac2
2 files changed, 2 insertions, 2 deletions
diff --git a/opcodes/configure b/opcodes/configure
index a3da5987f1b..22a05245286 100755
--- a/opcodes/configure
+++ b/opcodes/configure
@@ -12142,7 +12142,7 @@ if test "$enable_shared" = "yes"; then
SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.sl ${SHARED_LIBADD}"
;;
*)
- SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.so ${SHARED_LIBADD}"
+ SHARED_LIBADD="../bfd/libbfd.la ${SHARED_LIBADD}"
;;
esac
SHARED_DEPENDENCIES="../bfd/libbfd.la"
diff --git a/opcodes/configure.ac b/opcodes/configure.ac
index e564f067334..fb6254cd69d 100644
--- a/opcodes/configure.ac
+++ b/opcodes/configure.ac
@@ -203,7 +203,7 @@ if test "$enable_shared" = "yes"; then
SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.sl ${SHARED_LIBADD}"
;;
*)
- SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.so ${SHARED_LIBADD}"
+ SHARED_LIBADD="../bfd/libbfd.la ${SHARED_LIBADD}"
;;
esac
SHARED_DEPENDENCIES="../bfd/libbfd.la"