aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-07 00:15:53 -0500
committerAndreas K. Hüttel <dilfridge@gentoo.org>2022-02-10 12:34:31 +0100
commitb4cc4742beac5340fa99e9fbfb81b65400e5ea55 (patch)
treec085cf5c05054249c03658e7362d30cb8d11d69c
parentGentoo: gold/ld: add support for poisoned system directories (diff)
downloadbinutils-gdb-b4cc4742beac5340fa99e9fbfb81b65400e5ea55.tar.gz
binutils-gdb-b4cc4742beac5340fa99e9fbfb81b65400e5ea55.tar.bz2
binutils-gdb-b4cc4742beac5340fa99e9fbfb81b65400e5ea55.zip
Gentoo: libiberty: install PIC version of libiberty.a
This will install a PIC version of libiberty.a by overwriting the non-PIC version of libiberty.a while compiling. We do this because there is no shared version of libiberty for random apps to link against which means if someone wants to use this in a shared library or PIE, they're out of luck. It's arguable whether people should be able to use this in a shared lib, but usage in PIE should be fine. You could argue that this penalizes the non-PIE users, but the counter point is that people using this library in general are fairly low, and we'd rather have things work for all of them. (cherry picked from commit 112aff9ad3e2675556370c4281117a6df0a879d9)
-rw-r--r--libiberty/Makefile.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/libiberty/Makefile.in b/libiberty/Makefile.in
index abef3c4601b..9dfb6b6d2b0 100644
--- a/libiberty/Makefile.in
+++ b/libiberty/Makefile.in
@@ -258,6 +258,7 @@ $(TARGETLIB): $(REQUIRED_OFILES) $(EXTRA_OFILES) $(LIBOBJS)
$(AR) $(AR_FLAGS) $(TARGETLIB) \
$(REQUIRED_OFILES) $(EXTRA_OFILES) $(LIBOBJS); \
$(RANLIB) $(TARGETLIB); \
+ cp $(TARGETLIB) ../ ; \
cd ..; \
else true; fi; \
if [ x"$(NOASANFLAG)" != x ]; then \