summaryrefslogtreecommitdiff
path: root/Mac
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2018-03-28 01:40:29 -0700
committerNed Deily <nad@python.org>2018-03-28 04:40:29 -0400
commitfb3d3b7a65d8c0521a88c87e17a7554c5ec439d9 (patch)
tree4c225ec280690e1cae104c04a6f2ff9364422bfb /Mac
parentbpo-32872: Avoid regrtest compatibility issue with namespace packages. (GH-62... (diff)
downloadcpython-fb3d3b7a65d8c0521a88c87e17a7554c5ec439d9.tar.gz
cpython-fb3d3b7a65d8c0521a88c87e17a7554c5ec439d9.tar.bz2
cpython-fb3d3b7a65d8c0521a88c87e17a7554c5ec439d9.zip
bpo-32726: Do not force IDLE.app to launch in 32-bit mode. (GH-6279) (#6281)
Forcing the macOS IDLE.app gui process to launch in 32-mode was a necessary hack for old versions of Tk (Aqua Carbon as in Tk 8.4 and early versions of 8.5); it is not needed for current versions of Tk. Since 32-bit launching will no longer be supported on future releases of macOS, allow IDLE.app to launch in 64-bit mode. (cherry picked from commit df532ab752680f6e359672c2cd40bec8ac848628) Co-authored-by: Ned Deily <nad@python.org>
Diffstat (limited to 'Mac')
-rw-r--r--Mac/Makefile.in4
1 files changed, 0 insertions, 4 deletions
diff --git a/Mac/Makefile.in b/Mac/Makefile.in
index 1255b13b424..95fd4a2722d 100644
--- a/Mac/Makefile.in
+++ b/Mac/Makefile.in
@@ -221,10 +221,6 @@ install_IDLE:
-test -d "$(DESTDIR)$(PYTHONAPPSDIR)/IDLE.app" && rm -rf "$(DESTDIR)$(PYTHONAPPSDIR)/IDLE.app"
/bin/cp -PR "$(srcdir)/IDLE/IDLE.app" "$(DESTDIR)$(PYTHONAPPSDIR)"
ln -sf "$(INSTALLED_PYTHONAPP)" "$(DESTDIR)$(PYTHONAPPSDIR)/IDLE.app/Contents/MacOS/Python"
-ifneq ($(LIPO_32BIT_FLAGS),)
- rm "$(DESTDIR)$(PYTHONAPPSDIR)/IDLE.app/Contents/MacOS/Python"
- lipo $(LIPO_32BIT_FLAGS) -output "$(DESTDIR)$(PYTHONAPPSDIR)/IDLE.app/Contents/MacOS/Python" "$(BUILDPYTHON)"
-endif
sed -e "s!%prefix%!$(prefix)!g" -e 's!%exe%!$(PYTHONFRAMEWORK)!g' < "$(srcdir)/IDLE/IDLE.app/Contents/MacOS/IDLE" > "$(DESTDIR)$(PYTHONAPPSDIR)/IDLE.app/Contents/MacOS/IDLE"
sed "s!%version%!`$(RUNSHARED) $(BUILDPYTHON) -c 'import platform; print(platform.python_version())'`!g" < "$(srcdir)/IDLE/IDLE.app/Contents/Info.plist" > "$(DESTDIR)$(PYTHONAPPSDIR)/IDLE.app/Contents/Info.plist"
if [ -f "$(DESTDIR)$(LIBDEST)/idlelib/config-main.def" ]; then \