aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-04 13:28:13 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2024-05-04 14:35:45 +0200
commit54992c91ed89929e562ffc95e414340d0832677e (patch)
tree9ac323a62ca778ce80996f97b898f0142629b834
parentAdd a test to check for duplicate definitions in the static library (diff)
downloadglibc-54992c91ed89929e562ffc95e414340d0832677e.tar.gz
glibc-54992c91ed89929e562ffc95e414340d0832677e.tar.bz2
glibc-54992c91ed89929e562ffc95e414340d0832677e.zip
Revert "Add a test to check for duplicate definitions in the static library"
This reverts commit ff110b2591f0bdeccd121c3726af19c62d6fb184. I had the wrong cherry-pick reference (the commit content is right; it's just referring to a base that isn't upstream), but let's revert and reapply for clarity. Signed-off-by: Sam James <sam@gentoo.org> (cherry picked from commit fa616ea3730cb42046d19f28d611be0bc390af7c)
-rw-r--r--Makefile7
1 files changed, 0 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index af34adec20..a13cdb20c2 100644
--- a/Makefile
+++ b/Makefile
@@ -578,13 +578,6 @@ $(objpfx)lint-makefiles.out: scripts/lint-makefiles.sh
$(SHELL) $< "$(PYTHON)" `pwd` > $@ ; \
$(evaluate-test)
-# Link libc.a as a whole to verify that it does not contain multiple
-# definitions of any symbols.
-tests-special += $(objpfx)link-static-libc.out
-$(objpfx)link-static-libc.out:
- $(LINK.o) $(whole-archive) -r $(objpfx)libc.a -o /dev/null > $@ 2>&1; \
- $(evaluate-test)
-
# Print test summary for tests in $1 .sum file;
# $2 is optional test identifier.
# Fail if there are unexpected failures in the test results.