summaryrefslogtreecommitdiff
path: root/htl
diff options
context:
space:
mode:
authorGuy-Fleury Iteriteka <gfleury@disroot.org>2023-07-16 10:44:05 +0200
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2023-08-24 01:56:57 +0200
commit9dfa2562162bf5f7ad1d85d34d827c388631fd86 (patch)
tree9eb401cd573f9e9d6798b1f9b6a5d11a03907a68 /htl
parentLinux: Avoid conflicting types in ld.so --list-diagnostics (diff)
downloadglibc-9dfa2562162bf5f7ad1d85d34d827c388631fd86.tar.gz
glibc-9dfa2562162bf5f7ad1d85d34d827c388631fd86.tar.bz2
glibc-9dfa2562162bf5f7ad1d85d34d827c388631fd86.zip
htl: move pthread_equal into libc
Signed-off-by: Guy-Fleury Iteriteka <gfleury@disroot.org> Message-Id: <20230716084414.107245-2-gfleury@disroot.org>
Diffstat (limited to 'htl')
-rw-r--r--htl/Makefile3
-rw-r--r--htl/Versions2
-rw-r--r--htl/forward.c4
-rw-r--r--htl/pt-initialize.c1
4 files changed, 2 insertions, 8 deletions
diff --git a/htl/Makefile b/htl/Makefile
index 5de036acfd..b131aa19ab 100644
--- a/htl/Makefile
+++ b/htl/Makefile
@@ -46,7 +46,6 @@ libpthread-routines := pt-attr pt-attr-destroy pt-attr-getdetachstate \
pt-alloc \
pt-create \
pt-getattr \
- pt-equal \
pt-dealloc \
pt-detach \
pt-exit \
@@ -165,7 +164,7 @@ headers := \
distribute :=
-routines := forward libc_pthread_init alloca_cutoff htlfreeres pt-nthreads pt-pthread_self pt-self
+routines := forward libc_pthread_init alloca_cutoff htlfreeres pt-nthreads pt-pthread_self pt-self pt-equal
shared-only-routines = forward
extra-libs := libpthread
diff --git a/htl/Versions b/htl/Versions
index 70fa44631a..c2be77997b 100644
--- a/htl/Versions
+++ b/htl/Versions
@@ -89,7 +89,7 @@ libpthread {
pthread_condattr_getpshared; pthread_condattr_init;
pthread_condattr_setclock; pthread_condattr_setpshared;
- pthread_create; pthread_detach; pthread_equal; pthread_exit;
+ pthread_create; pthread_detach; pthread_exit;
pthread_getattr_np;
diff --git a/htl/forward.c b/htl/forward.c
index 1bee2b0203..a8147d362c 100644
--- a/htl/forward.c
+++ b/htl/forward.c
@@ -102,10 +102,6 @@ FORWARD (pthread_cond_timedwait,
(pthread_cond_t *cond, pthread_mutex_t *mutex,
const struct timespec *abstime), (cond, mutex, abstime), 0)
-FORWARD (pthread_equal, (pthread_t thread1, pthread_t thread2),
- (thread1, thread2), 1)
-
-
/* Use an alias to avoid warning, as pthread_exit is declared noreturn. */
FORWARD_NORETURN (__pthread_exit, void, (void *retval), (retval),
exit (EXIT_SUCCESS))
diff --git a/htl/pt-initialize.c b/htl/pt-initialize.c
index aa8561f7d5..0386b755af 100644
--- a/htl/pt-initialize.c
+++ b/htl/pt-initialize.c
@@ -47,7 +47,6 @@ static const struct pthread_functions pthread_functions = {
.ptr_pthread_cond_signal = __pthread_cond_signal,
.ptr_pthread_cond_wait = __pthread_cond_wait,
.ptr_pthread_cond_timedwait = __pthread_cond_timedwait,
- .ptr_pthread_equal = __pthread_equal,
.ptr___pthread_exit = __pthread_exit,
.ptr_pthread_getschedparam = __pthread_getschedparam,
.ptr_pthread_setschedparam = __pthread_setschedparam,