aboutsummaryrefslogtreecommitdiff
path: root/libc
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2022-01-23 05:30:32 +0000
committerJohn Ericson <John.Ericson@Obsidian.Systems>2022-01-24 18:36:37 +0000
commit0a3d946e7bb4cd3519370c879dac7cbb58d13a55 (patch)
treea10740e78297bb0f65b709c4c630379bab380742 /libc
parent[ConstraintElimination] Fix sign of sub decomposition. (diff)
downloadllvm-project-0a3d946e7bb4cd3519370c879dac7cbb58d13a55.tar.gz
llvm-project-0a3d946e7bb4cd3519370c879dac7cbb58d13a55.tar.bz2
llvm-project-0a3d946e7bb4cd3519370c879dac7cbb58d13a55.zip
[libc][cmake] Make `add_tablegen` calls match others
in all the other `add_tablegen` calls, the project name is so transformed so it can be a prefix of a CMake variable. I think it is better to do do that here too for consistency. Reviewed By: sivachandra Differential Revision: https://reviews.llvm.org/D117979
Diffstat (limited to 'libc')
-rw-r--r--libc/utils/HdrGen/PrototypeTestGen/CMakeLists.txt2
-rw-r--r--libc/utils/tools/WrapperGen/CMakeLists.txt2
2 files changed, 2 insertions, 2 deletions
diff --git a/libc/utils/HdrGen/PrototypeTestGen/CMakeLists.txt b/libc/utils/HdrGen/PrototypeTestGen/CMakeLists.txt
index c90fde76dd58..9e25c21c6b35 100644
--- a/libc/utils/HdrGen/PrototypeTestGen/CMakeLists.txt
+++ b/libc/utils/HdrGen/PrototypeTestGen/CMakeLists.txt
@@ -1,4 +1,4 @@
-add_tablegen(libc-prototype-testgen llvm-libc
+add_tablegen(libc-prototype-testgen LLVM_LIBC
PrototypeTestGen.cpp
)
target_link_libraries(libc-prototype-testgen PRIVATE LibcTableGenUtil)
diff --git a/libc/utils/tools/WrapperGen/CMakeLists.txt b/libc/utils/tools/WrapperGen/CMakeLists.txt
index fe8ffcce94a5..5fd78591e9b3 100644
--- a/libc/utils/tools/WrapperGen/CMakeLists.txt
+++ b/libc/utils/tools/WrapperGen/CMakeLists.txt
@@ -1,6 +1,6 @@
set(LLVM_LINK_COMPONENTS Support)
-add_tablegen(libc-wrappergen llvm-libc
+add_tablegen(libc-wrappergen LLVM_LIBC
Main.cpp
)