aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTodd Fiala <todd.fiala@gmail.com>2015-11-18 17:36:15 +0000
committerTodd Fiala <todd.fiala@gmail.com>2015-11-18 17:36:15 +0000
commit7d1da7e91cab9cea9d4df5a33e0fd20b567583a8 (patch)
tree7a2b2ea1e6191bab4644e848be811b2e215cb404 /lldb/scripts/CMakeLists.txt
parentAccept -whole-archive and -no-whole-archive (with a single dash) (diff)
downloadllvm-project-7d1da7e91cab9cea9d4df5a33e0fd20b567583a8.tar.gz
llvm-project-7d1da7e91cab9cea9d4df5a33e0fd20b567583a8.tar.bz2
llvm-project-7d1da7e91cab9cea9d4df5a33e0fd20b567583a8.zip
Switched cmake build from using buildSwigWrapperClases.py to the cleaned up version.
This change does not introduce static bindings. It is simply using the pylinted cleaned up code in prepare_bindings.py. If this breaks anyting, I'll revert immediately and figure out what needs to be addressed. I'm looking to wrap up the cleanup aspect of the code change (pylinted, removal of code that implements existing python stdlib code, fixes for Xcode adoption, etc.). llvm-svn: 253478
Diffstat (limited to 'lldb/scripts/CMakeLists.txt')
-rw-r--r--lldb/scripts/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/lldb/scripts/CMakeLists.txt b/lldb/scripts/CMakeLists.txt
index 0b846466e647..6aec9b0fe2af 100644
--- a/lldb/scripts/CMakeLists.txt
+++ b/lldb/scripts/CMakeLists.txt
@@ -18,9 +18,10 @@ add_custom_command(
DEPENDS ${SWIG_HEADERS}
DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/Python/buildSwigPython.py
DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/Python/modify-python-lldb.py
- COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/buildSwigWrapperClasses.py "--srcRoot=${LLDB_SOURCE_DIR}" "--targetDir=${CMAKE_CURRENT_BINARY_DIR}" "--cfgBldDir=${CMAKE_CURRENT_BINARY_DIR}" "--prefix=${CMAKE_BINARY_DIR}" "--swigExecutable=${SWIG_EXECUTABLE}" -m
+ COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/prepare_bindings.py "--srcRoot=${LLDB_SOURCE_DIR}" "--targetDir=${CMAKE_CURRENT_BINARY_DIR}" "--cfgBldDir=${CMAKE_CURRENT_BINARY_DIR}" "--prefix=${CMAKE_BINARY_DIR}" "--swigExecutable=${SWIG_EXECUTABLE}"
COMMENT "Python script building LLDB Python wrapper")
set_source_files_properties(${CMAKE_CURRENT_BINARY_DIR}/LLDBWrapPython.cpp PROPERTIES GENERATED 1)
+set_source_files_properties(${CMAKE_CURRENT_BINARY_DIR}/lldb.py PROPERTIES GENERATED 1)
add_custom_target(swig_wrapper ALL
DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/LLDBWrapPython.cpp