aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTodd Fiala <tfiala@google.com>2014-02-26 07:39:20 +0000
committerTodd Fiala <tfiala@google.com>2014-02-26 07:39:20 +0000
commit9bb71b73d92331d1fb3d7561a44443252be813a7 (patch)
tree1235716bca3b11121bf4b593e0d2de02cdb11a86 /lldb/scripts/CMakeLists.txt
parent[SROA] Split the alignment computation complete for the memcpy rewriting (diff)
downloadllvm-project-9bb71b73d92331d1fb3d7561a44443252be813a7.tar.gz
llvm-project-9bb71b73d92331d1fb3d7561a44443252be813a7.tar.bz2
llvm-project-9bb71b73d92331d1fb3d7561a44443252be813a7.zip
Suppress python readline module under Linux to fix a seg fault.
Bug fix for pr18841: http://llvm.org/bugs/show_bug.cgi?id=18841 This change creates a stub Python readline.so module that does almost nothing. Its whole purpose is to prevent Python from loading the real module, something it does during the embedded Python interpreter's initialization sequence (and way before lldb ever requests it within embedded_interpreter.py). On Ubuntu 12.04 and 13.10 x86_64, and in the Python 2.7.6 tree, the stock Python readline module links against the GNU readline library. This appears to be the case on all Pythons except where __APPLE__ is defined. LLDB now requires linking against the libedit library. Something about having both libedit.so and libreadline.so linked into the same process space is causing the Python readline.so to trigger a NULL memory access. I have put in a separate patch to python.org. This suppression of embedded interpreter readline support can be removed if at least any one of the following happens: 1. The stock python distribution accepts a patch similar to what I submitted to Python 2.7.6's Modules/readline.c file. 2. The stock python distribution implements Modules/readline.c in terms of libedit's readline compatibility mode (i.e. essentially compiles it the way __APPLE__ compiles that module) under Linux. 3. a clean-room implementation of the python readline module is implemented against libedit (either readline compatibility mode or native libedit). This could be implemented within the readline.cpp file that this change introduces. It cannot be a fork of python's readline.c module due to llvm licensing. The net effect of this change on Linux is that the embedded python's readline support will not exist. llvm-svn: 202243
Diffstat (limited to 'lldb/scripts/CMakeLists.txt')
-rw-r--r--lldb/scripts/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/lldb/scripts/CMakeLists.txt b/lldb/scripts/CMakeLists.txt
index 444ed0f097fb..9b2f2db54bb4 100644
--- a/lldb/scripts/CMakeLists.txt
+++ b/lldb/scripts/CMakeLists.txt
@@ -18,3 +18,6 @@ ADD_CUSTOM_TARGET(swig_wrapper ALL echo -n
if (NOT CMAKE_SYSTEM_NAME MATCHES "Windows")
install(SCRIPT lldb_python_module.cmake -DCMAKE_INSTALL_PREFIX=\"${CMAKE_INSTALL_PREFIX}\" -DCMAKE_BUILD_DIR=\"${CMAKE_BUILD_DIR}\")
endif()
+
+# build Python modules
+add_subdirectory(Python/modules)