aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavel Labath <labath@google.com>2017-10-31 13:23:19 +0000
committerPavel Labath <labath@google.com>2017-10-31 13:23:19 +0000
commitf753bfeeec449dcd0e56bfa98b359598e4798b1f (patch)
treeb90980fac499ccab6a8020ad07b487abe7647c34 /lldb/scripts/CMakeLists.txt
parent[ThinLTO] Double bits of module hash used for renaming (diff)
downloadllvm-project-f753bfeeec449dcd0e56bfa98b359598e4798b1f.tar.gz
llvm-project-f753bfeeec449dcd0e56bfa98b359598e4798b1f.tar.bz2
llvm-project-f753bfeeec449dcd0e56bfa98b359598e4798b1f.zip
Fix LLVM_LINK_LLVM_DYLIB build (pr35053)
Summary: r316368 broke this build when it introduced a reference to a pthread function to the Utility module. This caused cmake to generate an incorrect link line (wrong order of libs) because it did not see the dependency from Utility to the system libraries. Instead these libraries were being manually added to each final target. This changes moves the dependency management from the individual targets to the lldbUtility module, which is consistent with how llvm does it. The final targets will pick up these libraries as they will be a part of the link interface of the module. Technically, some of these dependencies could go into the host module, as that's where most of the os-specific code is, but I did not try to investigate which ones. Reviewers: zturner, sylvestre.ledru Subscribers: lldb-commits, mgorny Differential Revision: https://reviews.llvm.org/D39246 llvm-svn: 316997
Diffstat (limited to 'lldb/scripts/CMakeLists.txt')
-rw-r--r--lldb/scripts/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/lldb/scripts/CMakeLists.txt b/lldb/scripts/CMakeLists.txt
index fad841b37c09..1fe34115244b 100644
--- a/lldb/scripts/CMakeLists.txt
+++ b/lldb/scripts/CMakeLists.txt
@@ -48,10 +48,10 @@ add_custom_command(
--swigExecutable=${SWIG_EXECUTABLE}
VERBATIM
COMMENT "Python script building LLDB Python wrapper")
-set_source_files_properties(${LLDB_WRAP_PYTHON} PROPERTIES GENERATED 1)
+add_custom_target(swig_wrapper ALL DEPENDS ${LLDB_WRAP_PYTHON})
+
set_source_files_properties(${CMAKE_CURRENT_BINARY_DIR}/lldb.py PROPERTIES GENERATED 1)
-add_custom_target(swig_wrapper ALL DEPENDS ${LLDB_WRAP_PYTHON})
# Install the LLDB python module
install(DIRECTORY ${SWIG_PYTHON_DIR} DESTINATION ${SWIG_INSTALL_DIR})