aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Trevino Ferrer <diegof30@gmail.com>2019-08-08 22:16:33 +0000
committerDiego Trevino Ferrer <diegof30@gmail.com>2019-08-08 22:16:33 +0000
commitddc64eb948c7e71039325f21bc4e1cc763494da5 (patch)
treedbe0cd9c324b0fbad0c464911ee0ec74057a9873 /llvm/test/CMakeLists.txt
parentLinker: Add support for GlobalIFunc. (diff)
downloadllvm-project-ddc64eb948c7e71039325f21bc4e1cc763494da5.tar.gz
llvm-project-ddc64eb948c7e71039325f21bc4e1cc763494da5.tar.bz2
llvm-project-ddc64eb948c7e71039325f21bc4e1cc763494da5.zip
Added Delta IR Reduction Tool
Summary: Tool parses input IR file, and runs the delta debugging algorithm to reduce the functions inside the input file. Reviewers: alexshap, chandlerc Subscribers: mgorny, llvm-commits Tags: #llvm Differential Revision: https://reviews.llvm.org/D63672 > llvm-svn: 368071 llvm-svn: 368358
Diffstat (limited to 'llvm/test/CMakeLists.txt')
-rw-r--r--llvm/test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/llvm/test/CMakeLists.txt b/llvm/test/CMakeLists.txt
index 03d154e39d02..a409cd31af54 100644
--- a/llvm/test/CMakeLists.txt
+++ b/llvm/test/CMakeLists.txt
@@ -89,6 +89,7 @@ set(LLVM_TEST_DEPENDS
llvm-rc
llvm-readobj
llvm-readelf
+ llvm-reduce
llvm-rtdyld
llvm-size
llvm-split