summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Grosser <grosser@fim.uni-passau.de>2011-06-30 19:50:04 +0000
committerTobias Grosser <grosser@fim.uni-passau.de>2011-06-30 19:50:04 +0000
commit080307119ee5a6114686293dce2aa711f59bf6dc (patch)
tree61082d44fa78271d5cfb185570b15addb283ddb0 /polly/Makefile.config.in
parentCodeGeneration: Adapt to SCEVExpander change (diff)
downloadllvm-project-080307119ee5a6114686293dce2aa711f59bf6dc.tar.gz
llvm-project-080307119ee5a6114686293dce2aa711f59bf6dc.tar.bz2
llvm-project-080307119ee5a6114686293dce2aa711f59bf6dc.zip
Buildsystem: Add -no-rtti
Build Polly without run time type info (rtti), as otherwise Polly cannot be loaded into a LLVM that is built without rtti. llvm-svn: 134180
Diffstat (limited to 'polly/Makefile.config.in')
-rwxr-xr-xpolly/Makefile.config.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/polly/Makefile.config.in b/polly/Makefile.config.in
index d4f24d1c4888..197a3aa113cd 100755
--- a/polly/Makefile.config.in
+++ b/polly/Makefile.config.in
@@ -26,6 +26,8 @@ ifeq (@GXX@,yes)
POLLY_CXXFLAGS := "-fno-common -Woverloaded-virtual -Wno-long-long -Wall -W -Wno-unused-parameter -Wwrite-strings"
endif
+POLLY_CXXFLAGS += "-fno-rtti -fno-exceptions"
+
# Do us work with scoplib?
OPENSCOP_FOUND := @openscop_found@
SCOPLIB_FOUND := @scoplib_found@