summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina (Zero_Chaos) <zerochaos@gentoo.org>2020-02-13 11:40:08 -0500
committerRick Farina (Zero_Chaos) <zerochaos@gentoo.org>2020-02-13 11:40:48 -0500
commitdc295a5569353ef7a4f42a9b4796fd36f9520e68 (patch)
tree516e0d4212bec016b4ff89fab3b9dd3f90da2ecb
parentadd blake2 support (diff)
downloadcatalyst-dc295a5569353ef7a4f42a9b4796fd36f9520e68.tar.gz
catalyst-dc295a5569353ef7a4f42a9b4796fd36f9520e68.tar.bz2
catalyst-dc295a5569353ef7a4f42a9b4796fd36f9520e68.zip
update livecd/verify to control digest typecatalyst-4.0-branchpoint3.0.9
plus document it right Signed-off-by: Rick Farina (Zero_Chaos) <zerochaos@gentoo.org>
-rw-r--r--examples/livecd-stage2_template.spec7
-rwxr-xr-xtargets/support/create-iso.sh22
2 files changed, 21 insertions, 8 deletions
diff --git a/examples/livecd-stage2_template.spec b/examples/livecd-stage2_template.spec
index cc5cf00e..7dd64c3f 100644
--- a/examples/livecd-stage2_template.spec
+++ b/examples/livecd-stage2_template.spec
@@ -331,10 +331,11 @@ boot/kernel/gentoo/machine_type:
# boot/kernel/gentoo/console: tty0 ttyS0
boot/kernel/gentoo/console:
-# This feature will make sha512 checksums for every file in the iso (including files provided by livecd/overlay
+# This feature will make sha512, blake2, or both checksums for every file in the iso (including files provided by livecd/overlay
# These checksums can be verified at boot using the genkernel option "verify" added to the kernel line.
-# Currently this feature will be enabled if livecd/verify is defined to *any* value, leave commented to disable.
-#livecd/verify: true
+# Currently this feature will generate both checksums if livecd/verify is defined to *any* value other than "blake2" or "sha512"
+# No checksums are generated if this is left commented.
+#livecd/verify: sha512
# This feature controls the depclean run after fsscript and before unmerge.
# The default is unset, and will run emerge --depclean --with-bdeps=n which results
diff --git a/targets/support/create-iso.sh b/targets/support/create-iso.sh
index 92efaa8b..ed581763 100755
--- a/targets/support/create-iso.sh
+++ b/targets/support/create-iso.sh
@@ -98,14 +98,26 @@ fi
#from genkernel during boot. Here we make a function to create the sha512sums, and blake2sums
isoroot_checksum() {
echo "Creating checksums for all files included in the iso, please wait..."
- find "${clst_target_path}" -type f ! -name 'isoroot_checksums' ! -name 'isolinux.bin' ! -name 'isoroot_b2sums' -exec sha512sum {} + > "${clst_target_path}"/isoroot_checksums
- ${clst_sed} -i "s#${clst_target_path}/\?##" "${clst_target_path}"/isoroot_checksums
- find "${clst_target_path}" -type f ! -name 'isoroot_checksums' ! -name 'isolinux.bin' ! -name 'isoroot_b2sums' -exec b2sum {} + > "${clst_target_path}"/isoroot_b2sums
- ${clst_sed} -i "s#${clst_target_path}/\?##" "${clst_target_path}"/isoroot_b2sums
+ if [ -z "${1}" ] || [ "${1}" = "sha512" ]; then
+ find "${clst_target_path}" -type f ! -name 'isoroot_checksums' ! -name 'isolinux.bin' ! -name 'isoroot_b2sums' -exec sha512sum {} + > "${clst_target_path}"/isoroot_checksums
+ ${clst_sed} -i "s#${clst_target_path}/\?##" "${clst_target_path}"/isoroot_checksums
+ fi
+ if [ -z "${1}" ] || [ "${1}" = "blake2" ]; then
+ find "${clst_target_path}" -type f ! -name 'isoroot_checksums' ! -name 'isolinux.bin' ! -name 'isoroot_b2sums' -exec b2sum {} + > "${clst_target_path}"/isoroot_b2sums
+ ${clst_sed} -i "s#${clst_target_path}/\?##" "${clst_target_path}"/isoroot_b2sums
+ fi
}
run_mkisofs() {
- [ -n "${clst_livecd_verify}" ] && isoroot_checksum
+ if [ -n "${clst_livecd_verify}" ]; then
+ if [ "${clst_livecd_verify}" = "sha512" ]; then
+ isoroot_checksum sha512
+ elif [ "${clst_livecd_verify}" = "blake2" ]; then
+ isoroot_checksum blake2
+ else
+ isoroot_checksum
+ fi
+ fi
echo "Running \"mkisofs ${@}\""
mkisofs "${@}" || die "Cannot make ISO image"
}