summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/dtc/dtc-1.0.0.ebuild')
-rw-r--r--sys-apps/dtc/dtc-1.0.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-apps/dtc/dtc-1.0.0.ebuild b/sys-apps/dtc/dtc-1.0.0.ebuild
new file mode 100644
index 0000000..7361637
--- /dev/null
+++ b/sys-apps/dtc/dtc-1.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Utility to pre-compile Open Firmware device-trees for otherwise device-tree-less devices such as the PS3"
+HOMEPAGE="http://www.t2-project.org/packages/dtc.html"
+SRC_URI="http://www.jdl.com/software/dtc-${PV}.tgz"
+
+inherit eutils
+
+LICENSE="IPL-1"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64"
+IUSE=""
+
+
+src_compile () {
+ cd ${WORKDIR}/${PN}
+ emake
+}
+
+src_install () {
+ cd ${WORKDIR}/${PN}
+ make DESTDIR=${D}/usr PREFIX="" install
+ dodoc Documentation/manual.txt
+}