diff options
-rw-r--r-- | ChangeLog | 2 | ||||
-rwxr-xr-x | bin/eselect.in | 2 |
2 files changed, 3 insertions, 1 deletions
@@ -1,5 +1,7 @@ 2023-06-07 Ulrich Müller <ulm@gentoo.org> + * bin/eselect.in (PATH): Use printf instead of echo. + * configure.ac: Update version to 1.4.24. * Tagged 1.4.24 release. diff --git a/bin/eselect.in b/bin/eselect.in index 41d53d7..36581e1 100755 --- a/bin/eselect.in +++ b/bin/eselect.in @@ -62,7 +62,7 @@ umask +rx # Sanitise PATH: We don't want to execute Portage's internal helpers # if we're called from an ebuild. IFS=: -read -r -d '' -a path < <(echo -n "${PATH}") +read -r -d '' -a path < <(printf '%s\0' "${PATH}") for i in "${!path[@]}"; do [[ ${path[i]} == */portage?(/*)/ebuild-helpers?(/*) ]] && unset "path[i]" done |