summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-09-05 22:13:06 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-09-05 22:13:06 -0400
commitc1cf6cd3d2ad87c5731653b4992101801d093167 (patch)
tree594ee374dce9b493aa3d378e8ddf5f6693607dc4
parentmate-extra/mate-utils: Make utils available on all DEs, #585252 (diff)
downloadgentoo-mate-c1cf6cd3d2ad87c5731653b4992101801d093167.tar.gz
gentoo-mate-c1cf6cd3d2ad87c5731653b4992101801d093167.tar.bz2
gentoo-mate-c1cf6cd3d2ad87c5731653b4992101801d093167.zip
mate-base/mate-applets: backport kernel 4.7 support
Package-Manager: portage-2.3.0
-rw-r--r--mate-base/mate-applets/files/mate-applets-1.10.4-kernel-4.7.patch38
-rw-r--r--mate-base/mate-applets/mate-applets-1.10.4-r2.ebuild (renamed from mate-base/mate-applets/mate-applets-1.10.4-r1.ebuild)3
-rw-r--r--mate-base/mate-applets/mate-applets-1.12.1-r2.ebuild (renamed from mate-base/mate-applets/mate-applets-1.12.1-r1.ebuild)3
3 files changed, 44 insertions, 0 deletions
diff --git a/mate-base/mate-applets/files/mate-applets-1.10.4-kernel-4.7.patch b/mate-base/mate-applets/files/mate-applets-1.10.4-kernel-4.7.patch
new file mode 100644
index 0000000..afe06dc
--- /dev/null
+++ b/mate-base/mate-applets/files/mate-applets-1.10.4-kernel-4.7.patch
@@ -0,0 +1,38 @@
+From 1b4478eab642787c43601259611f7b27e0bb473b Mon Sep 17 00:00:00 2001
+From: leigh123linux <leigh123linux@googlemail.com>
+Date: Thu, 9 Jun 2016 10:06:34 +0100
+Subject: [PATCH] fix build with kernel-4.7
+
+---
+ cpufreq/src/cpufreq-monitor-libcpufreq.c | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/cpufreq/src/cpufreq-monitor-libcpufreq.c b/cpufreq/src/cpufreq-monitor-libcpufreq.c
+index 40c44ba..5fe79fb 100644
+--- a/cpufreq/src/cpufreq-monitor-libcpufreq.c
++++ b/cpufreq/src/cpufreq-monitor-libcpufreq.c
+@@ -23,8 +23,11 @@
+ #include <glib/gi18n.h>
+
+ #include <stdlib.h>
++#include <linux/version.h>
+ #include <cpufreq.h>
+-
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 7, 0)
++#include <cpuidle.h>
++#endif
+ #include "cpufreq-monitor-libcpufreq.h"
+ #include "cpufreq-utils.h"
+
+@@ -111,7 +114,11 @@ cpufreq_monitor_libcpufreq_run (CPUFreqMonitor *monitor)
+ /* Check whether it failed because
+ * cpu is not online.
+ */
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 7, 0)
+ if (!cpufreq_cpu_exists (cpu)) {
++#else
++ if (cpupower_is_cpu_online (cpu)) {
++#endif
+ g_object_set (G_OBJECT (monitor), "online", FALSE, NULL);
+ return TRUE;
+ }
diff --git a/mate-base/mate-applets/mate-applets-1.10.4-r1.ebuild b/mate-base/mate-applets/mate-applets-1.10.4-r2.ebuild
index 96e901e..4743098 100644
--- a/mate-base/mate-applets/mate-applets-1.10.4-r1.ebuild
+++ b/mate-base/mate-applets/mate-applets-1.10.4-r2.ebuild
@@ -57,8 +57,11 @@ DEPEND="${RDEPEND}
dev-libs/libxslt:0
>=mate-base/mate-common-1.10:0
sys-devel/gettext:*
+ sys-kernel/linux-headers
virtual/pkgconfig:*"
+PATCHES=( "${FILESDIR}/${PN}-1.10.4-kernel-4.7.patch" )
+
src_configure() {
gnome2_src_configure \
--libexecdir=/usr/libexec/mate-applets \
diff --git a/mate-base/mate-applets/mate-applets-1.12.1-r1.ebuild b/mate-base/mate-applets/mate-applets-1.12.1-r2.ebuild
index ecc284b..bfa64ba 100644
--- a/mate-base/mate-applets/mate-applets-1.12.1-r1.ebuild
+++ b/mate-base/mate-applets/mate-applets-1.12.1-r2.ebuild
@@ -65,8 +65,11 @@ DEPEND="${RDEPEND}
>=dev-util/intltool-0.50.1:*
dev-libs/libxslt:0
sys-devel/gettext:*
+ sys-kernel/linux-headers
virtual/pkgconfig:*"
+PATCHES=( "${FILESDIR}/${PN}-1.10.4-kernel-4.7.patch" )
+
src_configure() {
mate_src_configure \
--libexecdir=/usr/libexec/mate-applets \