aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--tox.ini15
1 files changed, 7 insertions, 8 deletions
diff --git a/tox.ini b/tox.ini
index 01d9c88..b34c6dc 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,17 +1,16 @@
[tox]
-envlist = py39,py310,py311,py312,pypy3,flake8
-skip_missing_interpreters = True
+envlist = py{39,310,311,312,313}-test,pypy3-test,flake8
+skipsdist = True
[testenv]
-commands =
- python setup.py test
sitepackages = True
-
-[testenv:flake8]
deps =
- flake8
+ test: pytest
+allowlist_externals =
+ pytest
commands =
- python -m flake8 pym
+ pylint: pylint pym
+ test: pytest -vv -ra -l -o console_output_style=count {posargs}
[flake8]
# We initially start small, but we probably want to expand that list with time.