summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlayman <layman@localhost>2015-03-19 23:07:57 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-05-13 13:42:10 -0400
commit286a7d1753b74ad7caa15646c01413d8771ec184 (patch)
treeaa0a02f6346caccfdee036b8a9d1ff301c82c1ab
parentmail-mta/exim: fix -lnsl. Bug #533660. (diff)
downloadhardened-dev-286a7d1753b74ad7caa15646c01413d8771ec184.tar.gz
hardened-dev-286a7d1753b74ad7caa15646c01413d8771ec184.tar.bz2
hardened-dev-286a7d1753b74ad7caa15646c01413d8771ec184.zip
sys-boot/efibootmgr: fix compilation with musl
-rw-r--r--sys-boot/efibootmgr/Manifest3
-rw-r--r--sys-boot/efibootmgr/efibootmgr-0.11.0-r99.ebuild37
-rw-r--r--sys-boot/efibootmgr/files/efibootmgr-use-linux-pci-header.patch17
3 files changed, 57 insertions, 0 deletions
diff --git a/sys-boot/efibootmgr/Manifest b/sys-boot/efibootmgr/Manifest
new file mode 100644
index 00000000..c36427dc
--- /dev/null
+++ b/sys-boot/efibootmgr/Manifest
@@ -0,0 +1,3 @@
+AUX efibootmgr-use-linux-pci-header.patch 417 SHA256 5c9cc92b268e7ef45dbfdb1ce1ecf31b29d1703a289b618cc3851a4ab0c79299 SHA512 c4e5861896bb59d90992852e6a8df01cd804540e31751cf576ec0cf51e9a023c6341f826f85efc3e363c5bbc4bd201e1bdb9547ef7ac10d4119f02744519e974 WHIRLPOOL 840e09af90b3dc1f96bc50200bf1c4cc7b249b50c1c90676c284b86d9787050c4064f0a4b80eaa205840c4dabc302c569744ceef3d51c561febd4370c609925b
+DIST efibootmgr-0.11.0.tar.bz2 53636 SHA256 f27ce3d7588512017bceb2d2a29aef110499a662a21550afa1158f9950f976d1 SHA512 65866239ae3e2f0142f48e57b16c2a2f4b736e6c7942e595492d82c628633826cfe1a68dd850b8d3090b1a0bd1bbf1906ea882e377a593d1866d686b984cac19 WHIRLPOOL 411cca8fcc26620d2c2a9d15f39e4bafc430efa2789cfe875b411522c641e6754295a640bf03876fd45c8c7c2880f81779bebd95485459316ed846210d7bb533
+EBUILD efibootmgr-0.11.0-r99.ebuild 954 SHA256 90968115e07ad2e950b9b823d5a4cbc7ee9cf3482b57475d4c83c4535cf8eaff SHA512 5cd8b9492730b1384496de09b800681e6150883882f1d75d3d530a5ea54c1e2761e4151e3b70e877d8803e0016a4374dfeaa8e1df2a98911bcaa1f4b5b7c3e8b WHIRLPOOL c00d7f50e4a3049e36a15057a80d80a4bdbf2a742eed41b1ddac7e8ef7459909ba64e04d345d75a0ffb9921ed2a8c5c4d3c5599c6e02d46a37efd0d1f51a20a3
diff --git a/sys-boot/efibootmgr/efibootmgr-0.11.0-r99.ebuild b/sys-boot/efibootmgr/efibootmgr-0.11.0-r99.ebuild
new file mode 100644
index 00000000..6f043a77
--- /dev/null
+++ b/sys-boot/efibootmgr/efibootmgr-0.11.0-r99.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/efibootmgr/efibootmgr-0.11.0.ebuild,v 1.4 2015/02/28 13:25:47 ago Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="User-space application to modify the EFI boot manager"
+HOMEPAGE="https://github.com/vathpela/efibootmgr"
+SRC_URI="https://github.com/vathpela/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ia64 x86"
+IUSE=""
+
+RDEPEND="sys-apps/pciutils
+ sys-libs/efivar"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/efibootmgr-use-linux-pci-header.patch"
+ sed -i -e s/-Werror// Makefile || die
+}
+
+src_configure() {
+ tc-export CC
+ export EXTRA_CFLAGS=${CFLAGS}
+}
+
+src_install() {
+ # build system uses perl, so just do it ourselves
+ dosbin src/efibootmgr/efibootmgr
+ doman src/man/man8/efibootmgr.8
+ dodoc AUTHORS README doc/ChangeLog doc/TODO
+}
diff --git a/sys-boot/efibootmgr/files/efibootmgr-use-linux-pci-header.patch b/sys-boot/efibootmgr/files/efibootmgr-use-linux-pci-header.patch
new file mode 100644
index 00000000..7fa44f0a
--- /dev/null
+++ b/sys-boot/efibootmgr/files/efibootmgr-use-linux-pci-header.patch
@@ -0,0 +1,17 @@
+Use pci.h from linux... sys/pci.h is glibc specific.
+
+--- src/lib/scsi_ioctls.c.orig 2014-12-28 10:43:35.513305649 +0100
++++ src/lib/scsi_ioctls.c 2014-12-28 10:43:45.024306074 +0100
+@@ -19,11 +19,11 @@
+ */
+
+ #include <stdio.h>
+-#include <sys/pci.h>
+ #include <stdint.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+ #include <sys/ioctl.h>
++#include <linux/pci.h>
+ #include <linux/nvme.h>
+ #include "scsi_ioctls.h"
+