aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2010-11-24 13:08:55 -0700
committerEric Blake <eblake@redhat.com>2010-11-24 15:23:43 -0700
commit416c09bcc03ed3bcfece6cc653ddcb9d6537a2ef (patch)
treef1aa944ddc53a2491d71ea0185884f313ee9e499 /Makefile.am
parentqemu: plug memory leak (diff)
downloadlibvirt-416c09bcc03ed3bcfece6cc653ddcb9d6537a2ef.tar.gz
libvirt-416c09bcc03ed3bcfece6cc653ddcb9d6537a2ef.tar.bz2
libvirt-416c09bcc03ed3bcfece6cc653ddcb9d6537a2ef.zip
maint: prohibit most uses of xmlGetProp
Making this change makes it easier to spot the memory leaks that will be fixed in the next patch. * cfg.mk (sc_prohibit_xmlGetProp): New rule. * .x-sc_prohibit_xmlGetProp: New exception. * Makefile.am (EXTRA_DIST): Ship exception file. * tools/virsh.c (cmdDetachInterface, cmdDetachDisk): Adjust offenders. * src/conf/storage_conf.c (virStoragePoolDefParseSource): Likewise. * src/conf/network_conf.c (virNetworkDHCPRangeDefParseXML) (virNetworkIPParseXML): Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bd70a3a8a..c525e65bd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,6 +38,7 @@ syntax_check_exceptions = \
.x-sc_prohibit_strncpy \
.x-sc_prohibit_test_minus_ao \
.x-sc_prohibit_VIR_ERR_NO_MEMORY \
+ .x-sc_prohibit_xmlGetProp \
.x-sc_require_config_h \
.x-sc_require_config_h_first \
.x-sc_trailing_blank \