aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel P. Berrange <berrange@redhat.com>2010-10-21 11:15:16 +0100
committerDaniel P. Berrange <berrange@redhat.com>2010-10-22 11:59:23 +0100
commit5f32588066e8d485eca67968b7c45919a3db910a (patch)
tree0d15a1f170650ec20d3be6e22189a6597d9f3051 /Makefile.nonreentrant
parentRemove all use of inet_pton and inet_ntop (diff)
downloadlibvirt-5f32588066e8d485eca67968b7c45919a3db910a.tar.gz
libvirt-5f32588066e8d485eca67968b7c45919a3db910a.tar.bz2
libvirt-5f32588066e8d485eca67968b7c45919a3db910a.zip
Ban use of all inet_* functions
All the inet_* functions can be replaced with calls to the virSocket APIs. Since many of the inet_* funtions are unsafe, and the remainder are obsolete, forbid all future use of them in libvirt. * Makefile.nonreentrant: Ban use of inet_*
Diffstat (limited to 'Makefile.nonreentrant')
-rw-r--r--Makefile.nonreentrant15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.nonreentrant b/Makefile.nonreentrant
index b567f3147..f656dbbf0 100644
--- a/Makefile.nonreentrant
+++ b/Makefile.nonreentrant
@@ -12,6 +12,10 @@
# | uniq \
# | sed -e 's/_r//'
#
+# Also manually add in all inet_* functions some of which
+# are not threadsafe and do not have _r variants. They are
+# all deprecated in favour of getnameinfo/getaddrinfo
+#
NON_REENTRANT =
NON_REENTRANT += asctime
@@ -83,3 +87,14 @@ NON_REENTRANT += strerror
NON_REENTRANT += strtok
NON_REENTRANT += tmpnam
NON_REENTRANT += ttyname
+NON_REENTRANT += inet_addr
+NON_REENTRANT += inet_aton
+NON_REENTRANT += inet_lnaof
+NON_REENTRANT += inet_makeaddr
+NON_REENTRANT += inet_netof
+NON_REENTRANT += inet_network
+NON_REENTRANT += inet_nsap_addr
+NON_REENTRANT += inet_nsap_ntoa
+NON_REENTRANT += inet_ntoa
+NON_REENTRANT += inet_ntop
+NON_REENTRANT += inet_pton