aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@redhat.com>2005-11-02 13:19:10 +0000
committerDaniel Veillard <veillard@redhat.com>2005-11-02 13:19:10 +0000
commitb8e381131ca1a5b38b660be48adf0bef0228c6da (patch)
tree8140117562a4cd5ebe733b7c22e3c0a9490a9923 /autogen.sh
parentInitial revision (diff)
downloadlibvirt-b8e381131ca1a5b38b660be48adf0bef0228c6da.tar.gz
libvirt-b8e381131ca1a5b38b660be48adf0bef0228c6da.tar.bz2
libvirt-b8e381131ca1a5b38b660be48adf0bef0228c6da.zip
* AUTHORS NEWS README autogen.sh configure.in: allow autogen.sh and
configure to start working * src/Makefile.am src/internal.h src/libxen.c: make the first compile Daniel
Diffstat (limited to 'autogen.sh')
-rwxr-xr-xautogen.sh64
1 files changed, 64 insertions, 0 deletions
diff --git a/autogen.sh b/autogen.sh
new file mode 100755
index 000000000..60e36c64f
--- /dev/null
+++ b/autogen.sh
@@ -0,0 +1,64 @@
+#!/bin/sh
+# Run this to generate all the initial makefiles, etc.
+
+srcdir=`dirname $0`
+test -z "$srcdir" && srcdir=.
+
+THEDIR=`pwd`
+cd $srcdir
+DIE=0
+
+(autoconf --version) < /dev/null > /dev/null 2>&1 || {
+ echo
+ echo "You must have autoconf installed to compile libxen."
+ echo "Download the appropriate package for your distribution,"
+ echo "or see http://www.gnu.org/software/autoconf"
+ DIE=1
+}
+
+(libtool --version) < /dev/null > /dev/null 2>&1 || {
+ echo
+ echo "You must have libtool installed to compile libxen."
+ echo "Download the appropriate package for your distribution,"
+ echo "or see http://www.gnu.org/software/libtool"
+ DIE=1
+}
+
+(automake --version) < /dev/null > /dev/null 2>&1 || {
+ echo
+ DIE=1
+ echo "You must have automake installed to compile libxen."
+ echo "Download the appropriate package for your distribution,"
+ echo "or see http://www.gnu.org/software/automake"
+}
+
+if test "$DIE" -eq 1; then
+ exit 1
+fi
+
+test -f src/libxen.c || {
+ echo "You must run this script in the top-level libxen directory"
+ exit 1
+}
+
+if test -z "$*"; then
+ echo "I am going to run ./configure with no arguments - if you wish "
+ echo "to pass any to it, please specify them on the $0 command line."
+fi
+
+libtoolize --copy --force
+aclocal $ACLOCAL_FLAGS
+automake --add-missing
+autoconf
+
+cd $THEDIR
+
+if test x$OBJ_DIR != x; then
+ mkdir -p "$OBJ_DIR"
+ cd "$OBJ_DIR"
+fi
+
+$srcdir/configure "$@"
+
+echo
+echo "Now type 'make' to compile libxen."