aboutsummaryrefslogtreecommitdiff
path: root/cfg.mk
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2011-07-11 15:26:33 -0600
committerEric Blake <eblake@redhat.com>2011-07-21 16:24:08 -0600
commit519a1c43791c369c2d1fa4ca058c5a824bedfe0d (patch)
tree2af4da3b3dbadcf68504714e2c6321bfa0d9462a /cfg.mk
parentsave: let iohelper work on O_DIRECT fds (diff)
downloadlibvirt-519a1c43791c369c2d1fa4ca058c5a824bedfe0d.tar.gz
libvirt-519a1c43791c369c2d1fa4ca058c5a824bedfe0d.tar.bz2
libvirt-519a1c43791c369c2d1fa4ca058c5a824bedfe0d.zip
save: add virFileDirectFd wrapper type
O_DIRECT has stringent requirements. Rather than make lots of changes at each site that wants to use O_DIRECT, it is easier to offload the work through a helper process that mirrors the I/O between a pipe and the actual direct fd, so that the other end of the pipe no longer has to worry about constraints. Plus, if the kernel ever gains better posix_fadvise support, then we only have to touch a single file to let all callers benefit from a more efficient way to avoid file system caching. * src/util/virfile.h (virFileDirectFdFlag, virFileDirectFdNew) (virFileDirectFdClose, virFileDirectFdFree): New prototypes. * src/util/virdirect.c: Implement new wrapper object. * src/libvirt_private.syms (virfile.h): Export new symbols. * cfg.mk (useless_free_options): Add to list. * po/POTFILES.in: Add new translations.
Diffstat (limited to 'cfg.mk')
-rw-r--r--cfg.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/cfg.mk b/cfg.mk
index 3024181e2..f2a951d5d 100644
--- a/cfg.mk
+++ b/cfg.mk
@@ -120,6 +120,7 @@ useless_free_options = \
--name=virDomainSoundDefFree \
--name=virDomainVideoDefFree \
--name=virDomainWatchdogDefFree \
+ --name=virFileDirectFdFree \
--name=virHashFree \
--name=virInterfaceDefFree \
--name=virInterfaceIpDefFree \