aboutsummaryrefslogtreecommitdiff
path: root/cfg.mk
diff options
context:
space:
mode:
authorMichal Privoznik <mprivozn@redhat.com>2011-07-22 16:07:25 +0200
committerDaniel Veillard <veillard@redhat.com>2011-07-25 13:49:33 +0800
commite2ed67a8b6ace6ecd8b2020fc191b59b99d5fd4f (patch)
treed5b6374e085225fe83a9e594999b12656b3e415f /cfg.mk
parentbandwidth: Declare internal structures (diff)
downloadlibvirt-e2ed67a8b6ace6ecd8b2020fc191b59b99d5fd4f.tar.gz
libvirt-e2ed67a8b6ace6ecd8b2020fc191b59b99d5fd4f.tar.bz2
libvirt-e2ed67a8b6ace6ecd8b2020fc191b59b99d5fd4f.zip
bandwidth: Add parsing and free functions
These functions parse given XML node and return pointer to the output. Unknown elements are silently ignored. Attributes must be integer and must fit in unsigned long long. Free function frees elements of virBandwidth structure.
Diffstat (limited to 'cfg.mk')
-rw-r--r--cfg.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/cfg.mk b/cfg.mk
index 977ea87a0..2eb73e69d 100644
--- a/cfg.mk
+++ b/cfg.mk
@@ -84,6 +84,7 @@ useless_free_options = \
--name=qemuMigrationCookieFree \
--name=qemuMigrationCookieGraphicsFree \
--name=sexpr_free \
+ --name=virBandwidthDefFree \
--name=virBitmapFree \
--name=virCPUDefFree \
--name=virCapabilitiesFree \