aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2012-09-04 10:57:25 -0600
committerEric Blake <eblake@redhat.com>2012-09-04 10:57:25 -0600
commitd74e5a4dfc434d3a1d01856d013a7f50d910fa95 (patch)
tree08c831433c3d0391a37fc519d3ac55c7a6cf9dfa /configure.ac
parentInclude an extra header needed for OpenBSD. (diff)
downloadlibvirt-d74e5a4dfc434d3a1d01856d013a7f50d910fa95.tar.gz
libvirt-d74e5a4dfc434d3a1d01856d013a7f50d910fa95.tar.bz2
libvirt-d74e5a4dfc434d3a1d01856d013a7f50d910fa95.zip
build: use correct libraries for clock_gettime
On OpenBSD, clock_gettime() exists in libc rather than librt, and blindly linking with -lrt made the build fail. Gnulib already did the work for determining which libraries to use, so we should reuse that work rather than doing it ourselves. * bootstrap.conf (gnulib_modules): Pull in clock-time. * configure.ac (RT_LIBS): Drop. * src/Makefile.am (libvirt_util_la_LIBADD): Use gnulib variable instead. * src/util/virtime.c (includes): Simplify.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 0 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index e0d00d5f1..cb91e7d72 100644
--- a/configure.ac
+++ b/configure.ac
@@ -183,16 +183,6 @@ LIBS="$LIBS $LIB_PTHREAD $LIBMULTITHREAD"
AC_CHECK_FUNCS([pthread_mutexattr_init])
LIBS=$old_libs
-old_LIBS=$LIBS
-RT_LIBS=
-LIBS="$LIBS $LIB_PTHREAD -lrt"
-AC_CHECK_FUNC([clock_gettime],[
- AC_DEFINE([HAVE_CLOCK_GETTIME],[],[Defined if clock_gettime() exists in librt.so])
- RT_LIBS=-lrt
-])
-LIBS=$old_libs
-AC_SUBST(RT_LIBS)
-
dnl Availability of various common headers (non-fatal if missing).
AC_CHECK_HEADERS([pwd.h paths.h regex.h sys/un.h \
sys/poll.h syslog.h mntent.h net/ethernet.h linux/magic.h \