aboutsummaryrefslogtreecommitdiff
path: root/daemon
diff options
context:
space:
mode:
authorDaniel P. Berrange <berrange@redhat.com>2012-07-20 15:31:46 +0100
committerDaniel P. Berrange <berrange@redhat.com>2012-07-30 12:50:23 +0100
commitca5ab840731d7752dc243d35329a305794dc43e4 (patch)
tree38a39df8ffe33426b04e3439b7694d3179a4487b /daemon
parentMove LXC monitor code out into separate file (diff)
downloadlibvirt-ca5ab840731d7752dc243d35329a305794dc43e4.tar.gz
libvirt-ca5ab840731d7752dc243d35329a305794dc43e4.tar.bz2
libvirt-ca5ab840731d7752dc243d35329a305794dc43e4.zip
Make RPC code generator a little more flexible
Update the gendispatch.pl script to get a little closer to being able to generate code for the LXC monitor, by passing in the struct prefix separately from the procedure prefix. Also allow method names using virCapitalLetters instead of vir_underscore_separator Signed-off-by: Daniel P. Berrange <berrange@redhat.com>
Diffstat (limited to 'daemon')
-rw-r--r--daemon/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 4c72b7b1c..928aeaf47 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -58,12 +58,12 @@ QEMU_PROTOCOL = $(top_srcdir)/src/remote/qemu_protocol.x
$(srcdir)/remote_dispatch.h: $(srcdir)/../src/rpc/gendispatch.pl \
$(REMOTE_PROTOCOL)
- $(AM_V_GEN)$(PERL) -w $(srcdir)/../src/rpc/gendispatch.pl -b remote \
+ $(AM_V_GEN)$(PERL) -w $(srcdir)/../src/rpc/gendispatch.pl -b remote REMOTE \
$(REMOTE_PROTOCOL) > $@
$(srcdir)/qemu_dispatch.h: $(srcdir)/../src/rpc/gendispatch.pl \
$(QEMU_PROTOCOL)
- $(AM_V_GEN)$(PERL) -w $(srcdir)/../src/rpc/gendispatch.pl -b qemu \
+ $(AM_V_GEN)$(PERL) -w $(srcdir)/../src/rpc/gendispatch.pl -b qemu QEMU \
$(QEMU_PROTOCOL) > $@
if WITH_LIBVIRTD