aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2012-02-02 13:20:09 -0700
committerEric Blake <eblake@redhat.com>2012-02-03 10:36:02 -0700
commitcb33ee1fad1f3372a96d809d254544b286317f0b (patch)
tree23378e98e73b055621b3f819b2fa524cb435cae9 /examples
parentcommand: allow merging stdout and stderr in string capture (diff)
downloadlibvirt-cb33ee1fad1f3372a96d809d254544b286317f0b.tar.gz
libvirt-cb33ee1fad1f3372a96d809d254544b286317f0b.tar.bz2
libvirt-cb33ee1fad1f3372a96d809d254544b286317f0b.zip
build: clean up CPPFLAGS/INCLUDES usage
Our syntax checker missed all-lower-case variables (this will be fixed by the next .gnulib update). Additionally, anywhere that we mix in-tree files with generated files, automake recommends listing builddir prior to srcdir for VPATH builds. * src/Makefile.am (*_la_CFLAGS): Favor $(top_srcdir). (INCLUDES): Likewise, and follow automake recommendations on builddir before srcdir. * python/Makefile.am (INCLUDES): Swap directory order. * tests/Makefile.am (INCLUDES): Likewise. * tools/Makefile.am (INCLUDES): Likewise. * daemon/Makefile.am (INCLUDES): Likewise. (libvirtd.init, libvirtd.service): Favor $(). * examples/hellolibvirt/Makefile.am (hellolibvirt_LDADD): Likewise. * examples/openauth/Makefile.am (openauth_LDADD): Likewise. * examples/dominfo/Makefile.am (INCLUDES): Drop dead include. * examples/domsuspend/Makefile.am (INCLUDES): Likewise.
Diffstat (limited to 'examples')
-rw-r--r--examples/dominfo/Makefile.am4
-rw-r--r--examples/domsuspend/Makefile.am4
-rw-r--r--examples/hellolibvirt/Makefile.am4
-rw-r--r--examples/openauth/Makefile.am4
4 files changed, 8 insertions, 8 deletions
diff --git a/examples/dominfo/Makefile.am b/examples/dominfo/Makefile.am
index 07982b0aa..188c53a7f 100644
--- a/examples/dominfo/Makefile.am
+++ b/examples/dominfo/Makefile.am
@@ -1,7 +1,7 @@
-## Copyright (C) 2005-2011 Red Hat, Inc.
+## Copyright (C) 2005-2012 Red Hat, Inc.
## See COPYING.LIB for the License of this software
-INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I@srcdir@/include
+INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include
LDADDS = $(STATIC_BINARIES) $(WARN_CFLAGS) $(top_builddir)/src/libvirt.la \
$(COVERAGE_LDFLAGS)
diff --git a/examples/domsuspend/Makefile.am b/examples/domsuspend/Makefile.am
index fc5e9319a..dbb38c561 100644
--- a/examples/domsuspend/Makefile.am
+++ b/examples/domsuspend/Makefile.am
@@ -1,7 +1,7 @@
-## Copyright (C) 2005-2011 Red Hat, Inc.
+## Copyright (C) 2005-2012 Red Hat, Inc.
## See COPYING.LIB for the License of this software
-INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include -I@srcdir@/include
+INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include
LDADDS = $(STATIC_BINARIES) $(WARN_CFLAGS) $(top_builddir)/src/libvirt.la \
$(COVERAGE_LDFLAGS)
diff --git a/examples/hellolibvirt/Makefile.am b/examples/hellolibvirt/Makefile.am
index a55fe191a..e92fa9daa 100644
--- a/examples/hellolibvirt/Makefile.am
+++ b/examples/hellolibvirt/Makefile.am
@@ -1,8 +1,8 @@
-## Copyright (C) 2005-2011 Red Hat, Inc.
+## Copyright (C) 2005-2012 Red Hat, Inc.
## See COPYING.LIB for the License of this software
INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include
noinst_PROGRAMS = hellolibvirt
hellolibvirt_CFLAGS = $(WARN_CFLAGS)
hellolibvirt_SOURCES = hellolibvirt.c
-hellolibvirt_LDADD = @top_builddir@/src/libvirt.la
+hellolibvirt_LDADD = $(top_builddir)/src/libvirt.la
diff --git a/examples/openauth/Makefile.am b/examples/openauth/Makefile.am
index 844b57280..b396150b7 100644
--- a/examples/openauth/Makefile.am
+++ b/examples/openauth/Makefile.am
@@ -1,8 +1,8 @@
-## Copyright (C) 2005-2011 Red Hat, Inc.
+## Copyright (C) 2005-2012 Red Hat, Inc.
## See COPYING.LIB for the License of this software
INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include
noinst_PROGRAMS = openauth
openauth_CFLAGS = $(WARN_CFLAGS)
openauth_SOURCES = openauth.c
-openauth_LDADD = @top_builddir@/src/libvirt.la
+openauth_LDADD = $(top_builddir)/src/libvirt.la