aboutsummaryrefslogtreecommitdiff
path: root/gnulib
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2011-11-29 16:42:23 -0700
committerEric Blake <eblake@redhat.com>2011-12-01 14:12:59 -0700
commit059d746ddb5000a24db7930a8cab789456f65995 (patch)
treee69991a369e3427ad17a42b5c6b6b7518d67c62a /gnulib
parentbuild: properly skip tests (diff)
downloadlibvirt-059d746ddb5000a24db7930a8cab789456f65995.tar.gz
libvirt-059d746ddb5000a24db7930a8cab789456f65995.tar.bz2
libvirt-059d746ddb5000a24db7930a8cab789456f65995.zip
build: update to latest gnulib
* .gnulib: Update to latest, for improved 'make syntax-check' and compiler warnings. * m4/virt-compile-warnings.m4 (LIBVIRT_COMPILE_WARNINGS): Re-silence -Wformat-nonliteral. * cfg.mk (_test_script_regex): Recognize our test scripts. * gnulib/local/lib/*.diff: Drop, now that gnulib has this. * tests/virsh-optparse: Fix use of compare. * tests/virsh-schedinfo: Likewise.
Diffstat (limited to 'gnulib')
-rw-r--r--gnulib/local/lib/openpty.c.diff26
-rw-r--r--gnulib/local/lib/pty.in.h.diff13
2 files changed, 0 insertions, 39 deletions
diff --git a/gnulib/local/lib/openpty.c.diff b/gnulib/local/lib/openpty.c.diff
deleted file mode 100644
index f17e5666e..000000000
--- a/gnulib/local/lib/openpty.c.diff
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git c/lib/openpty.c i/lib/openpty.c
-index c398db5..d61d5ba 100644
---- c/lib/openpty.c
-+++ i/lib/openpty.c
-@@ -32,6 +32,21 @@ rpl_openpty (int *amaster, int *aslave, char *name,
- (struct winsize *) winp);
- }
-
-+#elif (defined _WIN32 || defined __WIN32__) && !defined __CYGWIN__ /* mingw */
-+
-+# include <errno.h>
-+
-+int
-+openpty (int *amaster _GL_UNUSED, int *aslave _GL_UNUSED,
-+ char *name _GL_UNUSED,
-+ struct termios const *termp _GL_UNUSED,
-+ struct winsize const *winp _GL_UNUSED)
-+{
-+ /* Mingw lacks pseudo-terminals altogether. */
-+ errno = ENOSYS;
-+ return -1;
-+}
-+
- #else /* AIX 5.1, HP-UX 11, IRIX 6.5, Solaris 10, mingw */
-
- # include <fcntl.h>
diff --git a/gnulib/local/lib/pty.in.h.diff b/gnulib/local/lib/pty.in.h.diff
deleted file mode 100644
index 947070077..000000000
--- a/gnulib/local/lib/pty.in.h.diff
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git c/lib/pty.in.h i/lib/pty.in.h
-index aff989c..00eecc6 100644
---- c/lib/pty.in.h
-+++ i/lib/pty.in.h
-@@ -92,6 +92,8 @@ _GL_WARN_ON_USE (forkpty, "forkpty is not declared consistently - "
- /* Create pseudo tty master slave pair and set terminal attributes
- according to TERMP and WINP. Return handles for both ends in
- *AMASTER and *ASLAVE, and return the name of the slave end in NAME. */
-+struct termios;
-+struct winsize;
- # if @REPLACE_OPENPTY@
- # if !(defined __cplusplus && defined GNULIB_NAMESPACE)
- # undef openpty