aboutsummaryrefslogtreecommitdiff
path: root/gnulib
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2008-01-29 18:17:47 +0000
committerJim Meyering <meyering@redhat.com>2008-01-29 18:17:47 +0000
commitbc48db5758c1d4c0e5671c51cad314919fa1e714 (patch)
tree7b465231337893100e0a6357c8a2f175750c1b85 /gnulib
parentEnable the <config.h>-requiring test; fix violations (diff)
downloadlibvirt-bc48db5758c1d4c0e5671c51cad314919fa1e714.tar.gz
libvirt-bc48db5758c1d4c0e5671c51cad314919fa1e714.tar.bz2
libvirt-bc48db5758c1d4c0e5671c51cad314919fa1e714.zip
Update from gnulib
* lib/poll.c: Update. * lib/string.in.h: Update. * m4/string_h.m4: Update. * tests/test-getaddrinfo.c: Update. * lib/Makefile.am: Regenerate.
Diffstat (limited to 'gnulib')
-rw-r--r--gnulib/lib/Makefile.am2
-rw-r--r--gnulib/lib/poll.c6
-rw-r--r--gnulib/lib/string.in.h15
-rw-r--r--gnulib/m4/string_h.m44
-rw-r--r--gnulib/tests/test-getaddrinfo.c4
5 files changed, 21 insertions, 10 deletions
diff --git a/gnulib/lib/Makefile.am b/gnulib/lib/Makefile.am
index e7a6edfd6..64fc39873 100644
--- a/gnulib/lib/Makefile.am
+++ b/gnulib/lib/Makefile.am
@@ -509,8 +509,10 @@ string.h: string.in.h
-e 's|@''HAVE_DECL_STRERROR''@|$(HAVE_DECL_STRERROR)|g' \
-e 's|@''HAVE_DECL_STRSIGNAL''@|$(HAVE_DECL_STRSIGNAL)|g' \
-e 's|@''REPLACE_MEMMEM''@|$(REPLACE_MEMMEM)|g' \
+ -e 's|@''REPLACE_STRCASESTR''@|$(REPLACE_STRCASESTR)|g' \
-e 's|@''REPLACE_STRSTR''@|$(REPLACE_STRSTR)|g' \
-e 's|@''REPLACE_STRERROR''@|$(REPLACE_STRERROR)|g' \
+ -e 's|@''REPLACE_STRSIGNAL''@|$(REPLACE_STRSIGNAL)|g' \
-e '/definition of GL_LINK_WARNING/r $(LINK_WARNING_H)' \
< $(srcdir)/string.in.h; \
} > $@-t
diff --git a/gnulib/lib/poll.c b/gnulib/lib/poll.c
index db7b517b2..aa40d8cd7 100644
--- a/gnulib/lib/poll.c
+++ b/gnulib/lib/poll.c
@@ -1,7 +1,7 @@
/* Emulation for poll(2)
Contributed by Paolo Bonzini.
- Copyright 2001, 2002, 2003, 2006, 2007 Free Software Foundation, Inc.
+ Copyright 2001, 2002, 2003, 2006, 2007, 2008 Free Software Foundation, Inc.
This file is part of gnulib.
@@ -19,7 +19,7 @@
with this program; if not, write to the Free Software Foundation,
Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA. */
-#include "config.h"
+#include <config.h>
#include <sys/types.h>
#include "poll.h"
@@ -132,7 +132,7 @@ poll (pfd, nfd, timeout)
maxfd = pfd[i].fd;
/* Windows use a linear array of sockets (of size FD_SETSIZE). The
- descriptor value is not used to address the array. */
+ descriptor value is not used to address the array. */
#if defined __CYGWIN__ || (!defined _WIN32 && !defined __WIN32__)
if (maxfd > FD_SETSIZE)
{
diff --git a/gnulib/lib/string.in.h b/gnulib/lib/string.in.h
index dbbe2fd7a..b10a49143 100644
--- a/gnulib/lib/string.in.h
+++ b/gnulib/lib/string.in.h
@@ -313,11 +313,15 @@ char *strstr (const char *haystack, const char *needle)
/* Find the first occurrence of NEEDLE in HAYSTACK, using case-insensitive
comparison. */
-#if ! @HAVE_STRCASESTR@
+#if @GNULIB_STRCASESTR@
+# if @REPLACE_STRCASESTR@
+# define strcasestr rpl_strcasestr
+# endif
+# if ! @HAVE_STRCASESTR@ || @REPLACE_STRCASESTR@
extern char *strcasestr (const char *haystack, const char *needle)
__attribute__ ((__pure__));
-#endif
-#if defined GNULIB_POSIXCHECK
+# endif
+#elif defined GNULIB_POSIXCHECK
/* strcasestr() does not work with multibyte strings:
It is a glibc extension, and glibc implements it only for unibyte
locales. */
@@ -542,7 +546,10 @@ extern char *strerror (int);
#endif
#if @GNULIB_STRSIGNAL@
-# if ! @HAVE_DECL_STRSIGNAL@
+# if @REPLACE_STRSIGNAL@
+# define strsignal rpl_strsignal
+# endif
+# if ! @HAVE_DECL_STRSIGNAL@ || @REPLACE_STRSIGNAL@
extern char *strsignal (int __sig);
# endif
#elif defined GNULIB_POSIXCHECK
diff --git a/gnulib/m4/string_h.m4 b/gnulib/m4/string_h.m4
index 69761d720..766d7e984 100644
--- a/gnulib/m4/string_h.m4
+++ b/gnulib/m4/string_h.m4
@@ -5,7 +5,7 @@
# gives unlimited permission to copy and/or distribute it,
# with or without modifications, as long as this notice is preserved.
-# serial 3
+# serial 4
# Written by Paul Eggert.
@@ -80,6 +80,8 @@ AC_DEFUN([gl_HEADER_STRING_H_DEFAULTS],
HAVE_DECL_STRERROR=1; AC_SUBST([HAVE_DECL_STRERROR])
HAVE_DECL_STRSIGNAL=1; AC_SUBST([HAVE_DECL_STRSIGNAL])
REPLACE_STRERROR=0; AC_SUBST([REPLACE_STRERROR])
+ REPLACE_STRSIGNAL=0; AC_SUBST([REPLACE_STRSIGNAL])
REPLACE_MEMMEM=0; AC_SUBST([REPLACE_MEMMEM])
+ REPLACE_STRCASESTR=0; AC_SUBST([REPLACE_STRCASESTR])
REPLACE_STRSTR=0; AC_SUBST([REPLACE_STRSTR])
])
diff --git a/gnulib/tests/test-getaddrinfo.c b/gnulib/tests/test-getaddrinfo.c
index 7763f43f6..00a980b1b 100644
--- a/gnulib/tests/test-getaddrinfo.c
+++ b/gnulib/tests/test-getaddrinfo.c
@@ -1,6 +1,6 @@
/* Test the getaddrinfo module.
- Copyright (C) 2006-2007 Free Software Foundation, Inc.
+ Copyright (C) 2006-2008 Free Software Foundation, Inc.
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
@@ -17,7 +17,7 @@
/* Written by Simon Josefsson. */
-#include "config.h"
+#include <config.h>
#include "getaddrinfo.h"
#include "inet_ntop.h"
#include <stdio.h>