aboutsummaryrefslogtreecommitdiff
path: root/m4
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2010-03-24 15:31:31 -0600
committerJim Meyering <meyering@redhat.com>2010-03-25 09:28:24 +0100
commite07cf19fe5765a38d0d24bb084db94a41dd55e6f (patch)
tree9dac44b8413f98b8f6e572aa2ba7a290722a2be9 /m4
parentesx: Make the conf parser compare names case insensitive in VMX mode (diff)
downloadlibvirt-e07cf19fe5765a38d0d24bb084db94a41dd55e6f.tar.gz
libvirt-e07cf19fe5765a38d0d24bb084db94a41dd55e6f.tar.bz2
libvirt-e07cf19fe5765a38d0d24bb084db94a41dd55e6f.zip
build: don't use "test cond1 -o cond2": it's not portable
* configure.ac: Use "test cond1 || test cond2" instead. * m4/compiler-flags.m4 (gl_COMPILER_FLAGS): Likewise. * tests/test-lib.sh (verbose): Likewise.
Diffstat (limited to 'm4')
-rw-r--r--m4/compiler-flags.m45
1 files changed, 3 insertions, 2 deletions
diff --git a/m4/compiler-flags.m4 b/m4/compiler-flags.m4
index 72f9fe1a7..628bd1f0e 100644
--- a/m4/compiler-flags.m4
+++ b/m4/compiler-flags.m4
@@ -1,6 +1,7 @@
-# serial 3
+# serial 4
# Find valid warning flags for the C Compiler. -*-Autoconf-*-
#
+# Copyright (C) 2010 Red Hat, Inc.
# Copyright (C) 2001, 2002, 2006 Free Software Foundation, Inc.
#
# This program is free software; you can redistribute it and/or modify
@@ -37,7 +38,7 @@ AC_DEFUN([gl_COMPILER_FLAGS],
echo 'int x;' >conftest.c
$CC $CFLAGS -c conftest.c 2>conftest.err
ret=$?
- if test $ret != 0 -o -s conftest.err -o $has_option = "no"; then
+ if test $ret != 0 || test -s conftest.err || test $has_option = "no"; then
AC_MSG_RESULT(no)
else
AC_MSG_RESULT(yes)