aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog8
-rwxr-xr-xautobuild.sh12
-rw-r--r--libvirt.spec.in2
3 files changed, 21 insertions, 1 deletions
diff --git a/ChangeLog b/ChangeLog
index ffe607a90..22830b756 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,11 @@
+Thu Aug 28 11:08:15 CEST 2008 Jim Meyering <meyering@redhat.com>
+
+ improve parallel build support
+ * autobuild.sh: Append -j$N to MAKEFLAGS, if no -j option is there.
+ * libvirt.spec.in: Use %{?_smp_mflags} with "make".
+ Based on a patch from James Morris:
+ http://thread.gmane.org/gmane.comp.emulators.libvirt/8201
+
Wed Aug 27 20:50:00 EST 2008 Daniel P. Berrange <berrange@redhat.com>
Storage pool source discovery from David Lively
diff --git a/autobuild.sh b/autobuild.sh
index 7ae5d1e76..2fbecea88 100755
--- a/autobuild.sh
+++ b/autobuild.sh
@@ -21,6 +21,18 @@ rm -rf coverage
--with-lxc \
--with-xen-proxy
+# If the MAKEFLAGS envvar does not yet include a -j option,
+# add -jN where N depends on the number of processors.
+case $MAKEFLAGS in
+ *-j*) ;;
+ *) n=$(getconf _NPROCESSORS_ONLN 2> /dev/null)
+ test "$n" -gt 0 || n=1
+ n=$(expr $n + 1)
+ MAKEFLAGS="$MAKEFLAGS -j$n"
+ export MAKEFLAGS
+ ;;
+esac
+
make
make install
diff --git a/libvirt.spec.in b/libvirt.spec.in
index bac84a5b3..ba2447a26 100644
--- a/libvirt.spec.in
+++ b/libvirt.spec.in
@@ -172,7 +172,7 @@ of recent versions of Linux (and other OSes).
--with-init-script=redhat \
--with-qemud-pid-file=%{_localstatedir}/run/libvirt_qemud.pid \
--with-remote-file=%{_localstatedir}/run/libvirtd.pid
-make
+make %{?_smp_mflags}
%install
rm -fr %{buildroot}