summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2017-11-24 10:48:09 +0000
committerMike Pagano <mpagano@gentoo.org>2018-11-21 09:58:45 -0500
commit8c5b29f534686c94379bfa0caf2f9090df68767e (patch)
tree31a432879b5f67e0bacd43ef6024d52beb1806fa /1101_linux-4.4.102.patch
parentlinux kernel 4.4.101 (diff)
downloadlinux-patches-8c5b29f534686c94379bfa0caf2f9090df68767e.tar.gz
linux-patches-8c5b29f534686c94379bfa0caf2f9090df68767e.tar.bz2
linux-patches-8c5b29f534686c94379bfa0caf2f9090df68767e.zip
linux kernel 4.4.102
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to '1101_linux-4.4.102.patch')
-rw-r--r--1101_linux-4.4.102.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/1101_linux-4.4.102.patch b/1101_linux-4.4.102.patch
new file mode 100644
index 00000000..45e56d17
--- /dev/null
+++ b/1101_linux-4.4.102.patch
@@ -0,0 +1,43 @@
+diff --git a/Makefile b/Makefile
+index 0d7b050427ed..9e036fac9c04 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ VERSION = 4
+ PATCHLEVEL = 4
+-SUBLEVEL = 101
++SUBLEVEL = 102
+ EXTRAVERSION =
+ NAME = Blurry Fish Butt
+
+diff --git a/mm/debug-pagealloc.c b/mm/debug-pagealloc.c
+index fe1c61f7cf26..3b8f1b83610e 100644
+--- a/mm/debug-pagealloc.c
++++ b/mm/debug-pagealloc.c
+@@ -34,7 +34,7 @@ static inline void set_page_poison(struct page *page)
+ struct page_ext *page_ext;
+
+ page_ext = lookup_page_ext(page);
+- if (page_ext)
++ if (!page_ext)
+ return;
+ __set_bit(PAGE_EXT_DEBUG_POISON, &page_ext->flags);
+ }
+@@ -44,7 +44,7 @@ static inline void clear_page_poison(struct page *page)
+ struct page_ext *page_ext;
+
+ page_ext = lookup_page_ext(page);
+- if (page_ext)
++ if (!page_ext)
+ return;
+ __clear_bit(PAGE_EXT_DEBUG_POISON, &page_ext->flags);
+ }
+@@ -54,7 +54,7 @@ static inline bool page_poison(struct page *page)
+ struct page_ext *page_ext;
+
+ page_ext = lookup_page_ext(page);
+- if (page_ext)
++ if (!page_ext)
+ return false;
+ return test_bit(PAGE_EXT_DEBUG_POISON, &page_ext->flags);
+ }