summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2022-07-15 06:03:00 -0400
committerMike Pagano <mpagano@gentoo.org>2022-07-15 06:03:00 -0400
commitb75ac876bd560b3da5f50061fd2548f6150c2ed0 (patch)
tree05070ac952ed584c85b26f47ef8409a8e693be98
parentLinux patch 5.10.130 (diff)
downloadlinux-patches-b75ac876bd560b3da5f50061fd2548f6150c2ed0.tar.gz
linux-patches-b75ac876bd560b3da5f50061fd2548f6150c2ed0.tar.bz2
linux-patches-b75ac876bd560b3da5f50061fd2548f6150c2ed0.zip
Linux patch 5.10.1315.10-140
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--0000_README4
-rw-r--r--1130_linux-5.10.131.patch26
2 files changed, 30 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index 5c651d7f..7e7a9fd2 100644
--- a/0000_README
+++ b/0000_README
@@ -563,6 +563,10 @@ Patch: 1129_linux-5.10.130.patch
From: http://www.kernel.org
Desc: Linux 5.10.130
+Patch: 1130_linux-5.10.131.patch
+From: http://www.kernel.org
+Desc: Linux 5.10.131
+
Patch: 1500_XATTR_USER_PREFIX.patch
From: https://bugs.gentoo.org/show_bug.cgi?id=470644
Desc: Support for namespace user.pax.* on tmpfs.
diff --git a/1130_linux-5.10.131.patch b/1130_linux-5.10.131.patch
new file mode 100644
index 00000000..0cde88b2
--- /dev/null
+++ b/1130_linux-5.10.131.patch
@@ -0,0 +1,26 @@
+diff --git a/Makefile b/Makefile
+index b0a35378803db..53f1a45ae69b0 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ # SPDX-License-Identifier: GPL-2.0
+ VERSION = 5
+ PATCHLEVEL = 10
+-SUBLEVEL = 130
++SUBLEVEL = 131
+ EXTRAVERSION =
+ NAME = Dare mighty things
+
+diff --git a/drivers/mtd/nand/raw/gpmi-nand/gpmi-nand.c b/drivers/mtd/nand/raw/gpmi-nand/gpmi-nand.c
+index 8d096ca770b04..92e8ca56f5665 100644
+--- a/drivers/mtd/nand/raw/gpmi-nand/gpmi-nand.c
++++ b/drivers/mtd/nand/raw/gpmi-nand/gpmi-nand.c
+@@ -683,7 +683,7 @@ static void gpmi_nfc_compute_timings(struct gpmi_nand_data *this,
+ hw->timing0 = BF_GPMI_TIMING0_ADDRESS_SETUP(addr_setup_cycles) |
+ BF_GPMI_TIMING0_DATA_HOLD(data_hold_cycles) |
+ BF_GPMI_TIMING0_DATA_SETUP(data_setup_cycles);
+- hw->timing1 = BF_GPMI_TIMING1_BUSY_TIMEOUT(DIV_ROUND_UP(busy_timeout_cycles, 4096));
++ hw->timing1 = BF_GPMI_TIMING1_BUSY_TIMEOUT(busy_timeout_cycles * 4096);
+
+ /*
+ * Derive NFC ideal delay from {3}: