summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/lanes/lanes-9999.ebuild')
-rw-r--r--dev-lua/lanes/lanes-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-lua/lanes/lanes-9999.ebuild b/dev-lua/lanes/lanes-9999.ebuild
new file mode 100644
index 0000000..ef74800
--- /dev/null
+++ b/dev-lua/lanes/lanes-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VCS="git"
+GITHUB_A="LuaLanes"
+
+inherit cmake-utils lua
+
+DESCRIPTION="lightweight, native, lazy evaluating multithreading library"
+HOMEPAGE="https://github.com/LuaLanes/lanes"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc"
+
+DOCS=(README CHANGES)
+HTML_DOCS=(docs/.)
+
+all_lua_prepare() {
+ sed -r \
+ -e '/^#include "tools.h"$/{h;d};/^#include "universe.h"$/G' \
+ -i src/deep.c
+ lua_default
+}
+
+each_lua_configure() {
+ mycmakeargs=(
+ -DINSTALL_CMOD="$(lua_get_pkgvar INSTALL_CMOD)/${PN}"
+ -DINSTALL_LMOD="$(lua_get_pkgvar INSTALL_LMOD)"
+ )
+ cmake-utils_src_configure
+}
+
+all_lua_install() {
+ lua_default
+ rm "${ED}"/usr/share/lanes -r
+}