summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory A. Pratt <anarchy@gentoo.org>2014-04-15 08:28:55 -0500
committerJory A. Pratt <anarchy@gentoo.org>2014-04-15 08:28:55 -0500
commit747c3fa8dbf5ee03c8ff3df546cb6dd6825f0d6c (patch)
tree77a84768cb85cca1a4bdda7dbb096f7a534dd68d
parentAdjusted package.mask (diff)
downloadmozilla-747c3fa8dbf5ee03c8ff3df546cb6dd6825f0d6c.tar.gz
mozilla-747c3fa8dbf5ee03c8ff3df546cb6dd6825f0d6c.tar.bz2
mozilla-747c3fa8dbf5ee03c8ff3df546cb6dd6825f0d6c.zip
Add hardened useflag and append relro ldflags, bug #500186
-rw-r--r--www-client/firefox/firefox-28.0.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/www-client/firefox/firefox-28.0.ebuild b/www-client/firefox/firefox-28.0.ebuild
index 2c2619cc..b6564890 100644
--- a/www-client/firefox/firefox-28.0.ebuild
+++ b/www-client/firefox/firefox-28.0.ebuild
@@ -39,7 +39,7 @@ HOMEPAGE="http://www.mozilla.com/firefox"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
SLOT="0"
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
-IUSE="bindist gstreamer +jit +minimal pgo pulseaudio selinux system-cairo system-icu system-jpeg system-sqlite test"
+IUSE="bindist gstreamer hardened +jit +minimal pgo pulseaudio selinux system-cairo system-icu system-jpeg system-sqlite test"
# More URIs appended below...
SRC_URI="${SRC_URI}
@@ -205,6 +205,9 @@ src_configure() {
# It doesn't compile on alpha without this LDFLAGS
use alpha && append-ldflags "-Wl,--no-relax"
+ # Add full relro support for hardened
+ use hardened && append-ldflags "-Wl,-z,relro,-z,now"
+
# We must force enable jemalloc 3 threw .mozconfig
echo "export MOZ_JEMALLOC=1" >> ${S}/.mozconfig || die