aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-12-29 13:25:34 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-12-29 13:25:34 -0500
commit16a6a861b072b4e60ac88b7600f540db4c0686fc (patch)
tree7faf44d80884a37030c9afb9cc4f0c60ac68a69b
parentdev-libs/ell: in tree version works (diff)
downloadmusl-16a6a861b072b4e60ac88b7600f540db4c0686fc.tar.gz
musl-16a6a861b072b4e60ac88b7600f540db4c0686fc.tar.bz2
musl-16a6a861b072b4e60ac88b7600f540db4c0686fc.zip
dev-libs/libnl: sync with tree
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-libs/libnl/libnl-3.4.0.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/dev-libs/libnl/libnl-3.4.0.ebuild b/dev-libs/libnl/libnl-3.4.0.ebuild
index 481d9e9f..e580c3b8 100644
--- a/dev-libs/libnl/libnl-3.4.0.ebuild
+++ b/dev-libs/libnl/libnl-3.4.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
DISTUTILS_OPTIONAL=1
inherit distutils-r1 eutils libtool multilib multilib-minimal
@@ -17,15 +17,11 @@ SRC_URI="
"
LICENSE="LGPL-2.1 utils? ( GPL-2 )"
SLOT="3"
-KEYWORDS="amd64 arm arm64 ~mips ppc x86"
-IUSE="static-libs python utils"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
+IUSE="+debug static-libs python +threads utils"
RDEPEND="
python? ( ${PYTHON_DEPS} )
- abi_x86_32? (
- !<=app-emulation/emul-linux-x86-baselibs-20140508-r5
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
- )
"
DEPEND="
${RDEPEND}
@@ -77,9 +73,11 @@ src_prepare() {
multilib_src_configure() {
econf \
- --disable-silent-rules \
+ $(multilib_native_use_enable utils cli) \
+ $(use_enable debug) \
$(use_enable static-libs static) \
- $(multilib_native_use_enable utils cli)
+ $(use_enable threads) \
+ --disable-silent-rules
}
multilib_src_compile() {