summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-09-19 19:59:22 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-09-19 19:59:22 +0000
commit97783c8426e49ada1812a673191244729e3b3036 (patch)
treee0614e021d5328b4e00064bc74e5c3ed3c379844
parentImported from /home/gentoo/distfiles/mysql-extras-20050908.tar.bz2. (diff)
downloadmysql-extras-97783c8426e49ada1812a673191244729e3b3036.tar.gz
mysql-extras-97783c8426e49ada1812a673191244729e3b3036.tar.bz2
mysql-extras-97783c8426e49ada1812a673191244729e3b3036.zip
Imported from /home/gentoo/distfiles/mysql-extras-20050920.tar.bz2.mysql-extras-20050920
-rw-r--r--mysql-3.23-my-print-defaults.diff11
-rw-r--r--mysql-3.23-nisam.h.diff11
-rw-r--r--mysql-3.23-safe-mysqld-sh.diff50
-rw-r--r--mysql-3.23.52-install-db-sh.diff35
-rw-r--r--mysql-4.0-mysqlhotcopy-security.patch48
-rw-r--r--mysql-4.0.15.rc643
-rw-r--r--mysql-4.0.21-install-db-sh.diff11
-rw-r--r--mysql-4.0.24-manual.texi.patch20
-rw-r--r--mysql-4.0.24-r1.rc659
-rw-r--r--mysql-4.0.24-r2.rc671
-rw-r--r--mysql-4.1.9-thrssl.patch22
-rw-r--r--mysql-accesstmp.patch90
-rw-r--r--mysql-test-myisam-geometry.patch22
13 files changed, 493 insertions, 0 deletions
diff --git a/mysql-3.23-my-print-defaults.diff b/mysql-3.23-my-print-defaults.diff
new file mode 100644
index 0000000..dbdf14d
--- /dev/null
+++ b/mysql-3.23-my-print-defaults.diff
@@ -0,0 +1,11 @@
+--- orig/mysys/default.c Sun May 13 16:40:06 2001
++++ mysql-patched/mysys/default.c Sun May 13 16:40:17 2001
+@@ -48,7 +48,7 @@
+ #ifdef __WIN__
+ "C:/",
+ #else
+-"/etc/",
++"/etc/mysql/",
+ #endif
+ #ifdef DATADIR
+ DATADIR,
diff --git a/mysql-3.23-nisam.h.diff b/mysql-3.23-nisam.h.diff
new file mode 100644
index 0000000..8b44504
--- /dev/null
+++ b/mysql-3.23-nisam.h.diff
@@ -0,0 +1,11 @@
+--- include/nisam.h~ Tue Mar 27 10:11:02 2001
++++ include/nisam.h Fri Apr 13 16:26:02 2001
+@@ -31,7 +31,7 @@
+
+ #define N_MAXKEY 16 /* Max allowed keys */
+ #define N_MAXKEY_SEG 16 /* Max segments for key */
+-#define N_MAX_KEY_LENGTH 256 /* May be increased up to 500 */
++#define N_MAX_KEY_LENGTH 500 /* May be increased up to 500 */
+ #define N_MAX_KEY_BUFF (N_MAX_KEY_LENGTH+N_MAXKEY_SEG+sizeof(double)-1)
+ #define N_MAX_POSSIBLE_KEY_BUFF 500+9
+
diff --git a/mysql-3.23-safe-mysqld-sh.diff b/mysql-3.23-safe-mysqld-sh.diff
new file mode 100644
index 0000000..d47ef58
--- /dev/null
+++ b/mysql-3.23-safe-mysqld-sh.diff
@@ -0,0 +1,50 @@
+diff -ur mysql-3.23.47.orig/scripts/safe_mysqld.sh mysql-3.23.47/scripts/safe_mysqld.sh
+--- mysql-3.23.47.orig/scripts/safe_mysqld.sh Thu Dec 27 07:23:28 2001
++++ mysql-3.23.47/scripts/safe_mysqld.sh Fri Jan 4 05:08:08 2002
+@@ -68,42 +68,14 @@
+ done
+ }
+
+-MY_PWD=`pwd`
+-# Check if we are starting this relative (for the binary release)
+-if test -d $MY_PWD/data/mysql -a -f ./share/mysql/english/errmsg.sys -a \
+- -x ./bin/mysqld
+-then
+- MY_BASEDIR_VERSION=$MY_PWD # Where bin, share and data are
+- ledir=$MY_BASEDIR_VERSION/bin # Where mysqld is
+- DATADIR=$MY_BASEDIR_VERSION/data
+- if test -z "$defaults"
+- then
+- defaults="--defaults-extra-file=$MY_BASEDIR_VERSION/data/my.cnf"
+- fi
+-# Check if this is a 'moved install directory'
+-elif test -f ./var/mysql/db.frm -a -f ./share/mysql/english/errmsg.sys -a \
+- -x ./libexec/mysqld
+-then
+- MY_BASEDIR_VERSION=$MY_PWD # Where libexec, share and var are
+- ledir=$MY_BASEDIR_VERSION/libexec # Where mysqld is
+- DATADIR=$MY_BASEDIR_VERSION/var
+-else
+- MY_BASEDIR_VERSION=@prefix@
+- DATADIR=@localstatedir@
+- ledir=@libexecdir@
+-fi
++MY_BASEDIR_VERSION=@prefix@
++DATADIR=@localstatedir@
++ledir=@libexecdir@
+
+ MYSQL_UNIX_PORT=${MYSQL_UNIX_PORT:-@MYSQL_UNIX_ADDR@}
+ MYSQL_TCP_PORT=${MYSQL_TCP_PORT:-@MYSQL_TCP_PORT@}
+ user=@MYSQLD_USER@
+-
+-# Use the mysqld-max binary by default if the user doesn't specify a binary
+-if test -x $ledir/mysqld-max
+-then
+- MYSQLD=mysqld-max
+-else
+- MYSQLD=mysqld
+-fi
++MYSQLD=mysqld
+
+ # these rely on $DATADIR by default, so we'll set them later on
+ pid_file=
diff --git a/mysql-3.23.52-install-db-sh.diff b/mysql-3.23.52-install-db-sh.diff
new file mode 100644
index 0000000..6cbbaf1
--- /dev/null
+++ b/mysql-3.23.52-install-db-sh.diff
@@ -0,0 +1,35 @@
+diff -uNr mysql-3.23.52.orig/scripts/mysql_install_db.sh mysql-3.23.52/scripts/mysql_install_db.sh
+--- mysql-3.23.52.orig/scripts/mysql_install_db.sh Tue Aug 13 22:08:16 2002
++++ mysql-3.23.52/scripts/mysql_install_db.sh Sun Aug 25 04:11:09 2002
+@@ -309,14 +309,10 @@
+ END_OF_DATA
+ then
+ echo ""
+- if test "$IN_RPM" -eq 0
+- then
+- echo "To start mysqld at boot time you have to copy support-files/mysql.server"
+- echo "to the right place for your system"
+- echo
+ fi
+ echo "PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER !"
+ echo "This is done with:"
++ echo "/etc/init.d/mysql start (you have to start the server first!)"
+ echo "$bindir/mysqladmin -u root password 'new-password'"
+ echo "$bindir/mysqladmin -u root -h $hostname password 'new-password'"
+ echo "See the manual for more instructions."
+@@ -330,15 +326,6 @@
+ echo "able to use the new GRANT command!"
+ fi
+ echo
+- if test "$IN_RPM" -eq 0
+- then
+- echo "You can start the MySQL daemon with:"
+- echo "cd @prefix@ ; $bindir/safe_mysqld &"
+- echo
+- echo "You can test the MySQL daemon with the benchmarks in the 'sql-bench' directory:"
+- echo "cd sql-bench ; run-all-tests"
+- echo
+- fi
+ echo "Please report any problems with the @scriptdir@/mysqlbug script!"
+ echo
+ echo "The latest information about MySQL is available on the web at"
diff --git a/mysql-4.0-mysqlhotcopy-security.patch b/mysql-4.0-mysqlhotcopy-security.patch
new file mode 100644
index 0000000..f2f2e74
--- /dev/null
+++ b/mysql-4.0-mysqlhotcopy-security.patch
@@ -0,0 +1,48 @@
+--- 1.42/scripts/mysqlhotcopy.sh Tue May 25 21:00:12 2004
++++ 1.43/scripts/mysqlhotcopy.sh Fri Jul 9 14:30:48 2004
+@@ -8,5 +8,7 @@
+ use DBI;
+ use Sys::Hostname;
++use File::Copy;
++use File::Temp;
+
+ =head1 NAME
+
+@@ -626,7 +628,6 @@
+ sub copy_index
+ {
+ my ($method, $files, $source, $target) = @_;
+- my $tmpfile="$opt_tmpdir/mysqlhotcopy$$";
+
+ print "Copying indices for ".@$files." files...\n" unless $opt{quiet};
+ foreach my $file (@$files)
+@@ -652,21 +653,21 @@
+ }
+ close OUTPUT || die "Error on close of $to: $!\n";
+ }
+- elsif ($opt{method} eq 'scp')
++ elsif ($opt{method} =~ /^scp\b/)
+ {
+- my $tmp=$tmpfile;
+- open(OUTPUT,">$tmp") || die "Can\'t create file $tmp: $!\n";
+- if (syswrite(OUTPUT,$buff) != length($buff))
++ my ($fh, $tmp)=tempfile('mysqlhotcopy-XXXXXX', DIR => $opt_tmpdir);
++ die "Can\'t create/open file in $opt_tmpdir\n";
++ if (syswrite($fh,$buff) != length($buff))
+ {
+ die "Error when writing data to $tmp: $!\n";
+ }
+- close OUTPUT || die "Error on close of $tmp: $!\n";
+- safe_system("scp $tmp $to");
++ close $fh || die "Error on close of $tmp: $!\n";
++ safe_system("$opt{method} $tmp $to");
++ unlink $tmp;
+ }
+ else
+ {
+ die "Can't use unsupported method '$opt{method}'\n";
+ }
+ }
+- unlink "$tmpfile" if ($opt{method} eq 'scp');
+ }
+
diff --git a/mysql-4.0.15.rc6 b/mysql-4.0.15.rc6
new file mode 100644
index 0000000..be157f2
--- /dev/null
+++ b/mysql-4.0.15.rc6
@@ -0,0 +1,43 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/files/mysql-4.0.15.rc6,v 1.5 2004/09/07 04:03:24 robbat2 Exp $
+
+depend() {
+ use dns net
+}
+
+checkconfig() {
+ if [ ! -f /etc/mysql/my.cnf ]; then
+ eerror "No /etc/mysql/my.cnf file exists!"
+ fi
+
+ #dir=`my_print_defaults mysqld | grep -- '^--datadir' | tail -n1 | sed -e 's|^--datadir=||'`
+ dir=`my_print_defaults mysqld | sed -ne '/datadir/s|^--datadir=||p' | tail -n1`
+
+ if [ -z "$dir" ]; then
+ eerror "Your mysql doesn't have any datadir setting, default or specific"
+ eerror "Please check your my.cnf"
+ return 1
+ fi
+
+ if [ ! -d "$dir/mysql" ]; then
+ eerror "You don't appear to have the mysql database installed yet."
+ eerror "Please run /usr/bin/mysql_install_db to have this done..."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting mysqld"
+ start-stop-daemon --start --quiet --exec /usr/bin/mysqld_safe \
+ --background -- >/dev/null 2>&1
+ eend $?
+}
+
+stop () {
+ ebegin "Stopping mysqld"
+ start-stop-daemon --stop --retry 5 --quiet --pidfile=/var/run/mysqld/mysqld.pid
+ eend $?
+}
diff --git a/mysql-4.0.21-install-db-sh.diff b/mysql-4.0.21-install-db-sh.diff
new file mode 100644
index 0000000..8940e99
--- /dev/null
+++ b/mysql-4.0.21-install-db-sh.diff
@@ -0,0 +1,11 @@
+--- mysql-4.0.21/scripts/mysql_install_db.sh.orig
++++ mysql-4.0.21/scripts/mysql_install_db.sh
+@@ -371,6 +371,7 @@
+ echo "To do so, start the server, then issue the following commands:"
+- echo "$bindir/mysqladmin -u root password 'new-password'"
++ echo "/etc/init.d/mysql start (you have to start the server first!)"
+ echo "$bindir/mysqladmin -u root -h $hostname password 'new-password'"
++ echo "$bindir/mysqladmin -u root password 'new-password'"
+ echo "See the manual for more instructions."
+ #
+ # Print message about upgrading unless we have created a new db table.
diff --git a/mysql-4.0.24-manual.texi.patch b/mysql-4.0.24-manual.texi.patch
new file mode 100644
index 0000000..2789efb
--- /dev/null
+++ b/mysql-4.0.24-manual.texi.patch
@@ -0,0 +1,20 @@
+--- mysql-4.0.24.bbb/Docs/manual.texi 2005-03-11 22:49:27.000000000 +0100
++++ mysql-4.0.24/Docs/manual.texi 2005-03-11 22:57:56.000000000 +0100
+@@ -91349,7 +91349,7 @@
+
+ @c NOTE: To regenerate this list, run the make-errmsg-table.pl script.
+
+-@include errmsg-table.texi
++failed to include errmsg-table.texi
+
+ Client error information comes from the following files:
+
+@@ -91370,7 +91370,7 @@
+
+ @c NOTE: To regenerate this list, run the make-cl-errmsg-table.pl script.
+
+-@include cl-errmsg-table.texi
++failed to include cl-errmsg-table.texi
+
+
+ @node Extending MySQL, Problems, Error-handling, Top
diff --git a/mysql-4.0.24-r1.rc6 b/mysql-4.0.24-r1.rc6
new file mode 100644
index 0000000..4873370
--- /dev/null
+++ b/mysql-4.0.24-r1.rc6
@@ -0,0 +1,59 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/files/mysql-4.0.24-r1.rc6,v 1.2 2005/03/13 20:10:08 robbat2 Exp $
+
+depend() {
+ use dns net
+}
+
+
+getconfig() {
+ MY_CNF=${MY_CNF=/etc/mysql/my.cnf}
+ if [ ! -f ${MY_CNF} ]; then
+ eerror "No ${MY_CNF} file exists! Using automatic defaults!"
+ fi
+
+ #dir=`my_print_defaults mysqld | grep -- '^--datadir' | tail -n1 | sed -e 's|^--datadir=||'`
+ #dir=`my_print_defaults mysqld | sed -ne '/datadir/s|^--datadir=||p' | tail -n1`
+ local mysqld_cnf="`my_print_defaults --config-file=${MY_CNF} mysqld`"
+ datadir=`echo "${mysqld_cnf}" | sed -ne '/datadir/s|^--datadir=||p' | tail -n1`
+ pidfile=`echo "${mysqld_cnf}" | sed -ne '/pid-file/s|^--pid-file=||p' | tail -n1`
+
+ # push these out to the script
+ export MY_CNF
+ export pidfile
+ export datadir
+}
+
+checkconfig() {
+ getconfig
+ if [ -z "${datadir}" ]; then
+ eerror "Your mysql doesn't have any datadir setting, default or specific"
+ eerror "Please check your my.cnf : ${MY_CNF}"
+ return 1
+ fi
+
+ if [ ! -d "$datadir/mysql" ]; then
+ eerror "You don't appear to have the mysql database installed yet."
+ eerror "Please run /usr/bin/mysql_install_db to have this done..."
+ return 1
+ fi
+}
+
+start() {
+ getconfig
+ checkconfig || return 1
+ ebegin "Starting mysqld (${MY_CNF})"
+ start-stop-daemon --start --quiet --background \
+ --exec /usr/bin/mysqld_safe \
+ -- --defaults-file=${MY_CNF} >/dev/null 2>&1
+ eend $?
+}
+
+stop () {
+ getconfig
+ ebegin "Stopping mysqld (${MY_CNF})"
+ start-stop-daemon --stop --retry 5 --quiet --pidfile=${pidfile}
+ eend $?
+}
diff --git a/mysql-4.0.24-r2.rc6 b/mysql-4.0.24-r2.rc6
new file mode 100644
index 0000000..ec22177
--- /dev/null
+++ b/mysql-4.0.24-r2.rc6
@@ -0,0 +1,71 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/files/mysql-4.0.24-r2.rc6,v 1.1 2005/05/17 09:08:46 robbat2 Exp $
+
+depend() {
+ use dns net
+}
+
+getconfig() {
+ MY_CNF=${MY_CNF=/etc/mysql/my.cnf}
+ if [ ! -f ${MY_CNF} ]; then
+ eerror "No ${MY_CNF} file exists! Using automatic defaults!"
+ fi
+
+ #dir=`my_print_defaults mysqld | grep -- '^--datadir' | tail -n1 | sed -e 's|^--datadir=||'`
+ #dir=`my_print_defaults mysqld | sed -ne '/datadir/s|^--datadir=||p' | tail -n1`
+ local mysqld_cnf="`my_print_defaults --config-file=${MY_CNF} mysqld`"
+ datadir=`echo "${mysqld_cnf}" | sed -ne '/datadir/s|^--datadir=||p' | tail -n1`
+ pidfile=`echo "${mysqld_cnf}" | sed -ne '/pid-file/s|^--pid-file=||p' | tail -n1`
+ basedir=`echo "${mysqld_cnf}" | sed -ne '/basedir/s|^--basedir=||p' | tail -n1`
+ socket=`echo "${mysqld_cnf}" | sed -ne '/socket/s|^--socket=||p' | tail -n1`
+
+ # push these out to the script
+ export MY_CNF
+ export pidfile
+ export datadir
+ export basedir
+ export socket
+}
+
+checkconfig() {
+ getconfig
+ if [ -z "${datadir}" ]; then
+ eerror "Your mysql doesn't have any datadir setting, default or specific"
+ eerror "Please check your my.cnf : ${MY_CNF}"
+ return 1
+ fi
+
+ if [ ! -d "$datadir/mysql" ]; then
+ eerror "You don't appear to have the mysql database installed yet."
+ eerror "Please run /usr/bin/mysql_install_db to have this done..."
+ return 1
+ fi
+}
+
+start() {
+ local retstatus=1
+ local maxtry=5
+ getconfig
+ checkconfig || return 1
+ ebegin "Starting mysqld (${MY_CNF})"
+ start-stop-daemon --start --quiet --background \
+ --exec "${basedir}/bin/mysqld_safe" \
+ -- --defaults-file=${MY_CNF} >/dev/null 2>&1
+ retstatus=$?
+ while ! [[ -S "${socket}" || "${maxtry}" -lt "1" || "${retstatus}" -gt "0" ]] ; do
+ maxtry=$(($maxtry-1))
+ echo -n "."
+ sleep 1
+ done
+ ! [[ -S "${socket}" ]] && eerror "MySQL NOT started, proceding anyway"
+ eend $retstatus
+}
+
+stop () {
+ getconfig
+ ebegin "Stopping mysqld (${MY_CNF})"
+ start-stop-daemon --stop --retry 5 --quiet --pidfile=${pidfile}
+ eend $?
+}
diff --git a/mysql-4.1.9-thrssl.patch b/mysql-4.1.9-thrssl.patch
new file mode 100644
index 0000000..d50325e
--- /dev/null
+++ b/mysql-4.1.9-thrssl.patch
@@ -0,0 +1,22 @@
+--- mysql-4.1.10.orig/libmysql_r/Makefile.in 2005-02-12 21:38:04.000000000 +0100
++++ mysql-4.1.10/libmysql_r/Makefile.in 2005-02-19 01:41:11.000000000 +0100
+@@ -242,7 +242,7 @@
+ LIBDL = @LIBDL@
+ LIBEDIT_LOBJECTS = @LIBEDIT_LOBJECTS@
+ LIBOBJS = @LIBOBJS@
+-LIBS = @LIBS@ @ZLIB_LIBS@ @openssl_libs@
++LIBS = @CLIENT_LIBS@ @ZLIB_LIBS@ @openssl_libs@ @LIBS@
+ LIBTOOL = @LIBTOOL@
+ LIB_EXTRA_CCFLAGS = @LIB_EXTRA_CCFLAGS@
+ LM_CFLAGS = @LM_CFLAGS@
+--- mysql-4.1.10.orig/libmysql_r/Makefile.am 2005-02-12 21:37:33.000000000 +0100
++++ mysql-4.1.10/libmysql_r/Makefile.am 2005-02-19 01:43:49.000000000 +0100
+@@ -22,7 +22,7 @@
+
+ target = libmysqlclient_r.la
+ target_defs = -DDONT_USE_RAID -DMYSQL_CLIENT @LIB_EXTRA_CCFLAGS@
+-LIBS = @LIBS@ @ZLIB_LIBS@ @openssl_libs@
++LIBS = @CLIENT_LIBS@ @ZLIB_LIBS@ @openssl_libs@ @LIBS@
+
+ INCLUDES = @MT_INCLUDES@ \
+ -I$(top_srcdir)/include $(openssl_includes) @ZLIB_INCLUDES@
diff --git a/mysql-accesstmp.patch b/mysql-accesstmp.patch
new file mode 100644
index 0000000..700084e
--- /dev/null
+++ b/mysql-accesstmp.patch
@@ -0,0 +1,90 @@
+--- mysql-4.1.8/scripts/mysqlaccess.sh 2004-12-14 13:40:36.000000000 +0100
++++ mysql-4.1.8.bug77805/scripts/mysqlaccess.sh 2005-01-18 00:48:07.692271624 +0100
+@@ -2,7 +2,7 @@
+ # ****************************
+ package MySQLaccess;
+ #use strict;
+-use POSIX qw(tmpnam);
++use File::Temp qw(tempfile tmpnam);
+ use Fcntl;
+
+ BEGIN {
+@@ -32,7 +32,6 @@
+ $ACCESS_U_BCK = 'user_backup';
+ $ACCESS_D_BCK = 'db_backup';
+ $DIFF = '/usr/bin/diff';
+- $TMP_PATH = '/tmp'; #path to writable tmp-directory
+ $MYSQLDUMP = '@bindir@/mysqldump';
+ #path to mysqldump executable
+
+@@ -431,7 +430,7 @@
+ # no caching on STDOUT
+ $|=1;
+
+- $MYSQL_CNF = POSIX::tmpnam();
++ $MYSQL_CNF = tmpnam();
+ %MYSQL_CNF = (client => { },
+ mysql => { },
+ mysqldump => { },
+@@ -576,8 +575,6 @@
+ push(@MySQLaccess::Grant::Error,'not_found_mysql') if !(-x $MYSQL);
+ push(@MySQLaccess::Grant::Error,'not_found_diff') if !(-x $DIFF);
+ push(@MySQLaccess::Grant::Error,'not_found_mysqldump') if !(-x $MYSQLDUMP);
+-push(@MySQLaccess::Grant::Error,'not_found_tmp') if !(-d $TMP_PATH);
+-push(@MySQLaccess::Grant::Error,'write_err_tmp') if !(-w $TMP_PATH);
+ if (@MySQLaccess::Grant::Error) {
+ MySQLaccess::Report::Print_Error_Messages() ;
+ exit 0;
+@@ -1776,17 +1773,15 @@
+ @before = sort(@before);
+ @after = sort(@after);
+
+- $before = "$MySQLaccess::TMP_PATH/$MySQLaccess::script.before.$$";
+- $after = "$MySQLaccess::TMP_PATH/$MySQLaccess::script.after.$$";
+- #$after = "/tmp/t0";
+- open(BEFORE,"> $before") ||
+- push(@MySQLaccess::Report::Errors,"Can't open temporary file $before for writing");
+- open(AFTER,"> $after") ||
+- push(@MySQLaccess::Report::Errors,"Can't open temporary file $after for writing");
+- print BEFORE join("\n",@before);
+- print AFTER join("\n",@after);
+- close(BEFORE);
+- close(AFTER);
++ ($hb, $before) = tempfile("$MySQLaccess::script.XXXXXX") or
++ push(@MySQLaccess::Report::Errors,"Can't create temporary file: $!");
++ ($ha, $after) = tempfile("$MySQLaccess::script.XXXXXX") or
++ push(@MySQLaccess::Report::Errors,"Can't create temporary file: $!");
++
++ print $hb join("\n",@before);
++ print $ha join("\n",@after);
++ close $hb;
++ close $ha;
+
+ # ----------------------------------
+ # compute difference
+@@ -1799,8 +1794,8 @@
+
+ # ----------------------------------
+ # cleanup temp. files
+- unlink(BEFORE);
+- unlink(AFTER);
++ unlink($before);
++ unlink($after);
+
+ return \@diffs;
+ }
+@@ -2315,14 +2310,6 @@
+ => "The diff program <$MySQLaccess::DIFF> could not be found.\n"
+ ."+ Check your path, or\n"
+ ."+ edit the source of this script to point \$DIFF to the diff program.\n"
+- ,'not_found_tmp'
+- => "The temporary directory <$MySQLaccess::TMP_PATH> could not be found.\n"
+- ."+ create this directory (writeable!), or\n"
+- ."+ edit the source of this script to point \$TMP_PATH to the right directory.\n"
+- ,'write_err_tmp'
+- => "The temporary directory <$MySQLaccess::TMP_PATH> is not writable.\n"
+- ."+ make this directory writeable!, or\n"
+- ."+ edit the source of this script to point \$TMP_PATH to another directory.\n"
+ ,'Unrecognized_option'
+ => "Sorry,\n"
+ ."You are using an old version of the mysql-program,\n"
diff --git a/mysql-test-myisam-geometry.patch b/mysql-test-myisam-geometry.patch
new file mode 100644
index 0000000..54a4a93
--- /dev/null
+++ b/mysql-test-myisam-geometry.patch
@@ -0,0 +1,22 @@
+--- mysql.orig/mysql-test/t/myisam.test 2005-03-27 16:07:37.000000000 +0200
++++ mysql/mysql-test/t/myisam.test 2005-03-27 16:17:33.000000000 +0200
+@@ -476,7 +476,7 @@
+ #
+ # Test RTREE index
+ #
+---error 1235
++--error 1289
+ CREATE TABLE t1 (`a` int(11) NOT NULL default '0', `b` int(11) NOT NULL default '0', UNIQUE KEY `a` USING RTREE (`a`,`b`)) ENGINE=MyISAM;
+ # INSERT INTO t1 VALUES (1,1),(1,1);
+ # DELETE FROM rt WHERE a<1;
+--- mysql.orig/mysql-test/r/myisam.result 2005-03-27 16:08:20.000000000 +0200
++++ mysql/mysql-test/r/myisam.result 2005-03-27 16:12:18.000000000 +0200
+@@ -499,7 +499,7 @@
+ 1 SIMPLE t2 index NULL PRIMARY 4 NULL 2 Using index; Distinct
+ drop table t1,t2;
+ CREATE TABLE t1 (`a` int(11) NOT NULL default '0', `b` int(11) NOT NULL default '0', UNIQUE KEY `a` USING RTREE (`a`,`b`)) ENGINE=MyISAM;
+-ERROR 42000: This version of MySQL doesn't yet support 'RTREE INDEX'
++ERROR HY000: The 'RTree keys' feature is disabled; you need MySQL built with 'HAVE_RTREE_KEYS' to have it working
+ create table t1 (a int, b varchar(200), c text not null) checksum=1;
+ create table t2 (a int, b varchar(200), c text not null) checksum=0;
+ insert t1 values (1, "aaa", "bbb"), (NULL, "", "ccccc"), (0, NULL, "");