summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@tuffmail.com>2014-03-04 09:30:05 -0500
committerBrian Evans <grknight@tuffmail.com>2014-03-04 10:33:01 -0500
commit2c174fd98adb34416ccfdfa5e91c754dee20c7bc (patch)
tree776ac7c17cd06169bca4a6a1b03eb2d6acf7c866
parentRemove Werror from mysql and percona-server cmake (diff)
downloadmysql-extras-2c174fd98adb34416ccfdfa5e91c754dee20c7bc.tar.gz
mysql-extras-2c174fd98adb34416ccfdfa5e91c754dee20c7bc.tar.bz2
mysql-extras-2c174fd98adb34416ccfdfa5e91c754dee20c7bc.zip
Add static libs install based on condition
-rw-r--r--00000_index.txt9
-rw-r--r--20006_all_cmake_elib-mariadb-5.5.33.patch32
-rw-r--r--20006_all_cmake_elib-mysql-5.5.35.patch35
-rw-r--r--20006_all_cmake_elib-mysql-5.6.15.patch41
-rw-r--r--20006_all_cmake_elib-percona-5.5.35.patch37
-rw-r--r--20006_all_cmake_elib-percona-5.6.15.patch41
6 files changed, 177 insertions, 18 deletions
diff --git a/00000_index.txt b/00000_index.txt
index 719a590..359a77c 100644
--- a/00000_index.txt
+++ b/00000_index.txt
@@ -1562,36 +1562,43 @@
@ver 5.05.32.00 to 5.05.32.99
@pn mariadb
@@ Add ELIBPATH to split client and embedded libs
+@@ Also install static libs by ENABLE_STATIC_LIBS
@patch 20006_all_cmake_elib-mariadb-5.5.33.patch
@ver 5.05.33.00 to 5.05.99.99
@pn mariadb
@@ Add ELIBPATH to split client and embedded libs
+@@ Also install static libs by ENABLE_STATIC_LIBS
@patch 20006_all_cmake_elib-mysql-5.5.35.patch
@ver 5.05.35.00 to 5.05.99.99
@pn mysql
@@ Add ELIBPATH to split client and embedded libs
+@@ Also install static libs by ENABLE_STATIC_LIBS
@patch 20006_all_cmake_elib-mysql-5.6.15.patch
-@ver 5.06.15.00 to 5.05.99.99
+@ver 5.06.15.00 to 5.06.99.99
@pn mysql
@@ Add ELIBPATH to split client and embedded libs
+@@ Also install static libs by ENABLE_STATIC_LIBS
@patch 20006_all_cmake_elib-percona-5.5.35.patch
@ver 5.05.35.00 to 5.05.99.99
@pn percona-server
@@ Add ELIBPATH to split client and embedded libs
+@@ Also install static libs by ENABLE_STATIC_LIBS
@patch 20006_all_cmake_elib-percona-5.6.15.patch
@ver 5.06.15.00 to 5.06.99.99
@pn percona-server
@@ Add ELIBPATH to split client and embedded libs
+@@ Also install static libs by ENABLE_STATIC_LIBS
@patch 20006_all_cmake_elib-mariadb-10.0.7.patch
@ver 10.00.07.00 to 10.00.99.99
@pn mariadb
@@ Add ELIBPATH to split client and embedded libs
+@@ Also install static libs by ENABLE_STATIC_LIBS
@patch 20007_all_cmake-debug-werror.patch
@ver 5.05.32.00 to 5.05.99.99
diff --git a/20006_all_cmake_elib-mariadb-5.5.33.patch b/20006_all_cmake_elib-mariadb-5.5.33.patch
index fbb51a7..516abbd 100644
--- a/20006_all_cmake_elib-mariadb-5.5.33.patch
+++ b/20006_all_cmake_elib-mariadb-5.5.33.patch
@@ -88,15 +88,33 @@ diff -ur mysql-old/cmake/libutils.cmake mysql/cmake/libutils.cmake
diff -ur mysql-old/libmysql/CMakeLists.txt mysql/libmysql/CMakeLists.txt
--- mysql-old/libmysql/CMakeLists.txt 2014-01-18 22:28:40.429273470 -0100
+++ mysql/libmysql/CMakeLists.txt 2014-01-18 22:28:53.025273949 -0100
-@@ -329,7 +329,7 @@
+@@ -327,9 +327,14 @@
+ SET(LIBS clientlib dbug strings vio mysys ${ZLIB_LIBRARY} ${SSL_LIBRARIES} ${LIBDL})
+
++SET(INSTALL_STATIC_LIBS "")
++IF(NOT ENABLE_STATIC_LIBS)
++ SET(INSTALL_STATIC_LIBS "NOINSTALL")
++ENDIF()
++
# Merge several convenience libraries into one big mysqlclient
# and link them together into shared library.
-MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development)
-+MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development OUTPUT_DIR ${INSTALL_LIBDIR})
++MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development OUTPUT_DIR ${INSTALL_LIBDIR} ${INSTALL_STATIC_LIBS})
# Visual Studio users need debug static library for debug projects
IF(MSVC)
+@@ -350,7 +355,9 @@
+ SET(${OUTNAME} ${LIBNAME}${EXTENSION}${DOT_VERSION})
+ ENDIF()
+ ENDMACRO()
+- INSTALL_SYMLINK(${CMAKE_STATIC_LIBRARY_PREFIX}mysqlclient_r.a mysqlclient ${INSTALL_LIBDIR} Development)
++ IF(ENABLE_STATIC_LIBS)
++ INSTALL_SYMLINK(${CMAKE_STATIC_LIBRARY_PREFIX}mysqlclient_r.a mysqlclient ${INSTALL_LIBDIR} Development)
++ ENDIF()
+ ENDIF()
+
+ IF(NOT DISABLE_SHARED)
diff -ur mysql-old/libmysqld/CMakeLists.txt mysql/libmysqld/CMakeLists.txt
--- mysql-old/libmysqld/CMakeLists.txt 2014-01-18 22:28:40.090273457 -0100
+++ mysql/libmysqld/CMakeLists.txt 2014-01-18 22:28:53.025273949 -0100
@@ -127,3 +145,13 @@ diff -ur mysql-old/libmysqld/CMakeLists.txt mysql/libmysqld/CMakeLists.txt
IF(UNIX)
# Name the shared library, handle versioning (provides same api as client
# library hence the same version)
+--- mysql-old/libservices/CMakeLists.txt 2014-02-06 14:35:25.162325748 -0500
++++ mysql/libservices/CMakeLists.txt 2014-02-06 14:36:20.051137978 -0500
+@@ -26,4 +26,6 @@
+ logger_service.c)
+
+ ADD_CONVENIENCE_LIBRARY(mysqlservices ${MYSQLSERVICES_SOURCES})
+-INSTALL(TARGETS mysqlservices DESTINATION ${INSTALL_LIBDIR} COMPONENT Development)
++IF(ENABLE_STATIC_LIBS)
++ INSTALL(TARGETS mysqlservices DESTINATION ${INSTALL_LIBDIR} COMPONENT Development)
++ENDIF()
diff --git a/20006_all_cmake_elib-mysql-5.5.35.patch b/20006_all_cmake_elib-mysql-5.5.35.patch
index 0f332e8..9d478cc 100644
--- a/20006_all_cmake_elib-mysql-5.5.35.patch
+++ b/20006_all_cmake_elib-mysql-5.5.35.patch
@@ -93,15 +93,33 @@ diff -ur mysql-old/cmake/libutils.cmake mysql/cmake/libutils.cmake
diff -ur mysql-old/libmysql/CMakeLists.txt mysql/libmysql/CMakeLists.txt
--- mysql-old/libmysql/CMakeLists.txt 2014-01-20 00:14:06.580799638 -0100
+++ mysql/libmysql/CMakeLists.txt 2014-01-20 00:15:27.647802721 -0100
-@@ -165,7 +165,7 @@
-
+@@ -163,9 +163,14 @@
+
+ SET(LIBS clientlib dbug strings vio mysys ${ZLIB_LIBRARY} ${SSL_LIBRARIES} ${LIBDL})
+
++SET(INSTALL_STATIC_LIBS "")
++IF(NOT ENABLE_STATIC_LIBS)
++ SET(INSTALL_STATIC_LIBS "NOINSTALL")
++ENDIF()
++
# Merge several convenience libraries into one big mysqlclient
# and link them together into shared library.
-MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development)
-+MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development OUTPUT_DIR ${INSTALL_LIBDIR})
++MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development OUTPUT_DIR ${INSTALL_LIBDIR} ${INSTALL_STATIC_LIBS})
# Visual Studio users need debug static library for debug projects
INSTALL_DEBUG_SYMBOLS(clientlib)
+@@ -350,7 +355,9 @@
+ SET(${OUTNAME} ${LIBNAME}${EXTENSION}${DOT_VERSION})
+ ENDIF()
+ ENDMACRO()
+- INSTALL_SYMLINK(${CMAKE_STATIC_LIBRARY_PREFIX}mysqlclient_r.a mysqlclient ${INSTALL_LIBDIR} Development)
++ IF(ENABLE_STATIC_LIBS)
++ INSTALL_SYMLINK(${CMAKE_STATIC_LIBRARY_PREFIX}mysqlclient_r.a mysqlclient ${INSTALL_LIBDIR} Development)
++ ENDIF()
+ ENDIF()
+
+ IF(NOT DISABLE_SHARED)
diff -ur mysql-old/libmysqld/CMakeLists.txt mysql/libmysqld/CMakeLists.txt
--- mysql-old/libmysqld/CMakeLists.txt 2014-01-20 00:14:06.453799634 -0100
+++ mysql/libmysqld/CMakeLists.txt 2014-01-20 00:25:46.375826250 -0100
@@ -131,3 +149,14 @@ diff -ur mysql-old/libmysqld/CMakeLists.txt mysql/libmysqld/CMakeLists.txt
IF(UNIX)
# Name the shared library, handle versioning (provides same api as client library
# hence the same version)
+--- mysql-old/libservices/CMakeLists.txt 2014-02-06 14:35:25.162325748 -0500
++++ mysql/libservices/CMakeLists.txt 2014-02-06 14:36:20.051137978 -0500
+@@ -26,4 +26,6 @@
+ my_thread_scheduler_service.c)
+
+ ADD_LIBRARY(mysqlservices ${MYSQLSERVICES_SOURCES})
+-INSTALL(TARGETS mysqlservices DESTINATION ${INSTALL_LIBDIR} COMPONENT Development)
++IF(ENABLE_STATIC_LIBS)
++ INSTALL(TARGETS mysqlservices DESTINATION ${INSTALL_LIBDIR} COMPONENT Development)
++ENDIF()
+
diff --git a/20006_all_cmake_elib-mysql-5.6.15.patch b/20006_all_cmake_elib-mysql-5.6.15.patch
index 5dd5f0c..735cfa8 100644
--- a/20006_all_cmake_elib-mysql-5.6.15.patch
+++ b/20006_all_cmake_elib-mysql-5.6.15.patch
@@ -93,14 +93,36 @@ diff -ur mysql-old/cmake/libutils.cmake mysql/cmake/libutils.cmake
diff -ur mysql-old/libmysql/CMakeLists.txt mysql/libmysql/CMakeLists.txt
--- mysql-old/libmysql/CMakeLists.txt 2014-01-20 00:14:06.580799638 -0100
+++ mysql/libmysql/CMakeLists.txt 2014-01-20 00:15:27.647802721 -0100
-@@ -165,6 +165,6 @@
-
+@@ -179,8 +179,13 @@
+ LIST(APPEND LIBS auth_win_client)
+ ENDIF()
+
++SET(INSTALL_STATIC_LIBS "")
++IF(NOT ENABLE_STATIC_LIBS)
++ SET(INSTALL_STATIC_LIBS "NOINSTALL")
++ENDIF()
++
# Merge several convenience libraries into one big mysqlclient
-MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development)
-+MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development OUTPUT_DIR ${INSTALL_LIBDIR})
-
++MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development OUTPUT_DIR ${INSTALL_LIBDIR} ${INSTALL_STATIC_LIBS})
+
# Visual Studio users need debug static library for debug projects
INSTALL_DEBUG_SYMBOLS(clientlib)
+@@ -211,9 +216,11 @@
+
+ IF(UNIX)
+ GET_TARGET_NAME(mysqlclient lib_name)
+- INSTALL_SYMLINK(mysqlclient
+- ${lib_name} ${CMAKE_STATIC_LIBRARY_PREFIX}mysqlclient_r.a
+- ${INSTALL_LIBDIR} Development)
++ IF(ENABLE_STATIC_LIBS)
++ INSTALL_SYMLINK(mysqlclient
++ ${lib_name} ${CMAKE_STATIC_LIBRARY_PREFIX}mysqlclient_r.a
++ ${INSTALL_LIBDIR} Development)
++ ENDIF()
+ ENDIF()
+
+ IF(NOT DISABLE_SHARED)
diff -ur mysql-old/libmysqld/CMakeLists.txt mysql/libmysqld/CMakeLists.txt
--- mysql-old/libmysqld/CMakeLists.txt 2014-01-20 00:14:06.453799634 -0100
+++ mysql/libmysqld/CMakeLists.txt 2014-01-20 00:25:46.375826250 -0100
@@ -130,3 +152,14 @@ diff -ur mysql-old/libmysqld/CMakeLists.txt mysql/libmysqld/CMakeLists.txt
IF(UNIX)
# Name the shared library, handle versioning (provides same api as client library
# hence the same version)
+--- mysql-old/libservices/CMakeLists.txt 2014-02-06 14:35:25.162325748 -0500
++++ mysql/libservices/CMakeLists.txt 2014-02-06 14:36:20.051137978 -0500
+@@ -26,4 +26,6 @@
+ my_thread_scheduler_service.c)
+
+ ADD_LIBRARY(mysqlservices ${MYSQLSERVICES_SOURCES})
+-INSTALL(TARGETS mysqlservices DESTINATION ${INSTALL_LIBDIR} COMPONENT Development)
++IF(ENABLE_STATIC_LIBS)
++ INSTALL(TARGETS mysqlservices DESTINATION ${INSTALL_LIBDIR} COMPONENT Development)
++ENDIF()
+
diff --git a/20006_all_cmake_elib-percona-5.5.35.patch b/20006_all_cmake_elib-percona-5.5.35.patch
index 8662c5e..65f53a5 100644
--- a/20006_all_cmake_elib-percona-5.5.35.patch
+++ b/20006_all_cmake_elib-percona-5.5.35.patch
@@ -93,15 +93,33 @@ diff -ur mysql-old/cmake/libutils.cmake mysql/cmake/libutils.cmake
diff -ur mysql-old/libmysql/CMakeLists.txt mysql/libmysql/CMakeLists.txt
--- mysql-old/libmysql/CMakeLists.txt 2014-01-20 00:14:06.580799638 -0100
+++ mysql/libmysql/CMakeLists.txt 2014-01-20 00:15:27.647802721 -0100
-@@ -165,7 +165,7 @@
-
+@@ -163,9 +163,14 @@
+
+ SET(LIBS clientlib dbug strings vio mysys ${ZLIB_LIBRARY} ${SSL_LIBRARIES} ${LIBDL})
+
++SET(INSTALL_STATIC_LIBS "")
++IF(NOT ENABLE_STATIC_LIBS)
++ SET(INSTALL_STATIC_LIBS "NOINSTALL")
++ENDIF()
++
# Merge several convenience libraries into one big mysqlclient
# and link them together into shared library.
-MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development)
-+MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development OUTPUT_DIR ${INSTALL_LIBDIR})
-
++MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development OUTPUT_DIR ${INSTALL_LIBDIR} ${INSTALL_STATIC_LIBS})
+
# Visual Studio users need debug static library for debug projects
INSTALL_DEBUG_SYMBOLS(clientlib)
+@@ -350,7 +355,9 @@
+ SET(${OUTNAME} ${LIBNAME}${EXTENSION}${DOT_VERSION})
+ ENDIF()
+ ENDMACRO()
+- INSTALL_SYMLINK(${CMAKE_STATIC_LIBRARY_PREFIX}mysqlclient_r.a mysqlclient ${INSTALL_LIBDIR} Development)
++ IF(ENABLE_STATIC_LIBS)
++ INSTALL_SYMLINK(${CMAKE_STATIC_LIBRARY_PREFIX}mysqlclient_r.a mysqlclient ${INSTALL_LIBDIR} Development)
++ ENDIF()
+ ENDIF()
+
+ IF(NOT DISABLE_SHARED)
diff -ur mysql-old/libmysqld/CMakeLists.txt mysql/libmysqld/CMakeLists.txt
--- mysql-old/libmysqld/CMakeLists.txt 2014-01-20 00:14:06.453799634 -0100
+++ mysql/libmysqld/CMakeLists.txt 2014-01-20 00:25:46.375826250 -0100
@@ -131,3 +149,14 @@ diff -ur mysql-old/libmysqld/CMakeLists.txt mysql/libmysqld/CMakeLists.txt
IF(UNIX)
# Name the shared library, handle versioning (provides same api as client library
# hence the same version)
+--- mysql-old/libservices/CMakeLists.txt 2014-02-06 14:35:25.162325748 -0500
++++ mysql/libservices/CMakeLists.txt 2014-02-06 14:36:20.051137978 -0500
+@@ -26,4 +26,6 @@
+ my_thread_scheduler_service.c)
+
+ ADD_LIBRARY(mysqlservices ${MYSQLSERVICES_SOURCES})
+-INSTALL(TARGETS mysqlservices DESTINATION ${INSTALL_LIBDIR} COMPONENT Development)
++IF(ENABLE_STATIC_LIBS)
++ INSTALL(TARGETS mysqlservices DESTINATION ${INSTALL_LIBDIR} COMPONENT Development)
++ENDIF()
+
diff --git a/20006_all_cmake_elib-percona-5.6.15.patch b/20006_all_cmake_elib-percona-5.6.15.patch
index cb37a3a..69987af 100644
--- a/20006_all_cmake_elib-percona-5.6.15.patch
+++ b/20006_all_cmake_elib-percona-5.6.15.patch
@@ -93,14 +93,36 @@ diff -ur mysql-old/cmake/libutils.cmake mysql/cmake/libutils.cmake
diff -ur mysql-old/libmysql/CMakeLists.txt mysql/libmysql/CMakeLists.txt
--- mysql-old/libmysql/CMakeLists.txt 2014-01-20 00:14:06.580799638 -0100
+++ mysql/libmysql/CMakeLists.txt 2014-01-20 00:15:27.647802721 -0100
-@@ -165,6 +165,6 @@
-
+@@ -179,8 +179,13 @@
+ LIST(APPEND LIBS auth_win_client)
+ ENDIF()
+
++SET(INSTALL_STATIC_LIBS "")
++IF(NOT ENABLE_STATIC_LIBS)
++ SET(INSTALL_STATIC_LIBS "NOINSTALL")
++ENDIF()
++
# Merge several convenience libraries into one big mysqlclient
-MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development)
-+MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development OUTPUT_DIR ${INSTALL_LIBDIR})
-
++MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development OUTPUT_DIR ${INSTALL_LIBDIR} ${INSTALL_STATIC_LIBS})
+
# Visual Studio users need debug static library for debug projects
INSTALL_DEBUG_SYMBOLS(clientlib)
+@@ -211,9 +216,11 @@
+
+ IF(UNIX)
+ GET_TARGET_NAME(mysqlclient lib_name)
+- INSTALL_SYMLINK(mysqlclient
+- ${lib_name} ${CMAKE_STATIC_LIBRARY_PREFIX}mysqlclient_r.a
+- ${INSTALL_LIBDIR} Development)
++ IF(ENABLE_STATIC_LIBS)
++ INSTALL_SYMLINK(mysqlclient
++ ${lib_name} ${CMAKE_STATIC_LIBRARY_PREFIX}mysqlclient_r.a
++ ${INSTALL_LIBDIR} Development)
++ ENDIF()
+ ENDIF()
+
+ IF(NOT DISABLE_SHARED)
diff -ur mysql-old/libmysqld/CMakeLists.txt mysql/libmysqld/CMakeLists.txt
--- mysql-old/libmysqld/CMakeLists.txt 2014-01-20 00:14:06.453799634 -0100
+++ mysql/libmysqld/CMakeLists.txt 2014-01-20 00:25:46.375826250 -0100
@@ -130,3 +152,14 @@ diff -ur mysql-old/libmysqld/CMakeLists.txt mysql/libmysqld/CMakeLists.txt
IF(UNIX)
# Name the shared library, handle versioning (provides same api as client library
# hence the same version)
+--- mysql-old/libservices/CMakeLists.txt 2014-02-06 14:35:25.162325748 -0500
++++ mysql/libservices/CMakeLists.txt 2014-02-06 14:36:20.051137978 -0500
+@@ -26,4 +26,6 @@
+ my_thread_scheduler_service.c)
+
+ ADD_LIBRARY(mysqlservices ${MYSQLSERVICES_SOURCES})
+-INSTALL(TARGETS mysqlservices DESTINATION ${INSTALL_LIBDIR} COMPONENT Development)
++IF(ENABLE_STATIC_LIBS)
++ INSTALL(TARGETS mysqlservices DESTINATION ${INSTALL_LIBDIR} COMPONENT Development)
++ENDIF()
+